Automatisation Clim

Mon problème

Bonjour, Je débute avec HA et je souhaite faire une automatisation avec ma clim. Je souhaite la démarrer lorsque le solaire et dispo. Cela fonctionne bien mais j’aimerais bien régler la temperature de la clim . Je ne vois pas ou mettre se parametre…?

action:
  - device_id: ed054d1710129909e910b3a140277a4d
    domain: climate
    entity_id: climate.elsa
    type: set_hvac_mode
    hvac_mode: heat

Ma configuration


System Information

version core-2023.4.5
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.10.10
os_name Linux
os_version 6.1.24
arch x86_64
timezone Europe/Paris
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.31.0
Stage running
Available Repositories 1271
Downloaded Repositories 13
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 10.0
update_channel stable
supervisor_version supervisor-2023.04.0
agent_version 1.5.1
docker_version 23.0.3
disk_total 30.8 GB
disk_used 6.2 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons Terminal & SSH (9.6.2), File editor (5.5.0), ESPHome (2023.4.0), Duck DNS (1.15.0), Node-RED (14.1.4), Mosquitto broker (6.2.0)
Dashboards
dashboards 1
resources 4
views 1
mode storage
Recorder
oldest_recorder_run 18 avril 2023 à 15:27
current_recorder_run 19 avril 2023 à 15:12
estimated_db_size 112.22 MiB
database_engine sqlite
database_version 3.38.5
___

Bonjour,

peut-être en allant lire la doc officielle ? https://www.home-assistant.io/integrations/climate/

Il y a notamment cet exemple :

### Set temperature to 24 in heat mode
automation:
  trigger:
    platform: time
    at: "07:15:00"
  action:
    - service: climate.set_temperature
      target:
        entity_id: climate.kitchen
      data:
        temperature: 24
        hvac_mode: heat

Exact. désolez je n’avais pas était voir la doc! Merci a toi je test ca!!

Je reviens vers toi car j’ai bien progressé mais il me manque encore quelque chose!
Avec cette automatisation la température désiré ne fonctionne pas. La pac reprend la dernière température rentrée!
Peut tu me dire ce qui ne va pas?

alias: "Chauffage Étage "
description: Chauffage Auto Solaire Etage
trigger:
  - type: temperature
    platform: device
    device_id: 466943d6c7e83223b810751471e8f661
    entity_id: 9e9573e988e80deb4d280e0d3f613a17
    domain: sensor
    below: 18.8
  - platform: device
    device_id: e31268a6332e7c127d15d405e036d8e8
    domain: alarm_control_panel
    entity_id: 3b7ae17dd2972338e3ac1ab3e40085e4
    type: disarmed
condition:
  - condition: device
    device_id: e31268a6332e7c127d15d405e036d8e8
    domain: alarm_control_panel
    entity_id: 3b7ae17dd2972338e3ac1ab3e40085e4
    type: is_disarmed
  - type: is_temperature
    condition: device
    device_id: 466943d6c7e83223b810751471e8f661
    entity_id: 9e9573e988e80deb4d280e0d3f613a17
    domain: sensor
    below: 18.8
action:
  - service: climate.set_temperature
    data:
      temperature: 20
    target:
      device_id: ed054d1710129909e910b3a140277a4d
  - device_id: ed054d1710129909e910b3a140277a4d
    domain: climate
    entity_id: 16aebfb2a6d8d3fb0797b46805d30852
    type: set_hvac_mode
    hvac_mode: heat
  - service: climate.set_temperature
    data:
      temperature: 19
    target:
      device_id: aced67ef7868ecb193ee9c9c01382cbb
  - device_id: aced67ef7868ecb193ee9c9c01382cbb
    domain: climate
    entity_id: 1723ce688c2b9192aca5822a05474e2e
    type: set_hvac_mode
    hvac_mode: heat
  - service: climate.set_fan_mode
    data:
      fan_mode: LOW
    target:
      device_id:
        - ed054d1710129909e910b3a140277a4d
        - aced67ef7868ecb193ee9c9c01382cbb
    enabled: false
mode: single

Bonjour,
J’ai finalement mit un délais de 1 min entre chaque execution et cela fonctionne. Je penses que les action les unes a la suites ne passé pas.
:wink: