Connexion esp32

Mon problème

Bonjour,

Je me suis lancé dans la découverte d’un esp et et j’ai voulu l’intégrer à HA.

J’ai flashé un esp32 via le module complémentaire en branchant mon esp sur un port ubs de mon raspberry et il est bien indiqué en online. J’ai aussi configuré le dashboard où tout semble bien connecté. Je le vois aussi connecté à ma livebox

Cependant dès que je le connecte ailleurs que sur le raspberry en usb sur une prise même si il s’allume il ne se connecte plus à mon wifi j’avais bien fixé l’ip mais rien y fait je ne sais pas quoi faire

On dirait qu’il ne connecte plus si il n’est plus branché au raspberry

Ma configuration


System Information

version core-2024.3.0
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.12.2
os_name Linux
os_version 6.1.73-haos-raspi
arch aarch64
timezone Europe/Paris
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.34.0
Stage running
Available Repositories 1422
Downloaded Repositories 53
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 12.1
update_channel stable
supervisor_version supervisor-2024.03.0
agent_version 1.6.0
docker_version 24.0.7
disk_total 219.4 GB
disk_used 9.7 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons File editor (5.8.0), Terminal & SSH (9.10.0), Mosquitto broker (6.4.0), Duck DNS (1.15.0), MyElectricalData (0.12.0), ZigStar TI CC2652P/P7 FW Flasher (0.4.0), Zigbee2MQTT (1.36.0-1), SQLite Web (4.1.2), AirSend (1.2), Samba share (12.3.1), AppDaemon (0.16.4), ESPHome (2024.2.2)
Dashboards
dashboards 21
resources 31
views 27
mode storage
Recorder
oldest_recorder_run 5 mars 2024 à 09:32
current_recorder_run 13 mars 2024 à 22:31
estimated_db_size 449.09 MiB
database_engine sqlite
database_version 3.44.2
___

Bonjour

Pas très clair ta question

tu l’as flashé comment ?
tu utilises ESPHOME ?
Qu’appelles tu le module complémentaire ?

Si ESPHOME quel est le code ?

Bonjour,
Oui je l’ai flashé avec ESPHOME, j"ai suivi le tuto
Quand tu demandes le code cela correspond à quoi ?

Bonjour,
Quand tu vas dans le menu ESPHome tu vois les ESP déclarés dans HA, tu as un lien edit pour voir le fichier yaml associé à l’ESP.

Bob

Ok le voici,

esphome:
  name: esp32
  friendly_name: Esp32

esp32:
  board: esp32dev
  framework:
    type: arduino

# Enable logging
logger:

# Enable Home Assistant API
api:
  encryption:
    key: "makey"

ota:
  password: "monpassword"

wifi:
  ssid: "monwifi"
  password: "lepasswordduwifi"
  # Optional manual IP
  manual_ip:
    static_ip: l'ipstatic
    gateway: l'ipdelalivebox
    subnet: 255.255.255.0

Peux-tu indiquer les adresses IP stp, c’est du local, rien de confidentiel :wink:

    static_ip: l'ipstatic
    gateway: l'ipdelalivebox

Bob

    static_ip: 192.168.1.32
    gateway: 192.168.1.1
    subnet: 255.255.255.0

tu veux bien remplacer les lignes suivantes

api:
 encryption:
   key: "makey"

par

api:

l’utilisation du chiffrage n’est a mon avis pas nécessaire sur des réseaux prives

ce que tu peux faire aussi c’est a la fin de ton code c’est de rajouter les lignes suivantes

binary_sensor:
#Etat de la connection
  - platform: status
    name: "Connection_Status"

text_sensor:
  - platform: wifi_info
    ip_address:
      name: "ESP IP Address"

rebranche ton esp a ton raspberry
et relance le chargement du firmware

J’ai fait les changements et toujours pareil.

Quand il est branché sur mon raspberry j’ai ça

Sinon ça

Bon apparemment cela serait du à la portée du wifi, il ne le capte que si il est à moins de 2m de la livebox, un vrai problème
Est ce normal ou existe t’il une solution ?
Merci en tout cas pour vos réponses

Problème de réseau wifi résolu, merci pour vos retours