Customisation de la carte Thermostat

Bonjour, je possède 2 vannes thermostatiques Z-Wave(la première DAMFOSS sans retour de la température de la pièce et une deuxième POPP avec retour de la température).
Lorsque que je les affiche dans Lovelace avec la carte Thermostat, l’une des 2 n’affiche pas la température

.
Sur la documentation, je pense avoir compris qu’il faut ajouter une entité « climate » dans le fichier de configuration.

C’est sur « target_sensor » que je dois mettre l’entité de ma sonde de température.
Et heater l’entité de ma vanne. Mais ca ne marche pas.
Je vous joins ci-dessous la copie d’écran de l’outil de développement des 2 vannes :
Celle sans retour de température :

Et celle avec retour de température :

Merci pour votre aide.
Stéphane

Bonjour,

J’utilise le thermostat générique avec en entrée une sonde de température Aqara, en sortie un contact sec pour piloter ma chaudière à gaz.
Voici ce que j’ai dans mon fichier configuration.yaml

climate:
  - platform: generic_thermostat
    name: ThermoSalon
    #heater: light.contact_switch_salon_2
    heater: light.door_lock_unit_11
    target_sensor: sensor.temperature_18_salon
    min_temp: 10
    max_temp: 24
    ac_mode: false
    target_temp: 15.5
    cold_tolerance: 0.1
    hot_tolerance: 0.2
    min_cycle_duration:
      seconds: 180
    keep_alive:
      minutes: 3
    initial_hvac_mode: "heat"
    away_temp: 14
    precision: 0.1

Mon entité :

thermoSalon

La carte LoveLace
thermoBoard

Si cela peut t’aider :wink:
Il ne fait pas chaud chez moi :wink:

Allez, tu as un peu de lecture à faire … Pas besoin d’une sonde additionnelle, on ‹ remet › la consigne à la place de la remontée de température. Ainsi on sait quand la consigne a été prise en compte par la vanne.
Evidement, ça ne donne pas la valeur de la température de la pièce, mais ça fait de toute façon le job de régulation comme avant

Merci @Pulpy
Je lis attentivement le lien que tu m’as transmis, mais à un moment, il demande de mettre en place une automation dans HACS or, il n’y a pas de possibilité de créer une automation sous HACS.
Merci

Soit c’est un souci de typo, ou de lecture mais tu l’a bien vu c’est pas HACS mais HA (voire HAOS)

Non, c’est bien HACS

OK, c’est pas vraiment une création mais un import depuis les automatisations partagées par HACS

Sur le HACS de mon Home Assistant, je n’ai pas le menu Automatisation :

Ajoute une ligne dans ton configuration.yaml

automation: !include automations.yaml

et redémarre le core

J’ai déjà cette ligne dans mon fichier configuration.yaml

Le fichier automations.yaml existe (dans le répertoire config/ )?

Oui, il existe et a déjà des automatisations d’enregistrées

Des erreurs dans les logs ?

Sinon c’est là

Je ne vois pas d’erreur dans les logs.

:thinking: pas d’idée là … Refresh du navigateur (CTRL+F5) ?

Non plus, ca ne change pas

Je pense que l’utilisation des automatisations HACS se base sur les scripts python…

Du coup, ajoute

python_script:

Dans ton fichier configuration.yaml et redemarre pour faire apparaître le menu dans HACS

Documentation :

1 « J'aime »

Celle-ci je ne l’ai pas (du moins pas explicitement), mais ça se tente quand même

Le menu s’active aussi si on coche Appdaemon dans la configuration de HACS par exemple…

Du coup, c’est ça chez moi

1 « J'aime »