Défaillance installation zigbee2MQTT

Bonjour,

je suis l’heureux nouveau propriétaire d’une clé Phoscon ZIGbee2Mqtt.

J’ai suivi le tuto du « journal de Thomas ».

Et je bloque sur un 502 bad gateway sur l’UI Zigbee2 mqtt.

Pourriez vous m’aider svp? (j’ai déjà chercher pas mal de sujet surle forum, sans jamais trouver la bonne solution pour mon pb.

merci d’avance,

mon fichier de cong zigbee2mqtt :
‹  ›’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’
data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
base_topic: zigbee2mqtt
serial:
port: /dev/ttyACM0
adapter: deconz
advanced:
log_level: warn
pan_id: 6754
channel: 11
network_key:

  • 1
  • 3
  • 5
  • 7
  • 9
  • 11
  • 13
  • 15
  • 0
  • 2
  • 4
  • 6
  • 8
  • 10
  • 12
  • 13
    availability_blocklist: []
    availability_passlist: []
    device_options: {}
    blocklist: []
    passlist: []
    queue: {}
    frontend:
    port: 8099
    experimental: {}
    availability: false
    socat:
    enabled: false
    master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
    slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
    options: ‹ -d -d ›
    log: false
    zigbee_herdsman_debug: true
    ‹  ›’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’

voici mon log après redémarrage de l’add-on zigbee2mqtt :
‹  ›’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’
[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] socat.sh: executing…
[17:23:27] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing…
[17:23:28] INFO: MQTT available, fetching server detail …
[17:23:28] INFO: MQTT server settings not configured, trying to auto-discovering …
[17:23:29] INFO: Configuring ‹ mqtt://core-mosquitto:1883 › mqtt server
[17:23:29] INFO: MQTT credentials not configured, trying to auto-discovering …
[17:23:29] INFO: Configuring’addons’ mqtt user
[17:23:29] INFO: Previous config file found, checking backup
[17:23:29] INFO: Creating backup config in ‹ /config/zigbee2mqtt/.configuration.yaml.bk ›
[17:23:29] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks …
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[17:23:31] INFO: Handing over control to Zigbee2mqtt Core …

zigbee2mqtt@1.22.2 start
node index.js
CREATED DECONZ ADAPTER
Zigbee2MQTT:error 2022-01-14 17:23:47: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-14 17:23:47: Failed to start zigbee
Zigbee2MQTT:error 2022-01-14 17:23:47: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-01-14 17:23:47: Exiting…
Zigbee2MQTT:error 2022-01-14 17:23:47: undefined
[17:23:48] INFO: Handing over control to Zigbee2mqtt Core …
zigbee2mqtt@1.22.2 start
node index.js
CREATED DECONZ ADAPTER
Zigbee2MQTT:error 2022-01-14 17:24:04: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-14 17:24:04: Failed to start zigbee
Zigbee2MQTT:error 2022-01-14 17:24:04: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-01-14 17:24:04: Exiting…
Zigbee2MQTT:error 2022-01-14 17:24:04: undefined
[17:24:05] INFO: Handing over control to Zigbee2mqtt Core …
zigbee2mqtt@1.22.2 start
node index.js
CREATED DECONZ ADAPTER
Zigbee2MQTT:error 2022-01-14 17:24:21: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-14 17:24:21: Failed to start zigbee
Zigbee2MQTT:error 2022-01-14 17:24:21: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-01-14 17:24:21: Exiting…
Zigbee2MQTT:error 2022-01-14 17:24:21: undefined
[17:24:21] INFO: Handing over control to Zigbee2mqtt Core …
zigbee2mqtt@1.22.2 start
node index.js
CREATED DECONZ ADAPTER
‹  ›’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’

Tu as oublié de paramétrer le serveur mqtt

1 « J'aime »

Il te faut au minimum un serveur mqtt existant et configuré dans Zigbee2MQTT comme ça:

mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://192.168.xxx.xxx
  port: 1883

Regardes les tutos, y’en a sur le forum…

1 « J'aime »

merci beaucoup, je vais regarder cela

merci beaucoup, je vais regarder cela.
j’ai testé mais cela ne change rien.
Maintenant j’ai un autre problème, ma clé conbee2 n’est plus reconnu par Home assistant …

Là faut vraiment que tu recherches sur le forum:

  • As-tu vraiment installé un broker/serveur MQTT (ex: Mosquitto)
  • La config pour la clé combee avec Zigbee2MQTT ça se trouve dans plein de posts…
1 « J'aime »

merci.
je vais recommencer mes recherches.

Bonjour @Balcha31 ,

je viens de passer à Zigbee2Mqtt et j’ai rencontré le même problème.

J’ai pu régler le problème en suivant ces quelques étapes :

  • Récupérer la bonne adresse IP dans le journal de Mosquitto broker. Chez moi : 1642446933: New connection from 172.30.. on port 1883.
  • Changer la config de Zigbee2mqtt :
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://172.30.xxx.xxx:1883

J’ai également indiqué l’adresse directe vers la clé (info reprise du site officiel de z2m)

serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2438162-if00
  adapter: deconz

En espérant que cela puisse t’aider.

Bonnes recherches :wink:

Salut @Bumblebee ,

je vais réessayer cette procédure dès que ma clé ConBee2 fonctionnera :sob:
Suite à une maj avec DeConz, elle se connecte et déconnecte toutes les 2/3 sec (le pb est connu), j’attends la réponse du support de Phoscon (Dresden-elektronik).
Impossible de la flasher sous windows…

a++

oui tu dois finir de compléter ton fichier de configuration
essentiellement les options : mqtt pour ton server mqtt qui est un autre composant de home assistant et serial qui définis ta clef zigbee

mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://192.168.1.x:1883
  user: xxxx
  password: xxxxxx
serial:
  port: /dev/ttyACM0 (a vérifier sur ta machine)
  adapter: deconz

pour identifier le port ou est brancher ta clef :
Config. > Module … Superviseur > Systeme
dans la carte host en bas a droite les 3 points verticaux > matériel > trouve ta clef dans a liste > DEVNAME: valeur de ton port

Salut, après avoir flasher ma clé conbee2 et l’avoir reconfigurer. Maj le fichier de configuration avec tes préconisation @Bumblebee , c’est tjr le même résultat…

‹  ›’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’
Zigbee2MQTT:error 2022-01-24 08:05:23: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-24 08:05:23: Failed to start zigbee
Zigbee2MQTT:error 2022-01-24 08:05:23: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-01-24 08:05:23: Exiting…
Zigbee2MQTT:error 2022-01-24 08:05:23: Error: Error while opening serialport ‹ Error: Error: Resource busy, cannot open /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2473989-if00 ›
at SerialPort. (/app/node_modules/zigbee-herdsman/src/adapter/deconz/driver/driver.ts:182:28)
at SerialPort._error (/app/node_modules/zigbee-herdsman/node_modules/@serialport/stream/lib/index.js:198:14)
at /app/node_modules/zigbee-herdsman/node_modules/@serialport/stream/lib/index.js:242:12
[08:05:24] INFO: Handing over control to Zigbee2mqtt Core …

‹  ›’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’

Merci @Uowis ,
je rencontre tjr le même problème , cf mon dernier message à @Bumblebee

merci pour ton aide

Aucune idée si ça va t’aider ou pas, mais ce week end après installation de certains addon je n’arrivais pas à y accéder depuis mon navigateur Chrome.
Mais ça fonctionnait depuis Edge.
Si jamais ça peut t’aider.

Si la carte n’est pas HS (ce qui est possible…), c’est que le port /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2473989-if00 n’est pas correct.
C’est un problème assez classique. Par exemple Error while starting zigbee-herdsman · Issue #2928 · Koenkk/zigbee2mqtt · GitHub indique que ça a marché avec:

serial:
  port: /dev/ttyAMA0
  adapter: deconz

S’il y a déjà un autre port USB d’utilisé, ça peut être aussi une histoire de /dev/ttyACM1 (ou USB1 ou AMA1)…

Merci @golfvert : il n’y a que ma clé conbee2 de connecter.

je trouve plein de messages sur X forum, avec différentes configs mais j’obtient tjr ça:

<-----------------------------------------------------------------
2022-01-24T10:19:46.586Z zigbee-herdsman:adapter Failed to validate path: ‹ Error: spawn udevadm ENOENT ›
2022-01-24T10:19:46.592Z zigbee-herdsman:controller:log Starting with options ‹ {« network »:{« networkKeyDistribute »:false,« networkKey »:[1,3,5,7,9,11,13,15,0,2,4,6,8,10,12,13],« panID »:6754,« extendedPanID »:[221,221,221,221,221,221,221,221],« channelList »:[11]},« serialPort »:{« path »:"/dev/ttyACM0"},« databasePath »:"/config/zigbee2mqtt/database.db",« databaseBackupPath »:"/config/zigbee2mqtt/database.db.backup",« backupPath »:"/config/zigbee2mqtt/coordinator_backup.json",« adapter »:{« disableLED »:false,« concurrent »:null,« delay »:null}} ›
2022-01-24T10:19:46.594Z zigbee-herdsman:adapter:zStack:znp:log Opening SerialPort with /dev/ttyACM0 and {« baudRate »:115200,« rtscts »:false,« autoOpen »:false}
2022-01-24T10:19:46.610Z zigbee-herdsman:adapter:zStack:znp:log Serialport opened
2022-01-24T10:19:46.613Z zigbee-herdsman:adapter:zStack:znp:SREQ → SYS - ping - {« capabilities »:1}
2022-01-24T10:19:46.617Z zigbee-herdsman:adapter:zStack:unpi:writer → frame [254,0,33,1,32]
2022-01-24T10:19:46.874Z zigbee-herdsman:adapter:zStack:znp:log Writing CC2530/CC2531 skip bootloader payload
2022-01-24T10:19:46.876Z zigbee-herdsman:adapter:zStack:unpi:writer → buffer [239]
2022-01-24T10:19:47.879Z zigbee-herdsman:adapter:zStack:znp:SREQ → SYS - ping - {« capabilities »:1}
2022-01-24T10:19:47.882Z zigbee-herdsman:adapter:zStack:unpi:writer → frame [254,0,33,1,32]
2022-01-24T10:19:48.134Z zigbee-herdsman:adapter:zStack:znp:log Skip bootloader for CC2652/CC1352
2022-01-24T10:19:48.594Z zigbee-herdsman:adapter:zStack:znp:SREQ → SYS - ping - {« capabilities »:1}
2022-01-24T10:19:48.596Z zigbee-herdsman:adapter:zStack:unpi:writer → frame [254,0,33,1,32]
2022-01-24T10:19:54.602Z zigbee-herdsman:adapter:zStack:znp:SREQ → SYS - ping - {« capabilities »:1}
2022-01-24T10:19:54.603Z zigbee-herdsman:adapter:zStack:unpi:writer → frame [254,0,33,1,32]
2022-01-24T10:20:00.607Z zigbee-herdsman:adapter:zStack:znp:SREQ → SYS - ping - {« capabilities »:1}
2022-01-24T10:20:00.609Z zigbee-herdsman:adapter:zStack:unpi:writer → frame [254,0,33,1,32]
Zigbee2MQTT:error 2022-01-24 11:20:06: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-01-24 11:20:06: Failed to start zigbee
Zigbee2MQTT:error 2022-01-24 11:20:06: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-01-24 11:20:06: Exiting…
Zigbee2MQTT:error 2022-01-24 11:20:06: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
at Zigbee.start (/app/lib/zigbee.ts:58:27)
at Controller.start (/app/lib/controller.ts:100:27)
at start (/app/index.js:97:5)
------------------------------------------------------------------>

bref, ça me rend fou :wink:
j’e vais reflasher ma conbee2, tout réinstaller, MQTT broker, puis zigbee2mqtt , puis deconz

merci pour ton aide

merci @mathieul , je vais essayer

Pourquoi Deconz ?
Ce qu’il me semble avoir compris (je ne suis pas sûr) c’est que pour remonter les infos des modules zigbee il faut utiliser soit :

  • ZHA
  • Deconz
  • Z2M + Mosquito

Mais pas en cumuler 2, là c’est ce que je crois comprendre.

Salut,

Deconz n’était pas démarrer.
je suis avec une conf Z2M + Mosquito

mon fichier de conf est celui ci:

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: true
mqtt:
base_topic: zigbee2mqtt
server: mqtt://172.30.32.1:1883 – même résultat avec mqtt://192.168.xxx.yyy:1883
user: mqtt
password: mqtt
serial:
port: /dev/ttyACM0
advanced:
log_level: warn
pan_id: 6754
channel: 11
network_key:
- 1
- 3
- 5
- 7
- 9
- 11
- 13
- 15
- 0
- 2
- 4
- 6
- 8
- 10
- 12
- 13
availability_blocklist: []
availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
port: 8099
experimental: {}
availability: false
socat:
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: ‹ -d -d ›
log: false
zigbee_herdsman_debug: true


Bon,
désolé si ça peut paraître tourner en boucle, mais dans la discussion ci-dessus il y a des choses que je ne vois pas ou que je n’arrive pas a confirmer.

Préambule: Quand tu copies dans un message des fichiers yaml ou autre code, peux tu utiliser les balise de code (le bouton </>) ça améliore la lisibilité et surtout garde els indentations, ce qui est vital pour le yaml.

Premier point:
Je ne trouve pas dans ces message la confirmation que tu es certain du chemin vers ta clé!
Peux tu le confirmer que c’est : /dev/ttyACM0
Pour le confirmer, depuis HA, vas dans « Configuration > Modules Compl… > Système », puis tout à droite dans la section « Host » clique sur les trois points de config et choisis « Matériel » en passant à travers la liste de tous les /dev/ tu devrais en trouver un où il y a la clé connectée.
Ca ressemble à ça chez moi, c’est /dev/ttyUSB0:

Deuxième point.
Juste pour confirmer dans ton fichier de config 2 questions triviales!

  1. Y’a bien les indentations?
  2. user et password c’est bien la valeur « mqtt » que tu as mis sur mosquitto pour les 2?
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://172.30.32.1:1883 – même résultat avec mqtt://192.168.xxx.yyy:1883
  user: mqtt
  password: mqtt

Troisième Point:
Tu n’as plus sous la section « Serial » le « adapter: deconz »

C’est ce qui se trouve sur le site de Zigbee2MQTT:
https://www.zigbee2mqtt.io/guide/adapters/#recommended

1 « J'aime »

Bonjour @AlexHass ,

pour la visibilité des messages , je ferai plus attention la prochaine fois. Je m’en excuse.

initialement, je me suis basé sur le tuto fourni par thomas de la chine youtube « le journal de thomas » que je trouve très bien au passage :wink:

Pour répondre au 1er point:

  • J’utilise effectivement, la méthode que tu décris pour récupérer le « Dev name » de ma conbee2.
    donc j’ai soit utilisé le dev name soit identifiant (cf photo ci dessous) :

pour répondre au second point:

  • oui, il y a des indentations

image

  • le login et le pwd sont ceux ceux inscrit dans la configuration de mosquito mqtt:
    image

En tous cas, merci pour ton aide. Je me demande si je ne vais pas arrêter d’utiliser Z2M pour rester avec Deconz… Ca m’attriste de ne pas y arriver alors que ça n’a pas l’air d’être si compliqué