Gestion Piscine

Bonjour à tous,

Dans l’optique de remplacer mon boitier électrique vieillissant où l’horloge mécanique ne démarre pas la pompe mais l’éteint correctement!!! je souhaite domotiser tout ceci.

Je pensais partir sur du sonoff.
Un module TH16 avec sonde DS18B20 Pour mesurer la température de la piscine et éventuellement mettre l’allumage de la lumière dessus.

Un second module TH16 avec sonde température AM2301 pour la température extérieure.

Pour la prise de la pompe j’envisage ceci : SONOFF S55 IP55

Qu’en pensez vous?

Il me manque la gestion du niveau d’eau, et le ph, chlore.

Bonjour @cob94440,

As tu fait un tour sur le discord HACF ?

Il y a un salon piscine.

Peut être y a t’il des infos intéressantes…

(ce n’est pas une invitation à continuer le sujet sur discord :wink:, il faut faire vivre le forum :innocent:)

Je vais de ce pas regarder mais t’en fais pas je poste ici ce que je trouverais en partage.
Tout le monde ne vas pas s’y retrouver sur discord. C’est mon cas :innocent: :stuck_out_tongue_winking_eye:

2 J'aime

J’avoue que le discord est pratique pour la réactivité, mais pas pour l’organisation car les discussions s’entremêlent…

1 J'aime

J’ai un esp qui me remonte les températures et le pH si ça t’intéresse. La sonde temp est une dallas. La carte pH j’ai pas la réf sous la main mais c’est là moins chère sur AliExpress.
Le tout sur un esp via esphome.
Y’a une petite manipulation pour ajuster le potard sur la carte. Il faut mesurer la tension dans la sonde. Tu trouveras ton bonheur sur les sites Arduino.
Je gère la calibration depuis HA. Si il te faut un coup de main fait signe.

Le code esp en copie image pour le moment. Je suis en pause au boulot et j’arrive pas à copier le code depuis le téléphone

Sinon y a le projet raspipool

J’ai un autre projet pour la gestion du chlore car j’ai mis en place des pompes doseuses.
Faut que je fasse un poste pour les présenter sur le forum français pour le moment tu le trouve sur le forum anglais.

Merci @Twinsen c’est déjà un episte. Bon il faut que je gère une fuite avant tout et surtout la localiser.

Et j’ai un custom component pour gérer le temps de la filtration: https://github.com/oncleben31/ha-pool_pump

C’est encore très basique mais ca me suffit pour le moment vu qu j’ai pas enore de prise de mesure sur l’eau de ma piscine.
En revanche s’il y a des motivés pour l’utiliser je veux ben y investir de l’énergie pour l’améliorer.

2 J'aime

De mon côté ça m’intéresse de l’utiliser

Finalement je n’ai plus d’erreur en installant le plugin.
Il me reste à acquérir le matos et soigner ma piscine avant cela.

Voilà les caractéristiques de ma pompe :

POWPSCP1 1 cv - 1 HP 0,75 Kw 13 m3/h 213 mm 1”1/2 15 kg 975 W 4,3 A
Cette prise devrait faire l’affaire je pense.

Salut @oncleben31

Je viens pool_pump via HACS mais après comme je débute dans HA je ne sais pas ce que je dois faire.

Si tu peux m’indiquer la marche à suivre ça serait cool.

Bonjour @oncleben31 ,
Je me permets de poster ici.
Bon je viens de tout paramétrer. Venant de Jeedom j’utilisais le plugin piscine.

Juste une chose, je n’arrive pas à afficher le temps de fonctionnement de la pompe,ni l’affichage de l’heure pivot. Je ne comprends pas.

Pourriez vous m’aider ?

Merci

Les instructions sont là: GitHub - oncleben31/ha-pool_pump: 🏊💻Pool pump manager for Home Assistant
Quel élément te pose difficulté ?

La question est large. Comment as tu essayé de l’afficher ?

Bonjour, est ce que tu as un tuto, des infos pour la gestion du chlore et ph pour une piscine ? Merci pour ton aide

@stephane_Martin Non pas de tuto pour une piscine. Mais il y a pas mal de projet sur le forum anglais. Regardes aussi du côté de raspipool.
Sur le forum anglais j’ai fait un gros post avant que le forum français n’existe sur la confection de pompe doseuses pour mon aquarium. Cela te permettrais de distribuer une dose de chlore en fonction du résultat voulu. Il me semble qu’il faille vérifier l’ORP pour la piscine.
Je dis peut être un me connerie ne m’y connaissant qu’en aquarium et bassin de jardin mais il me semble qu’il faille ajuster le ph dans un premier temps pour que le chlore soit efficace et l’adjonction du chlore via l’ORP. Comme dit je te renvoie plutôt vers de post piscine. Il me semble qu’il y en ai plusieurs ici. Je planche sur un redox mètre depuis un moment mais ne trouve pas le temps pour m’y mettre. Tout le matos est là, le montage est fait il me manque plus que la calibration et peaufiner le programme. N’hésites pas à demander conseil au besoin.

Pardon je pensais qu’il s’agissait du post pH mètre. J’enlève le commentaire ?

Bonjour, je profite de la discussion pour exposer un souci avec HA-pool_pump. j’ai bien suivi les instructions de oncleben31 mais le service pool_pump.check reste inexistant sur ma config:
« Error while executing automation automation.check_pool_pump_on_event: Unable to find service pool_pump.check »
le service n’est pas pas present dans les outils de développement. Le reste semble fonctionner, mais comme le service pool_pump check n’existe pas, l’automatisation ne déclenche pas le switch qui controle la pompe de la piscine.
ma config :
home assistant 2021.5.2 en docker sous Raspbian.
des idées?
Merci.

Le service pool_pump.check est implémenté par le composant __init___.py ligne 90 :
async def check(call):
"""Service: Check if the pool pump should be running now.

A partir du moment ou les définitions sont bien faite, le service va monter.

Par rapport à la configuration et l’intégration donné par @oncleben31 il faut tout prendre (pool_pump: input_select: automation: ), les seuls éléments à paramétrer :
pool_pump:
switch_entity_id:switch.mon_switch_de_piscine
pool_temperature_entity_id:sensor.pool_water_temperature
et dans les automations :
automation:
- alias: 'Pompe Piscine On'
action:
entity_id: switch.mon_switch_de_piscine

- alias: 'Pompe Piscine Off'
action:
entity_id: switch.mon_switch_de_piscine
- alias: 'Check Pool Pump on Event'
- platform: state
entity_id:
- sensor.pool_water_temperature

J’ai juste un doute sur le faite qu’on ai le choix du nom du switch.mon_switch_de_piscine qu’il faille qu’il s’appel switch.pool_switch

salut, merci pour la réponse.
il me semble bien que tout est configuré comme tu me le rappelles. j’arrive bien à lancer les automations directement, mon switch change bien d’état.
Le problème est que le service pool_pump.check n’existe pas dans ma config. On dirait que init.py du « custom component » ne se lance pas. Comment ce scrypt python est-il censé être appelé?

Salut,
désolé du retard. En fait j’ai réussi à afficher l’heure pivot.
Par contre j’ai un problème. En ON ça fonctionne, je force bien la marche de la pompe non stop. La variable next_run_schedule est bien en « Manual Mode »

Par contre quand je passe en auto, elle reste en « manual mode » il ne m’affiche pas le debut et fin de la filtration…et donc ne passe pas en automatique…

Vois tu ce que je veux dire ?