GRDF: Gazpar_2_MQTT

Peux-tu me dire si lors du lancement de l’add-on, avec le message d’erreur dans les logs tu as également une notification persistante qui t’indique une adresse IP bloquée ?

Sinon dans le dossier /config de HAOS un fichier ip_ban.yaml avec une adresse IP à l’intérieur ?

Bonjour, je viens de créer l’issue dans le github.
Je reste à dispo si besoin d’aide pour débugger…

1 « J'aime »

Bonjour

Malgré la mise en place du Schedule à 6H30 les index ne se relève pas.
Pour avoir la remonté je dois arrêter l’addon, faire reconstruire et redémarrer l’Addon.
(Les index serait du 6 et 9 mai 2024)

Faut il faire un automatisme ? (Si oui comment réaliser « reconstruire »)

Merci

Merci pour le retour, je ne suis pas spécialiste addon et en train d’apprendre :slight_smile:
Est-ce que tu voix des lignes dans les logs vers et après 06:30 ajourd’hui?

Je ne vois rien, mais je regarde demain matin voir s’il se passe quelque chose et je te fais un retour.

J’ai testé un peu et ça redéclenche sans soucis (chez moi…ce n’est pas 100% preuve), vorir dessous
Comment tu pense que ça ne marche pas? Sachant que GRDF reste en retard


et

Entretemps…liste des installations sans soucis

  • Window 10 (container)
  • Windws 10 HyperV (haos)
  • Intel Nuc (container)
  • Synology 218+ VM (haos)
  • VM via OVH (haos)

Il existent des soucis avec qq installations…

Je ne voyais pas index varier.
Mais il y a bien un relevé à 6h30.( A re-confirmer demain).
Mais index ne varie que de façon aléatoire…1 fois au bout de 2 jours ou 3 jours ou le lendemain. (5501 actuellement)

Index_plubished ne varie pas depuis 10 jours (5499 actuellement)

Je comprend pas trop le principe des relevés de GRDF ???

T’as lû que GRDF a des soucis?

Non,

Sur le site GRDF, j’ai des consommations jour qui s’affiche, mais j’ai pas index de mon compteur.

Sur mon compteur je relève 5512, sur le relevé gazparmqtt j’ai 5501.
Donc je comprend pas comment les relevés GRDF se font…

Je vais essayer de suivre cette semaine et voir l’évolution.

Lire le site de grdf stp… attentivement (!)
S’ils sont incapable de être a jour lui même pas la peine de voir pour mieux dans l’intégration

1 « J'aime »

Mise-a-jour 0.8.5

Cause plusieurs soucis avec ‹ chromium › : refait et enlevé/remplacé

Testé sur:

  • i386 windows 10 docker
  • intel nuc ubuntu docker
  • windows hyper-v addon
  • synology VM addon
  • proxmox addon
  • rpi addon

Ce matin, le comptage de l’index a bien été pris en compte à 6 H 30
Mon index est passé de 5 501 à 5 505. La date d’index serait le 13/05/2024 si je comprends bien le log.

Par contre, le publish_index est toujours bloqué à 5 499.

2024-05-19 06:30:05,782 INFO Retrieve informative measures...
2024-05-19 06:30:06,536 INFO Informative measures found !
2024-05-19 06:30:06,536 INFO Analysis of informative measures provided by GRDF...
2024-05-19 06:30:06,536 INFO 1094 informative measures provided by Grdf
2024-05-19 06:30:06,537 INFO 1087 informative measures are ok
2024-05-19 06:30:06,537 INFO Accuracy is 99 percent
2024-05-19 06:30:06,537 INFO Last valid informative measure provided by GRDF : 
2024-05-19 06:30:06,537 INFO Date = 2024-05-13
2024-05-19 06:30:06,537 INFO Start index = 5504, End index = 5506
2024-05-19 06:30:06,537 INFO Volume = 2 m3, Energy = 23 kWh, Factor = 11.27482
2024-05-19 06:30:06,537 WARNING Inconsistencies detected on the measure : 
2024-05-19 06:30:06,537 WARNING Volume provided by Grdf (None m3) has been replaced by the volume between start index and end index (2 m3)
2024-05-19 06:30:06,537 INFO ---------------
2024-05-19 06:30:06,537 INFO Retrieve published measures...
2024-05-19 06:30:06,729 INFO Published measures found !
2024-05-19 06:30:06,729 INFO Analysis of published measures provided by GRDF...
2024-05-19 06:30:06,729 INFO 72 published measures provided by Grdf
2024-05-19 06:30:06,730 INFO 72 published measures are ok
2024-05-19 06:30:06,730 INFO Accuracy is 100 percent
2024-05-19 06:30:06,730 INFO Last valid published measure provided by GRDF : 
2024-05-19 06:30:06,730 INFO Start date = 2024-05-01 06:00:00, End date = 2024-05-09 06:00:00
2024-05-19 06:30:06,730 INFO Start index = 5487, End index = 5499
2024-05-19 06:30:06,731 INFO Volume = 12 m3, Energy = 134 kWh, Factor = 11.18
2024-05-19 06:30:06,731 WARNING Inconsistencies detected on the measure : 
2024-05-19 06:30:06,731 WARNING Volume provided by Grdf (None m3) has been replaced by the volume between start index and end index (12 m3)

et toujours le bandeau…orange

Bonjour, Quel sensor utilisez-vous sur le dashboard énergy ? Je n’ai pas le sensor « total »…

Output fr FR · vingerha/gazpar_2_mqtt Wiki (github.com)

ça fonctionne trés bien chez moi, mais impossible de faire fonctionner Long Term Statistics.

j’ai bien ajouté ceci dans mon fichier cong :

HASS_LTS=True
HASS_LTS_HOST="http://homeassistant.local:8123"
HASS_LTS_TOKEN=98724kjhawelkj....etc. (use the Long Term Access token, generated for the LTS_HOST below)

avec mon token bien évidemment.

mon home assistant est dispo via un https mais il est aussi dispo via http://homeassistant.local:8123

pourtant rien n’y fais j’ai toujours ceci dans les logs :

Home assistant Long Term Statistics (WebService)
ERROR Home Assistant Long Term Statistics : unable to publish LTS to Webservice HA with error: Cannot operate on a closed cursor.
ERROR Retrying with API
Home assistant Long Term Statistics (API)
ERROR Home Assistant Long Term Statistics : unable to publish LTS to HA with error: Cannot operate on a closed cursor.

Mes excuses, j’ai mis mes changements trops vite, release 086 doit être mieux :slight_smile:

EDIT: 086 publié 07:57 ce matin

Je viens de tester j’ai plus la même erreur j’ai ça maintenant :

2024-05-21 08:31:12,393 INFO Connection to WebSocket Home Assistant ws://homeassistant.local:8123/api/websocket
2024-05-21 08:31:12,448 INFO Connection to WebSocket Home Assistant ws://homeassistant.local:8123/api/websocket
2024-05-21 08:31:12,451 INFO Authentication needed
2024-05-21 08:31:12,452 ERROR => Authentication impossible, please verify url & token.
2024-05-21 08:31:12,452 INFO Connection to WebSocket Home Assistant ws://homeassistant.local:8123/api/websocket
2024-05-21 08:31:12,456 INFO Authentication needed
2024-05-21 08:31:12,457 ERROR => Authentication impossible, please verify url & token.
2024-05-21 08:31:12,457 CRITICAL The configuration of the Websocket Home Assistant WebSocket is erroneous

J’ai essayé de changé le token, de le mettre entre quote, ça ne fonctionne pas.

J’utilise un autre addon qui fonctionne bien avec la connexion websocket, donc j’ai des doutes sur le fait que ça vienne de chez moi.

Salut,
idem chez moi avec:

2024-05-21 08:38:36,427 INFO Connection to WebSocket Home Assistant ws://192.168.1.75:8123/api/websocket
2024-05-21 08:38:36,430 ERROR Handshake status 403 Forbidden -+-+- {'content-type': 'text/plain; charset=utf-8', 'content-length': '14', 'date': 'Tue, 21 May 2024 06:38:36 GMT', 'server': 'Python/3.12 aiohttp/3.9.5'} -+-+- b'403: Forbidden'
2024-05-21 08:38:36,431 CRITICAL Connection to Websocket Home Assistant failed
2024-05-21 08:38:36,431 WARNING  => WARNING, the WebSocket will be banned after multiple unsuccesful login attempts.
2024-05-21 08:38:36,431 WARNING  => ex: 403: Forbidden

Important est d’avoir une ligne vide
Autre soucis pourrait être le HOST…peut-être changer vers l’IP de ton VM