HACS est désactivé - Ratelimited

Bonjour la communauté,
Depuis 24 h au moins il m’est impossible de mettre à jour certaines intégrations issues de HACS.
l’interface du menu HACS m’indique « HACS est désactivé - Ratelimited »

J’ai vidé le cache et redémarré mais rien n’y fait. Quelqu’un a t il une idée de la marche à suivre pour résoudre cela ?
Merci.

Salut je suis un total nocive et je viens d’installer HACS également aujourd’hui. J’ai exactement la même erreur et j’ai donc cherché une réponse.

Apparemment HACS limite le nombre de connexion, c’est normal après une installation.

https://hacs.xyz/docs/faq/initial_startup

Mais je laisse les pros te répondre étant donné que je découvre HA.

Je réponds à moi même :joy: :thinking:…je cherche pendant des heures avant de me décider à écrire sur le forum et comme par hasard je trouve ensuite la soluce …
en fait je suis allé dans configuration, intégration, configurer HACS. Dans filter with country code la valeur « all » était sélectionnée…Je l’ai passée à « FR » sans vraiment savoir ce que cela ferait. Après redémarrage, tout est ok. Je ne sais pas pourquoi mais si cela peut aider…

2 « J'aime »

salut @zenip
je viens de trouver la soluce…voir mon message précédent. dis moi si c’est ok pour toi

Salut, non ca ne change rien pour moi… je vais patienter… content que tu es trouvé la solution.

Hello

J’ai vu sur le forum anglophone :

J’ai ajouté dans le config. Yaml

config:
  hacs.disable(HacsDisabledReason.RATE_LIMIT) return True

Ça semble fonctionner après reboot

Salut,
J’ai le même soucis mais je ne trouve pas le config.yaml …
Pour info, je suis sur une install docker .

Merci par avance.

@Bigmat et @FitzChevalerie
Attention avec l’ajout de cette option… La mise en place du mécanisme de désactivation coté HA a été justement fait pour bloquer temporairement, plutôt que définitivement par github.

User-to-server requests are rate limited at 5,000 requests per hour and per authenticated user

Donc désactiver cette limitation locale, c’est bien mais c’est prendre un risque de se retrouver coincé plus longtemps encore : si la limite est atteinte, continuer à faire des requêtes, ne fait jamais descendre le compteur

Dans la configuration normale, le fonctionnement classique revient en quelques heures. Il faut juste faire preuve de patience et ne pas redémarrer 10000 fois

2 « J'aime »

Merci pour l’info et les conseils
J’ai enlevé ce code et l’erreur n’est pas revenue

Je confirme : en mettant FR au lieu de ALL, et en rechargeant, c’est reparti.