Integration error: resources - Integration 'resources' not found

Mon problème

Integration error: resources - Integration ‹ resources › not found.

Ma configuration


System Health

version core-2022.6.4
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.12
os_name Linux
os_version 5.15.41
arch x86_64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 4959
Installed Version 1.25.5
Stage running
Available Repositories 1045
Downloaded Repositories 2
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 8.1
update_channel stable
supervisor_version supervisor-2022.05.3
agent_version 1.2.1
docker_version 20.10.14
disk_total 30.8 GB
disk_used 7.2 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons Mosquitto broker (6.1.2), Z-Wave JS to MQTT (0.43.0), Z-Wave JS (0.1.60), Terminal & SSH (9.4.0), Ring-MQTT with Video Streaming (5.0.2), Node-RED (12.0.2), Zigbee2MQTT (1.25.2-1), File editor (5.3.3)
Dashboards
dashboards 1
resources 1
views 4
mode storage
Recorder
oldest_recorder_run 8 juin 2022 à 10:05
current_recorder_run 9 juin 2022 à 16:09
estimated_db_size 311.44 MiB
database_engine sqlite
database_version 3.34.1
___

Bonjour,

Je viens demander de l’aide car à la verification de la config j’obtiens l’erreur suivante :
Integration error: resources - Integration ‹ resources › not found.

J’ai tenté la suppression des differentes card de l’interface Lovelace sans succés.
Supprimer les sources interface dans HACS.
Je ne trouve pas le moyen de corriger.

Si vous pouviez me guider ?

Merci :slight_smile:

La bonne nouvelle en informatique, c’est quand un truc marche, 99.9% si on ne change rien il continue de marcher.
Et à l’inverse, ce sont les modifications qui provoquent les problèmes.
Donc, il faudrait chercher ce que tu as changé entre « avant ça marchait » et « maintenant ça marche plus ».

Le soucis c’est que plusieurs semaines se sont passées entre !
Et je n’avais pas le réflexe de vérifier la config a chaque fois - essentiellement du travail sur nodered pour les automatisations.

Dans les logs il y a ça :

Logger: homeassistant.setup
Source: setup.py:162
First occurred: 16:09:29 (1 occurrences)
Last logged: 16:09:29

Setup failed for resources: Integration not found.

Trouvé !

Simplement dans le fichier configuration.yaml
Aucunes idées du comment c’est arrivé là ! Mais le check de la configuration est validé maintenant.

[core-ssh config]$ grep -rnw . -e 'resources'
./configuration.yaml:14:resources:

resources:
  - url: /local/mini-graph-card-bundle.js?v=0.11.0
    type: module