Intégration Legrand Cable outlet 064882 à Zigbee2MQTT

Salut à tous

je viens juste de voir ce post et j’arrive après la bataille
j’ai ces sorties de câble et je les pilote depuis novembre via le Rest API Deconz

est ce que le travail présenté ici pourra m’aider à avoir une intégration propre?
voir mon ancienne demande d’aide:
https://forum.hacf.fr/t/demande-daide-modification-dune-entite-thermostat-apres-son-integration/7747

Salut @Haz,

grâce à cet ajout dans Z2M, tu n’aura plus besoin de passer par du RestAPI, l’intégration est pleinement reprise dans HA sans devoir rajouter des choses.
Tout est fonctionnel, à savoir, le mode Contacteur (ON/OFF), le mode Fil pilote (avec les 6 ordres) ainsi que la remontée de la puissance consommée.

J’ai actuellement 6 de ces sorties de câble et ça fonctionne très bien

merci

je vais attendre la fin de l’hiver, on ne sait jamais :thinking:
la panne de la raspberry il y a deux semaines a suffisamment provoqué la panique :cold_face:

mais je ne connais pas Z2M, est ce que l’on peux passer aussi par Deconz? est ce que je dois changer l’appairage des prises?
est ce qu’il faut faire un reset des prises, télécharger un nouveau firmware?

Cette intégration a été faite pour Z2M, ça ne fonctionne donc pas dans Deconz.

Si tu passes sous Z2M, tu devras tout réappairer.
Le reset des prises se fait très vite (appui de 8 secondes sur le petit bouton avec une roue dentée jusqu’à ce que la led passe au rouge).
Et il n’y a pas de nouveau firmware à télécharger

ok je essaierais bien pour avoir quelque chose de propre mais tout ré-appairer ne me tente pas du tout…

Salut

J’ai fait un tour sur le site zigbee2mqtt et je suis allé voir notre fameuse sortie de câble… Legrand 064882 control via MQTT | Zigbee2MQTT
Je vois que les mesures de consommation ne remonte pas automatiquement

To read (/get ) the value publish a message to topic… blabla

Avec l’intégration Phoscon, la remontée d’information est automatique. Est ce que cela signifie que sur Z2M il y a quelque chose de particulier à faire? ou bien est ce une erreur du site Z2M?

Salut Haz, non les mesures de consommation remontent bien automatiquement et sont instantanées. Aucune manipulation à faire de ce côté là, je te rassure

merci @Carthage
du coup, il a certainement une erreur dans la description du site Z2M? ou alors je comprends mal :thinking:

Sinon super travail!
vu le mal que j’ai eu pour intégrer cette prise via Phoscon et deConz… j’imagine la galère pour toi.

On ne peut pas vraiment appelé ça une erreur. Il est indiqué que l’on peut récupérer la valeur via un /get.
Peut-être pour faire des choses plus poussées mais je ne m’en suis jamais servi.
Dans tous les cas, tu peux partir dessus les yeux fermés, la remontée des informations fonctionnent très bien (je l’utilise au quotidien).

Oui, ça a été une galère pas possible mais la finalité, c’est que ça fonctionne et que je puisse en faire bénéficier la communauté :slight_smile:

1 « J'aime »

Bonjour,
Je me permet de venir vers vous car je viens d’acquérir ce device.
Je l’ai donc ajouté a Z2M qui le détecte directement, mais il m’est impossible d’acquérir la valeur de consommation ne même de changer un des modes de fonctionnement( device_mode / cable_outlet_mode…)
Je pense avoir un soucis au niveau de l’appairage, avez vous fait une manipulation spécifique pour que celui ci fonctionne?
Merci a vous

Bonjour,
les données de consommation mettent un peu de temps avant d’avoir les premières remontées suite à un appairage (du moins, ce que j’ai pu constater).
Pour les modes de fonctionnement, voici un résumé :

  • device_mode sur ‹ OFF ›: le device fonctionne en mode ‹ ON/OFF › et les options du cable_outlet_mode sont indisponibles.
  • device_mode sur ‹ ON ›: le device fonctionne en mode ‹ Fil pilote ›, les options du cable_outlet_mode sont disponibles.

Maintenant, s’il t’es impossible de modifier au moins le device_mode, c’est que tu dois avoir un souci d’appairage.
Pour ma part, et afin que le device soit détecté correctement, voici ma procédure :

  • je fais un reset d’usine (8 secondes appuyé sur le bouton avec la roue dentée). La led doit passer au rouge fixe.
  • Je passe Z2M en mode appairage et j’attends que ce dernier reconnaisse correctement le device. (Pendant ce laps de temps, la led doit s’éteindre environ 1 seconde et se rallumer en rouge)
  • J’appuie un bref instant sur le bouton avec la roue dentée et la led passe au vert.
  • Enfin, j’enlève le mode appairage de Z2M.

Voilà, en espérant pouvoir t’aider avec cette réponse. Si tu rencontres encore des problèmes, n’hésites pas !

1 « J'aime »

Merci de la réponse! Tout fonctionne!
Cela venait bien de mon appairage, le voyant ne passait pas au vert.
Encore merci!

1 « J'aime »

Pas de soucis. Amuse toi bien :stuck_out_tongue_winking_eye:

Bonjour,
Pour ma part je n’arrive pas à faire l’appairage de ma sortie de cable Legrand 0648 19 avec Zigbee2MQTT.
J’ai une Led rouge fixe à la mise sous tension. J’appuie sur la roue dentée pendant 8 sec., alors le voyant rouge s’éteint passe un court instant au vert puis repasse au rouge fixe. Lors du passage au vert brièvement un relai semble « claquer » en même temps. Et Zigbee2MQTT est en mode appairage pendant toute la manip. sans rien détecter.
Petit détail (qui peut avoir son importance), j’ai réussi son appairage sous ZHA avec une Zigate, mais je n’ai pas toutes les entités qui remontent (notamment fil pilote) c’est pourquoi je préfèrerai qu’il soit sur mon réseau Zigbee2MQTT. Je l’ai donc bien retiré du réseau ZHA associé avec la Zigate avant d’essayer de l’appairer avec Zigbee2MQTT.

J’ai cherché un peu une notice Legrand pour cette sortie de cable avec les significations des led (rouge, vert et bleu) où les cas de dépannage mais je n’ai rien trouvé hormis une notice de cablage, mais rien sur le fonctionnement.

Comme il a déjà était appairé (à ZHA), il faut sûrement lui faire un reset avant de le mettre en mode appairage. Après, comment faire, ça c’est une autre question…

Si la led est au rouge fixe lors de sa mise sous tension, c’est qu’il est en attente d’être appairé.
Or, d’après ce que je peux lire, tu mets Z2M en mode appairage, tu mets sous tension ton device (qui normalement doit s’appairer à ce moment) et tu lui fais un reset dans la foulée.
Et le relai qui semble « claquer », c’est normal car si je suis ta méthode d’appairage (du moins, ce que tu écris), le device repasse en mode par défaut, à savoir, en mode contacteur.

J’ai posté plus haut la méthode afin d’appairer correctement ces devices, jettes un coup d’œil !

Donc à te lire, je dois le mettre sous tension, lancer l’appairage Z2M.
J’attends que la led rouge s’eteigne 1 seconde puis j’appuie un bref instant sur le bouton pour faire passer le led au vert ?

Pour infos a 46 euros sur Amazon

2 « J'aime »

Désolé de répondre que maintenant, je n’avais pas vu ton message…
Sinon oui c’est ça, c’est exactement ça qu’il faut faire pour appairer le device en question.

Lorsque la led passe au vert fixe, tu peux arrêter le mode appairage sur Z2M

1 « J'aime »

Un message a été fusionné à un sujet existant : [BON PLAN] Legrand Sortie de Cable (Zigbee) With Netatmo