LiXee - ZiPulses

Bon, après 10 jours sans encombres, mon ZiPulses est passé hors ligne. Je ne sais pas si c’est lié au protocole mais c’est dommage qu’il n’arrive pas à reprendre contact avec le routeur dès le premier coup de moins bien…

Bonsoir,
J’ai installé le ZiPulses qui fonctionne correctement, appairé avec un Dongle USB SONOFF.
Comme je n’arrive pas à modifier les attributs « multiplier » et « Diviser » , J’ai déclaré un sensor dans le configuration.yaml :

template:
  - sensor:
    - name: "Gas_NRJ"
      unit_of_measurement: "kWh"
      device_class: "energy"
      state_class: "total_increasing"
      state: "{{ states('sensor.lixee_zipulses_summation_delivered')|float * 0.01 | float * 11.16 }}"
      availability: "{{ states('sensor.lixee_zipulses_summation_delivered') not in ['none', 'unknown', 'unavailable'] }}"

Le coeficient 11.16 permet de transformer les m3 en kWh. Ce coef est mis à jour tous les mois par GRDF.
Je souhaiterais faire évoluer ce coef sans avoir à éditer, chaque mois, le configuration.yaml
Pour cela, j’ai créé une « entrée » de type Nombre depuis l’éditeur de Paramètres HA nommée coef-gaz (input_number.coef_gaz)
Je pilote simplement sa valeur depuis l’aperçu HA :

Apercu-HA

Ma question: Comment modifier la déclaration du sensor Gas_NRJ pour qu’il utilise la valeur du Coef-Gaz plutôt que 11.16 gravé en dur ?
Merci d’avance pour votre aide !

Il suffit de modifier ton template.

  - sensor:
    - name: "Gas_NRJ"
      unit_of_measurement: "kWh"
      device_class: "energy"
      state_class: "total_increasing"
      state: "{{ states('sensor.gazpar_lixee_zipulses_summation_delivered')|float * states('input_number.Coef-Gaz')|float}}"
      availability: "{{ states('sensor.gazpar_lixee_zipulses_summation_delivered') not in ['none', 'unknown', 'unavailable'] }}"

C’est ce que j’ai de mon côté

1 « J'aime »

Merci à Gilles pour le yaml qui fonctionne parfaitement. :grinning:
Mais à la réflexion: Chaque modification du Coef-Gaz va affecter le calcul de l’énergie Gaz cummulée depuis la mise en place du capteur. Cela cause une variation brutale (en plus ou en moins selon les cas) de la conso gaz en kWh. et cela modifie les évolutions du passé.
A voir si un sensor de type « incrémental » permettrait d’éviter ça .

Je suis loin d’être un expert et je me trompe peut-être, mais je ne pense pas que la modification de l’input coefficient-Gaz va modifier le sensor. Ce sensor étant du type total_increasing, seules les valeurs suivant la date de la mise à jour de l’input number utiliseront cette nouvelle valeur.

Au sujet de l’autonomie du ZiPulses lorsqu’il est alimenté par pile, (question posée par @Burns35 ):
J’ai branché un boitier de 8 piles AA sur la prise d’alimentation externe (voir photo) et …
Ce n’est absolument pas une bonne solution !!!
En effet, comme cela m’a été expliqué par Fred (de Lixee): L’entrée alim externe passe par un régulateur (qui transforme le 12v en 3.3V) qui consomme beaucoup.
Résultat: Les 8 piles AA se sont vidées en 4 semaines :frowning_face:
La bonne solution a été ajoutée très récemment sur le GitHub:
https://github.com/fairecasoimeme/ZiPulses#alimentation (section « Alimentation externe (custom) »)

1 « J'aime »

Bonjour à tous,
Savez vous s’il y a un « sens » pour brancher les fils qui viennent du compteur gazpar sur le bornier du zipulses ? Je vois qu’un + est noté sur le boitier mais je me demande si cela a une importance. J’ai acheté un câble tout fait avec le connecteur pour le gazpar mais les fils ne sont pas différenciés. J’ai installé/branché mon zipulses hier à 18h et pour l’instant à part la température et la tension batterie, il ne remonte rien. D’où mon interrogation de savoir si je suis bien branché ou non…

Bonjour @Jessy , côté Gazpar c’est un contact sec, donc pas de polarité . Côté ZiPulses, attention à ne pas confondre le bornier d’alimentation externe (polarisé, donc avec un signe +) avec le bornier de branchement des fils du gazpar. Si vous avez branché les fils sur le bornier d’alimentation externe, c.c’est normal de ne pas avoir de conso,

Merci mais heureusement, j’ai bien branché les fils côté comptage et pas du côté alimentation du zipulses :laughing:
Donc j’ai un autre souci.
Je n’ai que ces lignes, rien pour la conso :

{
    "divisor": 100,
    "linkquality": 72,
    "multiplier": 1,
    "temperature": 20.25,
    "unitOfMeasure": "m3",
    "voltage": 2800
}

Je devrais avoir la ligne « energy » mais je n’en ai pas :confused:

Oui, aucune chance que ça fonctionne. Il faudrait tenter un réappairage et s’asssurer d’avoir l’energy.

C’est dommage qu’il soit aussi difficile à faire marcher ce Zipulses ! Le Zlinky est beaucoup plus simple/fiable…

1 « J'aime »

Il faut pas mal insister pour l apparairage et être vraiment à côté d un coordinateur ou router zigbee. Ne pas hésiter à le reset s il ne s appaire pas. Pas de sens de fil pour le comptage .

Après 1 ou 2 resets, j’ai réussi à bien configurer le zipulses. Une bonne semaine d’utilisation plus tard, les relevés de conso correspondent bien à ceux de Grdf :ok_hand:
Ce qui m’inquiète maintenant, c’est la durée de vie de la pile :smiling_face_with_tear: Je suis avec la pile bouton, on lit ça et là qu’elle est morte en 1 ou 2 mois, et on est encore en été ! Alors avec les températures d’hiver…

De mon côté, avec la pile standard, mon ZiPulses fonctionne sur mon Gazpar depuis le mois d’Avril, et la pile indique 2,7V. Pour le moment, pas d’hiver et pas de chauffage, juste l’eau chaude sanitaire.

Merci pour le retour, est-ce possible d’avoir le nombre d’impulsions ? Eau chaude sanitaire pour un célibataire ou une famille de 6 personnes, ça peut aller du simple au sextuple ! :slight_smile:

Grande maison, 5 personnes. Où puis-je trouver le nombre d’impulsions? Summation delivered indique 45 000 environ

Le CurrentSummationDelivered correspond au nombre d’impulsions justement. Ça sera l’équivalent d’à peu près un mois de chauffage en plein hiver pour moi. Merci.

Vous la trouvez où cette valeur « CurrentSummationDelivered » ? Je suis sous HA et Z2M, je ne vois pas cette valeur ?

Le champ s’appelle Energy dans Z2M. Attention, il se remet à zéro quand on fait un réappairage (c’est dommage d’ailleurs).

Ha ben non, moi j’ai directement les M3 dans « energy » vu que je mesure du gaz…