Migration zigbee2mqtt jeedom to HA

Bonjour,

Je viens vers vous car je suis en cours de migration de jeedom ver HA.
Il ne me reste que zigbee2mqtt à migrer.

Je ne souhaite pas tout réinclure.

J’ai donc récupérer coté jeedom la sauvegarde de zigbee2mqtt

Je me suis donc connecté sur le sambashare de HA pour y coller mes fichiers

J’ai donc copié mes fichiers dans ce repertoire, sauf configuration.yaml

Puis j’ai configuré l’addon :

J’ai une conbee 2

Le addon démare bien. C’est déjà une bonne chose.

Mais mes modules restent injoignables

Je ne comprends pas bien pourquoi …

Je constate que mes friendly name ont disparu. Savez vous pourquoi ?

J’ai vérifié le channel, jeedom et HA sont en 11.

Une histoire de configuration du reseau zigbee ? Ext pan id et pan id ?

Voici ce que j’ai sur jeedom

J’ai bien éteint jeedom pour faire le test.

Votre aide serait très précieuse, car jeedom tourne seulement pour zigbee2mqtt.

Merci d’avance

Ma configuration


[center]## System Information

version core-2024.5.2
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.12.2
os_name Linux
os_version 6.6.25-haos
arch x86_64
timezone Europe/Paris
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 4944
Installed Version 1.34.0
Stage running
Available Repositories 1399
Downloaded Repositories 9
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 12.2
update_channel stable
supervisor_version supervisor-2024.04.4
agent_version 1.6.0
docker_version 25.0.5
disk_total 30.8 GB
disk_used 12.6 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons Mosquitto broker (6.4.0), File editor (5.8.0), Node-RED (17.0.12), MQTT Explorer (browser-1.0.3), Studio Code Server (5.15.0), Advanced SSH & Web Terminal (17.2.0), Vcontrol add-on (1.10.1), Zigbee2MQTT (1.37.0-1), Z-Wave JS UI (3.6.0), EMQX (0.5.1), Log Viewer (0.17.0), Samba share (12.3.1), InfluxDB (5.0.0), MyElectricalData (0.12.0)
Dashboards
dashboards 3
resources 3
views 5
mode storage
Recorder
oldest_recorder_run 3 mai 2024 à 13:18
current_recorder_run 7 mai 2024 à 20:18
estimated_db_size 500.86 MiB
database_engine sqlite
database_version 3.44.2
[/center]

Bonjour,
essaye de réveiller un appareil , genre les thermomètres aqara, clique sur le petit bouton.
Que le réseau ce reconstruise.

Les friendly name, sont dans le configuration.yaml de Z2M ( ou un autre fichier si ta découper la configue). recopie les du Z2M de jeedom.

1 « J'aime »

Salut,

Et pour que les infos des zigbee soient prises en compte par HA, il faut aussi lui configurer le MQTT dans lequel z2m envoie les infos.
Au passage emqx, c’est pas le plus léger des brokers

1 « J'aime »

Merci pour vos retour.

Il me manquait la key du réseau zigbee

Vous m’avez bien orienté en me parlant du fichier de config

Merci à vous deux

Bonjour; j’ai le meme probleme, ou se trouve la key du reseau zigbee @beber53 ?
[EDIT]: c’est la network key — trouve. Merci

Bonjour,
Je suis bloqué sur le meme problème.
J’ai bien rajouté le network_key mais ça ne change rien.
Tous mes devices sont bien listés mais pour chacun d’eux, la valeur de « Vu pour la dernière fois » reste sur N/A et la Disponibilité sur Désactivé.
@afawaz et @beber53 pourriez-vous nous expliquer les différentes étapes svp ?
Merci par avance

@slin43 ce que j’ai fait:
J’ai installé zigbee2mqtt puis je l’ai arrêté.
J’ai copié le répertoire data dans un premier temps sans le configuration.yaml.
après démarrage et configuration de zigbee2mqtt sur HA comme ici : Comment installer MQTT et Zigbee2MQTT sur Home Assistant 2024?
Les devices a ce stade était visible mais pas moyen de les piloter,
j’ai comparé les deux configuration.yaml et j’ai mis la nouvel network key.
Apres redémarrage ca a bien fonctionné.

1 « J'aime »

Merci pour ta réponse.
Je viens de tout recommencer sans succès …
J’ai pas l’impression que le network_key soit pris en compte.
Voici ce que je vois dans le configuration.yaml (fichier dans \192.168.2.30\config\zigbee2mqtt) :

homeassistant: true
advanced:
  network_key:
    - 83
    - 87
    - 11
    - 14
    - 226
    - 237
    - 34
    - 243
    - 69
    - 221
    - 80
    - 114
    - 192
    - 187
    - 253
    - 117
  pan_id: 46485
  ext_pan_id:
    - 179
    - 184
    - 244
    - 14
    - 146
    - 188
    - 200
    - 21
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://core-mosquitto:1883
  user: mqtt_adm
  password: blabla
serial:
  port: /dev/ttyACM1
  adapter: deconz
frontend:
  port: 8099
devices:
  '0x00158d0003059013':
    friendly_name: '0x00158d0003059013'
...

et voici le code yaml directement dans la config de l’addon Z2M dans HA :

data_path: /config/zigbee2mqtt
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
mqtt:
  server: mqtt://core-mosquitto:1883
  user: mqtt_adm
  password: blabla
  base_topic: zigbee2mqtt
serial:
  port: /dev/ttyACM1
  adapter: deconz

Je ne comprends pas pourquoi ces 2 codes ne sont pas similaires, ça ne me semble pas cohérent.

La network_key visible dans le 1er est bien issue du configuration.yaml issue de Jeedom.

Toute aide serait TOP ! :grin:

J’ai comparé tes données au miens, je ne vois pas bcp de differences:

  homeassistant_legacy_entity_attributes: false
  legacy_api: false
  legacy_availability_payload: false

c’est la seule chose que j’ai en plus dans la section advanced !
As tu pris la meme panID () ZigBee pan ID, changing requires repairing all devices! et l’extPan ID ?

et Est tu sur que le device est correct ? /dev/ttyACM1
Tu peux aller dans System → Materiel , pour l’exemple , moi j’ai ca :
/dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20231215150902-if00
avec ezsp comme adaptateur.

Nous avons pas peut etre pas le meme dongle zigbee .

1 « J'aime »

Merci @afawaz d’avoir pris le temps de me répondre :+1:
J’ai pris en compte tes remarques et tout comparé 15 fois, mais impossible de comprendre;
J’ai fini par ré-appairé les 50 équipements car déjà perdu trop de temps la dessus :wink:
Ça fonctionne forcément du coup
Bonne journée

1 « J'aime »