Mise à jour OS Impossible

Bonjour tout le monde !:slightly_smiling_face:

Je m’excuse d’avance si j’ai potentiellement mal cherché mais je n’ai pas vraiment trouvé de solution à mon problème que ce soit sur des groupes facebook ou alors des forum en anglais…

Depuis quelques moi je n’arrive pas a faire les mise à jour. Cela tourne dans le vide. Je n’ai pas trop eu le temps de m’y pencher ses derniers temps mais j’aimerais bien résoudre ce problème.

record_230328_170420

Cela peut rester des semaines comme ça. Si je redémarre HA c’est pareil et si j’éteins le Raspberry PI cela ne tourne plus dans le vide mais le mise à jour n’est pas faire et si je relance rebelotte.

J’ai bien essayer de lancer seulement la mise à jour de l’OS mais j’ai ce message d’erreur :

Dans les logs un peu la même chose :

Si jamais vous avez des infos/des pistes je suis preneur !:wink:

Ma configuration


System Information

version core-2022.11.0b0
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.10.5
os_name Linux
os_version 5.15.61-v8
arch aarch64
timezone Europe/Paris
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.27.1
Stage running
Available Repositories 1249
Downloaded Repositories 11
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 9.3
update_channel beta
supervisor_version supervisor-2022.11.0
agent_version 1.4.1
docker_version 20.10.18
disk_total 219.4 GB
disk_used 8.5 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons Duck DNS (1.15.0), File editor (5.4.1), deCONZ (6.17.0), Terminal & SSH (9.6.1), Studio Code Server (5.4.0)
Dashboards
dashboards 2
resources 9
views 4
mode storage
Recorder
oldest_recorder_run 14 mars 2023 à 18:24
current_recorder_run 29 mars 2023 à 21:00
estimated_db_size 105.13 MiB
database_engine sqlite
database_version 3.38.5
___

Salut

Il semblerait que tu arrives quand même a te connecter

Je ferais un BACKUP complet
Je ne sais pas comment est installé to HA soit sur SD soit sur SSD

Moi je repartirais sur une nouvelle installation avec restauration

quand tu installes HAOS,
lors de la fenêtre initiale ou tu définis ton login et mot de passe en bas tu as la possibilité de restaurer un backup

il faudra certainement procéder a un redémarrage complet de ton PI pour que toutes les dependances puissent s’installer

Merci de ta réponse,

J’ai oublié de précisé aussi que je ne peut pas faire de sauvegarde, j’ai ce message d’erreur :

Mon dernier backup remonte à 5 mois en arrière…

Si vraiment je n’ai pas d’autre solution je ferais comme tu as dis, mais il s’en est passé des modifications depuis 5 mois… :confused:

ce que tu peux essayer de faire c’est si tu peux accéder a ton configuration.yaml
c’est de récupérer tout cela via samba
pareil si tu as des intégrations essayer de copier le max de choses
puis de repartir sur une base saine