Modifier les paramètres d'un FGS-214

Hello !

Je cherche à changer un paramètre de mes FGS-214.
Par défaut, le contact est « ouvert », et je veux modifier le paramètre en « normalement fermé ».

Dans la doc j’ai trouvé ceci :

J’ai fait le tour de HA, mais je ne trouve rien (par exemple du côté Zwave et des paramètres de ce modules, comme je l’ai fait pour d’autres modules, là la liste des paramètres est vide, ça ne s’ouvre pas).

Connaissez-vous, svp, la bonne méthode ?

Merci :slight_smile:

De mémoire (ça vaut ce que ça vaut :upside_down_face:), il me semble que HA utilise Open Zwave et ton module semble ne pas encore être pris en charge (dans la liste, ça s’arrête à FGS213)…

Il faut attendre la prise en charge dans un premier temps par Open Zwave (git) puis son intégration dans HA.

Peux être qu’en utilisant les services (d’abord `print_config_parameter).

Merci pour ta réponse.

Je n’ai pas d’Open Zwave.
J’ai installé Zwave via INTEGRATIONS.

Tout fonctionne (prise connectée, différents modèles de relais, thermostats, etc), mes relais sont bien liés aux thermostats (par exemple).

Je vais aller voir ton dernier lien, merci.

Je suis allé voir les services, je trouve bien le print_config_paramter, mais je ne comprends pas comment l’exploiter.

Il faut vraiment que je modifie ce paramètres (inverser le OUTPUT TYPE), c’est pour commander mes groupes de radiateurs.
Le FGS-214 a un seul contact, le FGS-224 est le même mais en double contact, ce dernier est listé chez OpenZwave).

J’avoue que je ne trouve pas la sortie de cette commande

J’ai eu du mal mais j’ai trouvé… Les logs ne remontent apparemment pas dans l’interface web.

Il faut :

  • arrêter HA (je l’ai fait en SSH :
    ha core stop

  • puis modifier le fichier de configuration configuration.yaml pour y ajouter :
    logger:
    default: info
    Ce qui change le niveau d’enregistrement des logs (journaux).

  • il faut relancer HA et attendre un peu ensuite que Zwave démarre :
    ha core restart

dans service, choisir : zwave.print_config_parameter
Puis dans le champ « Données de service » écrire ceci (c’est un exemple) :
node_id: 26
parameter: 162

puis cliquer sur APPELER LE SERVICE

Ensuite il faut aller lire le fichier home-assistant.log

Une fois qu’on a terminé, il faut STOPER HA, commenter les 2 lignes pour le log en ajoutant un # devant les 2 lignes, sauvegarder le fichier puis relancer HA (tout ça pour ne pas remplir le log inutilement.

Ca me montre donc ceci :

2020-11-06 11:35:21 INFO (SyncWorker_27) [homeassistant.components.zwave] Config parameter 162 on Node 26: None

Donc le paramètre 162 de mon module 26 n’est pas remonté. Donc je ne risque pas de pouvoir le modifier :’(

1 J'aime

Merci pour la méthode ! :+1:

Effectivement, cela ne semble pas très prometteur…

Est-ce que tu as regardé le contenu de ton fichier zwcfg_*.xml ?
Ce fichier se trouve au même niveau que ton fichier configuration.yaml

Peut être y trouveras tu un mot clé pour continuer tes investigations

Le node 26 est le dernier de ce fichier.
Il y a plein de ligne, mais nop, ça ne me donne pas de piste.

Comment savoir si un module est listé comme prochainement supporté par HA ?
Ou comment en faire la demande ? Est-ce possible ?

L’intégration Zwave de HA est basé sur la compatibilité de Open Zwave.

Donc faut regarder du côté de OZW.

Sinon faut regarder si tu peux pas ajouter la compatibilité en remplaçant 214 par 224.

:warning: Aucunes responsabilités en cas de problème ! C’est quand même du 220V qui passe ! Fait attention à toi ! On sait jamais…

juste pour info, j’ai des modules FGS-224 et effectivement il ne sont pas bien reconnu sous HA via l’integration z-wave.
image

Peut-etre attendre la maj des modules sous openzwave… :man_shrugging:

Est ce que tu peux tout de même les utiliser ?

oui, par contre il m’indique des entités en plus.
par ex j’ai 3 switchs, seul les 2 premiers fonctionnent.

C’est déjà mieux dans ce sens ! :joy:

:grinning: c’est clair

bon apres j’ai un tas d’appareils en plus

ca devient vite le bazar!!
j’espere qu’ils vont faire la maj rapidement histoire de remettre un peu d’ordre!! :wink:

as-tu accès aux paramètres ? Car j’ai besoin de modifier pour le mettre en « normalement fermé »

non je n’ai pas accès aux paramètres.
Dans mon cas ca ne pose pas de pb car je n’en ai pas besoin.
mais pour toi, c’est embetant…dsl