MyElectricalData

@ClassicRed, Je n’ai pas crée de nouveau post car la nouvelle version est en ligne et enedisgateway2mqtt est devenu obsoléte et en fin de vie.

Pour les gens qui ont des erreurs SQL au démarrage, la plus simple est de supprimer le fichier cache.db et de relancer l’intégration mais attention vous allez perdre tt l’historique dans le cache.

Pour les gens qui viennent de migrer depuis EnedisGateway2MQTT, MyElectricalData effectue une migration des données avec la méthode suivante :

  • Tranfert des consommation/production depuis enedisgateway.db vers cache.db
  • Renomage du enedisgateway.db en enedisgateway.db.migrate
    Vos anciennes données sont tjr disponible dans le enedisgateway.db.migrate si besoin.

Pour migrer proprement depuis enedisgateway et avant la migration vers une version 0.8.X :

  • Arrêter l’integration
  • Backup le fichier enedisgateway.db (au cas où)
  • Rename l’actuel en enedisgateway.db.wait
  • Migrer en 0.8.X, Attention le fichier de config à changé vous pouvez reprende l’exemple ici
  • Démarrer en 0.8.X pour init la le nouveau cache.
  • Arrêter l’integration.
  • Rename le enedisgateway.db.wait en enedisgateway.db
  • Re-lance l’intégration, il va migrer les anciennes données dans le nouveau cache.
    Et normalement tt est bon !

Pour ceux qui aurais eu un soucis lors de la migration et souhaite récupérer leur ancienne données en cache.

  • Arrêter l’intégration
  • Supprimer le cache.db
  • Démarré l’intégration pour init correctement le cache.db
  • Arrêter l’intégration
  • Reprendre le backup (où le enedisgateway.db.migrate) et le positionner au même endroit que le cache.db avec le nom enedisgateway.db
  • Lancer l’intégration en v0.8.X
  • L’import du enedisgateway.db vers cache.db ce fera au lancement + un rename de enedisgateway.db en enedisgateway.db.migrate.
    Et normalement tt est bon !

Si vous avez tjr un soucis, go crée une issue sur Github, je n’assurerais plus de support sur le forum car impossible à suivre.

@M4dm4rtig4n :
dans la dernière version, il n’y a plus le sensor
sensor.enedisgateway_XXXXXXXXXXXXXXXXXX_hourly ?

Correcte… que UN sensor reste : sensor.myselectricaldata_numeroPDL

Je me répond à moi même.
J’ai relue l’ensemble de ce post et j’ai découvert que @M4dm4rtig4n avait donné un exemple que je remets ici au cas ou quelqu’un en aurait besoin.

INFLUXDB_ENABLE="True"
INFLUXDB_HOST="influxdb"
INFLUXDB_PORT=8086
INFLUXDB_TOKEN="admin:admin"
INFLUXDB_ORG="-"
INFLUXDB_BUCKET="test/autogen"

pour mon cas, j’ai crée une nouvelle base dans influxdb Version: 1.8.10 que j’ai nommé « myelectricaldata » et cela semble fonctionner.
voici la partie concernée de mon fichier config.yaml

influxdb:
  enable: true
  hostname: 192.168.x.xx
  port: 8086
  token: myelectricaldata:myelectricaldata
  org: "-"
  bucket: "myelectricaldata/autogen"
  # ATTENTION, L'activation de l'importation asynchrone va réduire fortement le temps d'importation dans InfluxDB
  # mais va augmenter drastiquement la consommation mémoire & CPU.
  # À activer uniquement sur un hardware robuste (et pas sur un Raspberry ou autre par exemple).
  asynchronous: 'false'

en ajoutant quec’est pas une config pour influx v2

1 « J'aime »

Possible que je ne l’ai pas reprit, après tu as une flopper d’information disponible directement dans MQTT

Libre à toi de crée un sensor dans HA qui va allez recupérer l’information que tu cherche directement dans MQTT.

Idem, si ils vous manques des informations que vous désirez voir apparaitre dans MQTT go me crée une issue sut Github

Hello, depuis ma réinstallation, je n’ai plus d’erreur.
Par contre, je n’arrive pas à obtenir les données de la veille. Quelqu’un a déjà rencontré ce souci ?

timeLastCall: 2022-12-05 08:41:38
yesterdayDate: 2022-12-04
yesterday: 0
yesterdayLastYearDate: 2021-12-05
yesterdayLastYear: 0
daily: 0, 36.5, 35.4, 22.5, 30, 29.1, 25.4
current_week: 178.9
last_week: 198.9
day_1: 0
day_2: 36.5
day_3: 35.4
day_4: 22.5
day_5: 30
day_6: 29.1
day_7: 25.4

Salut,
chez moi c’est pas mieux j’ai même des consos très loin du réel.
Je pense qu’il faut attendre quelques jours pour que tout soit normal.

timeLastCall: 2022-12-05 08:49:42
yesterdayDate: 2022-12-04
yesterday: 0
yesterdayLastYearDate: 2021-12-05
yesterdayLastYear: 0
daily: 0, 0, 370.3, 353.3, 402.9, 367.9, 388.9
current_week: 1883.3
last_week: 2366.2
day_1: 0
day_2: 0
day_3: 370.3
day_4: 353.3
day_5: 402.9
day_6: 367.9
day_7: 388.9

Bonjour,
Idem chez moi le hier d’hier est arrivé aujourd’hui.

Hello

@gag78 , @telenaze , @Floww77
Soyez patient
@M4dm4rtig4n , fais de son mieux pour corrigé les soucis

et comme il 'a dis et demandé , il ne fera plus de support sur le forum

Toutes les bugs et anomalies , vous devez les remonté sur son github.

hello !, pas de pb, j’ai créé une issue.
L’idée était de partager le pb dès fois que j’ai loupé quelque chose dans la conf :wink:

je n’ai toujours pas récupéré les données de la semaine passée (donc celles d’hier non plus). Pourtant je ne vois pas que j’ai dépassé le quota journalier cette fois ci…du coup je me pose des questions si tout reste compatible avec la card si il manque des sensors. Il faut les réadapter ?
Je ne vois pas de sensor.myselectricaldata_numeroPDL pour ma part dans mes outils de dev…

Il fau avoir ça, peut-être ton config n;'est pas bon, est-ceque tu voix les données dans ton MQTT?

@Stef_42

modifie ta config tout simplement

j’ai une erreur maintenant :

2022-12-06 13:31:39.416 - CRITICAL :  L'export Home Assistant est dépendant de MQTT, merci de configurer MQTT avant d'exporter vos données dans Home Assistant
2022-12-06 13:31:39.424 -    ERROR : Job "fetch_data_boot (trigger: date[2022-12-06 13:31:28 CET], next run at: 2022-12-06 13:31:28 CET)" raised an exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/apscheduler/executors/base.py", line 125, in run_job
    retval = job.func(*job.args, **job.kwargs)
  File "/app/models/jobs.py", line 157, in job_import_data
    app.LOG.critical("L'export Home Assistant est dépendant de MQTT, "
  File "/app/models/log.py", line 97, in critical
    sys.exit()
SystemExit

poste ta config

vire des tokens et info perso avant

tu as bien mqtt installé ?
car

Je pense qu’il fallait aussi mettre « enable : true » dans la section mqtt
Malheureusement il y a un souci ailleurs :

Traceback (most recent call last):
  File "/app/main.py", line 55, in <module>
    hostname=MQTT_CONFIG["hostname"],
KeyError: 'hostname'
[13:43:21] FATAL: The app has crashed. Are you sure you entered the correct config options?

Voici mon config :

cycle: 14400
debug: false
home_assistant:
  card_myenedis: true
  discovery_prefix: homeassistant
  enable: true
influxdb:
  asynchronous: 'false'
  bucket: myelectricaldata
  enable: false
  host: influxdb
  org: myelectricaldata
  port: 8086
  token: XXXXXXXXXXX
mqtt:
  client_id: myelectricaldata
  enable: true
  host: core-mosquitto
  password: 'MonMDP'
  port: 1883
  prefix: myelectricaldata
  qos: 0
  retain: true
  username: 'MonUsermqtt'
myelectricaldata:
  "monPDL":
    name: "Maison"
    cache: true
    consumption: true
    consumption_detail: true
    consumption_detail_max_date: ''
    consumption_max_date: ''
    consumption_price_base: 0.1303
    enable: true
    plan: BASE
    token: "MonToken"
    refresh_addresse: true
    refresh_contract: true

J’ai essayé host: mosquitto mais même résultat…

ton erreur est la

host: core-mosquitto

remplace par

hostname: core-mosquitto

essai avec le mien adapte tes tokens et info perso

cycle: 14400
debug: false
home_assistant:
  card_myenedis: true
  discovery_prefix: homeassistant
  enable: true
influxdb:
  enable: false
  hostname: a0d7b954-influxdb
  port: 8086
  token: xxxxxx:xxxxxxx
  org: "-"
  bucket: "myelectricaldata/autogen"
mqtt:
  client_id: myelectricaldata
  enable: true
  hostname: core-mosquitto
  password: EdXXXXXXXX
  port: 1883
  prefix: myelectricaldata
  qos: 0
  retain: true
  username: XXXXXX
myelectricaldata:
  212XXXXXXXX49:
    name: Maison
    cache: true
    consumption: true
    consumption_detail: true
    consumption_detail_max_date: ''
    consumption_max_date: ''
    consumption_price_base: 0.20
    consumption_price_hc: 0
    consumption_price_hp: 0
    enable: true
    offpeak_hours_0: ''
    offpeak_hours_1: ''
    offpeak_hours_2: ''
    offpeak_hours_3: ''
    offpeak_hours_4: ''
    offpeak_hours_5: ''
    offpeak_hours_6: ''
    plan: BASE
    production: false
    production_detail: false
    production_detail_max_date: ''
    production_max_date: ''
    production_price: 0
    token: NNuI3xiMCXXXXXXXXXXXXXXXXXXXXXXX
    refresh_addresse: true
    refresh_contract: true

Tu avais la bonne info avant … Dommage

Par contre cela s’adapte comment par rapport à la card Sanilho ? Car j’ai des données ça donne n’importe quoi…
image