Nouveau thermostat type proportionnel avec gestion des presets / portes et fenêtres / détection de mouvement / gestion de présence et surconsommation

Tout d’abord, désolé pour le formatage, je débute sur HA comme sur les forums :sweat_smile:
J’ai bien vu cette option de config centrale que j’ai décochée mais rien n’y fait… D’ailleurs, il est bien indiqué « is_controlled_by_central_mode: false » dans de mon senseur. Je sais très bien que je ne suis pas à l’abri d’avoir fait une boulette mais j’essaie de bien prendre mon temps pour lire chaque étape et le GitHub de l’intégration.
Je viens de refaire ma config pour la énième fois et j’ai bien l’impression que c’est ma première vanne que j’ai configurée qui agit en config centrale sur les autres alors que je l’ai toujours décochée.
Bref, je tiens ma config en « pseudo centrale », c’est toujours mieux :wink:
PS: si tu peux intégrer plusieurs capteurs d’ouvertures à l’avenir, ça pourrait être pas mal (Pièce traversante avec baies vitrées de part et d’autre).
PS Bis: Merci de prendre de ton temps de répondre aussi vite!

Ca n’a rien à voir ça. C’est pour commander tous les VTherms de façon centralisée (tous les passer en Hors Gel avant de partir en vacances par exemple).

En fait je ne sais pas ce que tu veux faire, ce qui est un soucis pour aider.

Est-ce que tu veux que le VTherm: VT Cuisine ait ses propres preset ou tu veux qu’il utilise les preset de la config centrale ?
Si tu veux qu’il ait ses propres preset, il faut décocher la case (dans la config pre-reglages du VTherm) :
Capture d’écran 2024-04-01 à 16.49.47

Tu dois être en v6.xx évidemment pour que ça marche.

J’ai essayé de décrypter les lignes mais ça ne devait pas être la bonne alors :smiley:
J’ai une douzaine de radiateurs, chaque pièce à son radiateur propre avec sa vanne (sauf le salon qui a 3 radiateurs et 2 baies vitrées avec capteurs), je les connecte avec le thermomètre bien situé dans la pièce pour que ce soit au plus près de la température ressentie, les capteurs d’ouverture de fenêtres/porte pour l’arrêt automatique de chaque radiateur. Le tout en config locale.
D’ailleurs, ta V6 devrait bien corriger le problème que j’avais de mise en sécurité que j’avais pour certaines pièces ;).
Pour résumer, j’aimerais juste gérer mes radiateurs en config locale comme j’y arrivais très bien avant la V6. Je fais bien attention à décocher tout ce qui concerne les config centrales mais c’est toujours ma première vanne configurée qui prend le rôle de config centrale…
Merci encore pour tes réponses et ton indulgence pour mes questions de débutant! D

Bonjour @Jean-Marc_Collin ,
J’ai peur de pas bien comprendre le last_seen. On peut mettre le même thermomètre (le seul que j’ai dans la chambre) dans les 2 champs ?

On peut passer en MP ? On va regarder plus en détail, je comprends pas cette histoire de première vanne qui prend le role de config centrale. Ca ne veut rien dire pour moi.

Hello @chrisdelt ,

Non. Il faut avoir une entité de type sensor qui s’appelle last_seen. Souvent il faut explicitement lui demander de la créer. Il faut aller dans Paramètres / Appareils. Chercher son thermomètre.
Par exemple j’ai ça pour mon thermomètre Zigbee de la chambre:
Capture d’écran 2024-04-01 à 23.56.48

Si jouvre le « +2 entités non affichées », je vois last_seen:
Capture d’écran 2024-04-01 à 23.58.05

Il faut cliquer dessus et l’activer:
Capture d’écran 2024-04-01 à 23.59.15

Après qqes minutes elle devient visible et est valorisée, on peut alors la mettre dans le VTHerm (sous la température) :

A chaque fois qu’elle sera mise à jour, le VTherm rafraichira la date de dernière vue du thermomètre même si la température n’a pas changée.

1 « J'aime »

Bonjour.
C’est mon 1° message et je te remercie pour tout le travail que tu fait :slight_smile:
Je n’arrive pas a trouver où ce gerre la partie puissance du radiateur en Watt pour le delestage.

Hello @Jax24fr ,

C’est dans la première page (Principaux attributs) même si je te l’accorde qu’elle serait mieux dans la page de gestion de la puissance.

1 « J'aime »

Top, merci beaucoup !

Bonjour,

Depuis la mise à jour d’hier, les thermostats ne semblent plus envoyer les bonnes valeurs de consigne à mes têtes Danfoss Ally. Elles ne chauffent plus et restent bloquées à 5 degrés en permanence, quelle que soit la consigne que j’indique. En gros, on dirait que la valeur d’ouverture des vannes n’est plus transmise aux têtes ou à minima la maintient fermée (5deg).

Si je mets manuellement 25 degrés sur une tête de radiateur, la température revient à 5 degrés après quelques secondes. J’ai 7 têtes et le problème est identique sur toutes.

Merci pour votre aide et vos conseils.

Voici un screen qui devrait mieux expliquer ce qui se passe. Le Thermostat est censé ouvrir la vanne à 100% mais elle reste fermée.

Hello, la modif d’hier (6.2.1) consiste à plafonner l’envoi sur les valves en utilisant le max qui est indiqué dans le number.max.
Certaines valves ont des valeurs qui vont jusqu’à 255 et non 100 comme les autres.
Donc le calcul a été changé pour avoir number.max x pourcentageOuverture/100 au lieu de simplement de pourcentageOuverture.

Peux-tu vérifier ce max sur l’entité qui représente la vanne commandable ?

Et retour en arrière stp le temps de comprendre.

Merci pour le retour,

L’entité s’appelle « number.radiateur_salle_de_bain_2_occupied_heating_setpoint_scheduled » et c’est une valeur entre 5 et 35

La 6.2.0 ne fonctionnait pas non plus, je suis repassé en 6.1.0 et tout est OK maintenant

Non c’est pas ça qu’il faut regarder. Ca c’est la température. Il faut l’entité qui pilote l’ouverture de la vanne.
Attend j’ai un doute, tu essayes bien de piloter directement l’ouverture de la vanne via un VTherm de type over_valve ?

RE,

C’est le seul moyen que j’ai trouvé pour ouvrir ou fermer mes vannes Dansfoss Ally. Si il y a un autre moyen de faire plus propre je suis preneur :slight_smile:

L’entité "number.radiateur_salle_de_bain_2_occupied_heating_setpoint_scheduled " c’est celle indiquée dans les "attributs de(s) l’entité(s) liée(s) → 1ère valve

Voici toutes les entités de la vanne (j’en ai 7 toutes pareilles)

Ca ne va pas marcher. heating_setpoint_scheduled c’est une température et pas un pourcentage d’ouverture. Les VTHerm over valve commande l’ouverture de la vanne directement en pourcentage (de 0 à 100).
Si tu n’as pas d’entité Number qui commande le pourcentage d’ouverture de la vanne, tu ne peux pas utiliser le VTHerm over valve mais tu dois utiliser le VTHerm over climate (si tu as bien une entité climate pour piloter ton TRV).

Je vois un climate.radiateur_salle_de-bain2 qui m’a l’air d’être le bon. Ce sera moins précis mais ca marche pas si mal avec l’auto-regulation.

Tu ne peux pas transformer le type d’un VTherm donc tu vas devoir le supprimer et le recréer.

Ok, merci pour le tips, je vais essayer comme ça alors.

En français c’est « Thermostat sur un autre Thermostat » c’est bien ça ?

1 « J'aime »

Je viens d’en monter un et j’ai quelques questions.

Comment on active cette « auto-régulation » ? c’est la tête de radiateur qui gère du coup ?, elle va elle même ouvrir et fermer la vanne pour atteindre la température désirée ? Du coup si c’est bien ça, la tête de vanne utilisera son thermomètre interne donc très imprécis.

Le thermostat ne fait que règler la tête à la même température que celle fixée dans le mode ? Ca va donc prendre beaucoup plus de temps pour chauffer une pièce à la température désirée c’est juste ? et à quoi sert le thermomètre externe dans la configuration thermostat ?

Désolé, mes questions doivent etre un peu stupides mais mon chauffage fonctionnait de cette manière sous Jeedom déjà, j’ai un peu de peine à comprendre cette autre façon de gèrer son installation.

Regarde un peu la doc, y a toutes les réponses dedans.

1 « J'aime »

Bonjour
J’ai depuis l’update une problème, le chauffage est en mode safety

J’ai ça comme erreur depuis la dernière mise à jours de versatile.

Proportional algorithm: calculation is not possible cause target_temp (18.0) or current_temp (None) is null. Heating/cooling will be disabled. This could be normal at startup

Je retente le redemarrage de HA et ça semble corriger le problème

Ton capteur de température ne donne pas la température manifestement.