Ouverture carte à partir d'une image sur floorplan

Mon problème

Bonsoir, j’aimerais ouvrir une carte que j’ai crée en cliquant sur une image présente sur mon floorplan et je bloque.

Les 2 codes sont en dessous, celui de la carte et probablement celui a mixe de l’image dans le floorplan.

 - type: image
    entity: vacuum.yo_tonte
    image: local/Tondeuse.jpg
    style:
      left: 52%
      top: 85.4%
      width: 10.15%

image: default
image_size: '7'
show_animation: true
show_status: true
show_toolbar: false
type: custom:landroid-card
entity: vacuum.yo_tonte
image_left: false
compact_view: false
show_name: false

Salut,

2 sujets pour la même question, c’est de la gourmandise :wink:

Et pour répondre à ta question, je te propose de regarder tout ce qui concerne les popup

Mon problème

Bonsoir, j’essaye a partir d’une image sur mon floorplan de la renvoyer au tableau de bord énergie.
Pouvez vous m’aider j’ai regarde plusieurs posts mais je ne les comprends pas.
Merci d’avance :slight_smile:

 - type: image
    image: /local/Solaire.png
    navigation_path: /lovelace/Énergie
    style:
      left: 72.5%
      top: 12.6%
      width: 2%

Bj
Tu es sur de ton chemin ?

PS : évite les majuscules privilégie : solaire au lieu de Solaire

1 « J'aime »

Et les accents c’est pareil… à eviter

1 « J'aime »

Mince, ca marche quand même :sweat_smile:

Dans le nom d’image oui, mais dans le path, c’est prendre un risque. Pour navigation_path: /lovelace/Énergie et navigation_path: /lovelace/energie, rien que pour saisir un accent majuscule dans le navigateur c’est pas direct.
Et puis, même si ça marche, la gestion des espaces/accents entre windows/unix/navigateur dans les noms de fichiers/répertoires c’est pas toujours simple.
Du point de vue visuel, que ce soit été.png ou ete.png pas de différence donc autant éviter de se mettre des bâtons dans les roues.

2 « J'aime »

Salut…
Pour reprendre ta config
si tu es sûr que Solaire.png existe bien dans le répertoire de ton HA devrait être :

  • /config/www/Solaire.png

La syntaxe devrait être

    image: /local/Solaire.png
    tap_action:
      action: navigate
      navigation_path: /energy

Il est vrai qu’il faudrait s’habituer à ne pas mettre majuscule et accentuation!
Même si cela fonctionne !
Edit : il est bien de faire des sous répertoires dans www et d’y mettre les entités voulues.

  • image
  • audio
  • etc…

la totale pour ce que tu présentes

- type: image
    image: /local/Solaire.png
    tap_action:
      action: navigate
      navigation_path: /energy
    style:
      left: 72.5%
      top: 12.6%
      width: 2%

PS

Pour retrouver facilement le nom du « lovelace » que tu veux, il faut regarder le lien lors de son accès par ton navigateur

http://adresse_ip:port/dashboard-camera/ext-bureau

l’accés serait:

    tap_action:
      action:  navigate
      navigation_path: /dashboard-camera/ext-bureau

Bonsoir,

Un grand merci a tous, je suis ravie le renvoi marche parfaitement;
C’est promis, je vais améliorer ma sémantique.
Grand merci pour vos conseils.
Très bonne soirée

Yoann