Probleme d'acces depuis l'exterieur et DuckDNS

Bonjour,

(décidément, j’ai pas de bol^^)

Je tente l’accès extérieur au HA, je suis le tuto Accès extérieur depuis DuckDNS

et quand je veux save la partie config, j’ai droit à

Échec de l'enregistrement de la configuration du module complémentaire, Missing required option 'domains' in Duck DNS (core_duckdns). Got {'aliases': [], 'domains': [None], 'lets_encrypt': {'lets_encrypt': {'accept_terms': True, 'certfile': 'fullchain.pem', 'keyfile': 'privkey.pem'}, 'token': 'xxxxxxxx', 'domains': ['xxxx.duckdns.org'], 'seconds': 300}, 'seconds': 300, 'token': None}

J’ai loupé un truc ?

Config :
Home Assistant Core 2022.5.4
Home Assistant Supervisor 2022.05.3
Home Assistant OS 7.6
Kernel version 5.10.108
Agent version 1.2.1

Manifestement il manque le mot clé domains dans la config
image
Au passage j’ai caché ton nom de domaine :saluting_face:

Merci :slight_smile:

pourtant j’ai copié coller ton bout de code et changé que le token et le sous domaine :

lets_encrypt:
  accept_terms: true
  certfile: fullchain.pem
  keyfile: privkey.pem
token: xxxx-xxxx-xxxxx-xxxxxxx
domains:
  - monsousdomaine.duckdns.org
seconds: 300

je viens de refaire encore et pareil

Tu as vérifié que le bon domaine / token et que c’est bien ‹ à toi › ?
Sauf erreur si je reprends celui d’hier, ça tombe loin de l’europe …
Tu peux comparer si tu veux entre :
Quel Est Mon IP - WhatIsMyIP.com® qui donne ton adresse ip ublique
Online Ping, Traceroute, DNS lookup, WHOIS, Port check, Reverse lookup, Proxy checker, Bandwidth meter, Network calculator, Network mask calculator, Country by IP, Unit converter qui va te donner l’adresse associée au domaine

oui c’est bien mon sous domaine et bien mon ip qui tombe sur mon FAI en france.

Je crois que hier j’avais mis un truc au pif pour pas mettre le mien.

quand je fais un tracert de monsousdomaine.duckdns.org je retombe bien sur mon ip

je suis en full stack chez free donc je n’ai pas d’ip partagé à 4.

Ok, cool.
Je crois que vient d’une mise à jour de l’addon.
Si j’en crois l’écran il faut remplir les cases (domain/token etc) plutot que de faire la config en yaml comme avant.

oui j’ai tenté aussi en remplissant les champs, mais pareil :(.

Juste au cas où, tu avais bien viré les doublons dans le yaml et la redirection des ports ok ?

les doublons dans le yaml ?

coté port c’est ok.

Coté duckdns, c’est ok aussi puisque si je met le port de ma domotique domoticz j’arrive bien dessus.

Peux-tu supprimer (vider) le dossier ssl (donc les deux fichiers) puis recommencer de zéro en désinstallant l’add-on.

Le port 443 / 80 et 8123 sont bien ouverts sur ta box ?

ok, si j’arrive à ré-activer le ssh sans que tout plante, pour le moment ca veut pas :frowning:

le ssl qui est dans .mnt/data/supervisor/ (qui est vide chez moi) ou celui qui est dans /etc/ ? (qui lui contient une 5 fichiers et 3 repertoires)

j’ai dû rester en console proxmox, impossible de démarrer le plugin ssh sans que mon HA plante complètement.

Tu es sous quel type d’installation ? Supervised pou core ?

Home Assistant Core 2022.5.4
Home Assistant Supervisor 2022.05.3
Home Assistant OS 7.6
Kernel version 5.10.108
Agent version 1.2.1

cela répond à la question ? car je ne sais pas ^^

1 « J'aime »

Ok alors petite question.

Pourquoi tu te connectes en SSH ?

Si tu es en supervised (comme mentionnée au-dessus) installes le plugin File Editor ensuite une fois installé tu pourras éditer les fichiers utiles.

Le dossier SSL et accessible via File Editor avec la sécurité de ne pas supprimer d’autre fichier.

Normalement, tu n’as pas à aller dans etc ou autres, seulement le dossier config.

comme je ne trouve pas de rep /ssl/ dans file editor /config, j’ai cherché le ssl ailleurs.

Ah oui normal, il y a une petite subtilité je crois, il faut changer la valeur de enforce_basepath: false je crois dans la config de File Editor.

Cela te permet de remonter dans l’architecture.

https://forum.hacf.fr/t/installer-file-editor-et-modifier-vos-fichiers-de-configuration-depuis-ha/203#afficher-tous-les-dossiers-5

oki :slight_smile: effectivement j’ai accès à tout maintenant, mais du coup j’efface le rep dans /etc/ ?

Tu dois avoir un dossier ssh dans config normalement ou alors en remontant une fois.

Bonjour,

Non, ni dans config/ ni dans / (racine)