Shelly intégration : 500 Internal Server Error

Bonjour,

Je suis novice avec HA. Je m’initie en essayant d’intégrer un module Shelly 2.5.
J’utilise HA sur une carte Raspberry PI3. J’ai ajouté HACS dans lequel j’ai intégré le module ShellyForAss.
Le module Shelly 2.5 a été configuré en me connectant directement à son adresse IP locale. Il fonctionne correctement via l’accès direct.
Dans HA, Paramètres/Appareils et services il y a bien un pavé « Shelly smart home » qui apparait, mais lorsque je clique sur le bouton « Configurer » j’ai systématiquement l’erreur suivante qui s’affiche : « Le flux de configuration n’a pas pu être chargé: 500 Internal Server Error Server got itself in trouble »

Quelqu’un connait-il ce problème et saurait m’aider à le résoudre ?
Merci d’avance !


System Information

version | core-2023.1.2 – | – installation_type | Home Assistant OS dev | false
hassio | true docker | true user | root virtualenv | false python_version | 3.10.7 os_name | Linux os_version
| 5.15.76-v8 arch | aarch64 timezone | Europe/Paris config_dir | /config

Home Assistant Community Store
GitHub API | ok – | – GitHub Content | ok GitHub Web | ok GitHub API Calls Remaining | 4973
Installed Version | 1.29.1 Stage | running Available Repositories | 1268 Downloaded Repositories | 3

Home Assistant Cloud
logged_in | false – | – can_reach_cert_server | ok can_reach_cloud_auth | ok can_reach_cloud | ok

Home Assistant Supervisor
host_os | Home Assistant OS 9.4 – | – update_channel | stable supervisor_version | supervisor-2022.12.1

agent_version | 1.4.1 docker_version | 20.10.19 disk_total | 6.6 GB disk_used | 2.5 GB healthy | true

supported | true board | rpi3-64 supervisor_api | ok version_api | ok installed_addons | Terminal & SSH (9.6.1)

Dashboards
dashboards | 2 – | – resources | 0 views | 2 mode | storage

Recorder
oldest_recorder_run | 9 janvier 2023 à 16:02 – | – current_recorder_run | 13 janvier 2023 à 14:47

estimated_db_size | 1.02 MiB database_engine | sqlite database_version | 3.38.5


Je me répond à moi-même car j’ai trouvé la solution…
Après avoir visionné pas mal de vidéos sur l’intégration, dont l’une traitait des produits Shelly, j’ai vu qu’il fallait modifier le fichier de configuration YAML en ajoutant quelques lignes. Cette fois, le problème était de savoir comment trouver et modifier ce fichier ! La vidéo mentionnait l’outil « Visual Studio Code » … que je n’avais pas. Il a donc fallu que j’ajoute cet item. Au final j’ai ajouté les lignes suivantes au fichier configuration.yaml :

ShellyforHASS

shelly:
sensors:
- all

Après un ultime redémarrage … le pavé Shelly smart home m’affichait bien les liens « 1 appareil et 13 entities ». :sweat_smile:

Je peux donc maintenant continuer mon apprentissage de Home Assistant :wink: