[TUTO] Installation de Zigbee2mqtt et Broker Mosquitto

Bonjour
je crois que j’ai compris ce qu’il se passe :
Localhost = 127.0.0.1 est l’adresse vue depuis l’intérieur de la machine.
homeassistant.local = 192.168… est l’adresse vue depuis l’extérieur de la machine. Comme on utilise des ports qui servent à aiguiller les données depuis l’extérieur, il faut utiliser une adresse externe bien que Z2M et MQTT soient installés sur la même machine
Sinon core-mosquitto s’est remis à marcher j’avais ss doute fait une faute de frappe.

Bonjour,

Tout d’abord, merci pour ce tuto détaillé. Vraiment un grand merci !
Mais si je viens ici, c’est parce que je rencontre une difficulté dans le paramétrage.

Tout d’abord, je suis ultra débutant et je souhaite tester avant d’investir dans une solution de type HomeAssistant Hub Green.
J’ai donc installé HA sur une VM via VM Fusion sur mon macbook. J’ai connecté un dongle Sonoff 3 Zigbee et j’ai réussi à appairer un module Lixee pour mon compteur Linky.

En revanche, je bloque sur le démarrage de MQTT dans la liste des intégrations.
Le MQTT Broker est bien lancé.
Quand dans la liste de sintégrations je clique sur « configurer » de MQTT, j’ai l’erreur « Erreur de connexion » et dans le journal de MQTT Broker, j’ai l’erreur suivante :
2024-03-14 16:38:16: New connection from 172.30.32.1:45137 on port 1883.
2024-03-14 16:38:16: Client 2o3us0M3GseT06bCmmrTDA disconnected, not authorised.

J’ai essayé avec un user bien spécifique dans MQTT Broker (et paramétré dans HA) et sans user. Toujours la même erreur.
Du coup, je ne vois pas remonter mes capteurs et donc mes données Lixee.

Pouvez-vous m’aider ?
peut être qu’il manque des informations pour pouvoir m’aider, n’hésitez pas à me dire ce qui pourrait vous aider à diagnostiquer le problème.

Merci beaucoup par avance

Bonjour, peux tu partager la config du broker, le journal du broker stp?

Bonjour,
Je suis en train de migrer z2m sur mon nuc.
J’ai proxmox avec une vm ha.
J’ai bien installé mosquitto et z2m.
J’ai recupéré l’id de ma clé que j’ai mis dans serial.
Mais z2m ne démarre pas !
voici le log de z2m

[17:38:29] INFO: Preparing to start...
[17:38:30] INFO: Socat not enabled
[17:38:32] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2024-03-23 17:38:40: Logging to console and directory: '/config/zigbee2mqtt/log/2024-03-23.17-38-40' filename: log.txt
Zigbee2MQTT:info  2024-03-23 17:38:40: Starting Zigbee2MQTT version 1.36.0 (commit #unknown)
Zigbee2MQTT:info  2024-03-23 17:38:40: Starting zigbee-herdsman (0.35.1)
Zigbee2MQTT:error 2024-03-23 17:38:41: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2024-03-23 17:38:41: Failed to start zigbee
Zigbee2MQTT:error 2024-03-23 17:38:41: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2024-03-23 17:38:41: Exiting...
Zigbee2MQTT:error 2024-03-23 17:38:41: Error: spawn udevadm ENOENT
    at Process.ChildProcess._handle.onexit (node:internal/child_process:284:19)
    at onErrorNT (node:internal/child_process:477:16)
    at processTicksAndRejections (node:internal/process/task_queues:82:21)

l’id de ma clé
image

Si quelqu’un peut m’aider svp ?
Merci

Tu as un serial en trop…
Et ensuite corrigé l’indentation.

voila c’est mieux

il a même recuperer mes devices de jeedom

Apparemment pas besoin de recopier mon fichier configuration.yaml

Merci bien :wink:

@ClassicRed
Super Tuto ! Simple, clair, efficace, et surtout « up to date »
Mis en application hier sur une VM Virtualbox HA avec une Conbee2, résultat nickel
Ca évite de galérer tout seul dans son coin quand on ne maitrise pas encore toutes les subtilités

1 « J'aime »

Bonjour,

J’ai suivi le tutoriel et tenté par moi meme de faire marché tout ca, mais je ne comprend pas comment faire appareil des appareil dans MQTT ?
J’essaye de cliquer sur activer mais j’ai ce message d’erreur :

et dans les logs j’ai ceci :

Zigbee2MQTT:info  2024-03-28 18:46:03: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload '{"state":"online"}'
Zigbee2MQTT:info  2024-03-28 18:46:03: Zigbee2MQTT started!
Zigbee2MQTT:info  2024-03-28 18:47:29: Start Touchlink scan
Zigbee2MQTT:error 2024-03-28 18:47:43: Request 'zigbee2mqtt/bridge/request/touchlink/scan' failed with error: 'SRSP - AF - interPanCtl after 6000ms'
Zigbee2MQTT:info  2024-03-28 18:47:43: MQTT publish: topic 'zigbee2mqtt/bridge/response/touchlink/scan', payload '{"data":{},"error":"SRSP - AF - interPanCtl after 6000ms","status":"error","transaction":"v35vj-1"}'
Zigbee2MQTT:info  2024-03-28 18:50:00: Zigbee: disabling joining new devices.
Zigbee2MQTT:error 2024-03-28 18:50:00: Request 'zigbee2mqtt/bridge/request/permit_join' failed with error: 'Cannot execute command, in Inter-PAN mode'
Zigbee2MQTT:info  2024-03-28 18:50:00: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{},"error":"Cannot execute command, in Inter-PAN mode","status":"error","transaction":"2b1cu-1"}'
Zigbee2MQTT:info  2024-03-28 18:50:01: Zigbee: disabling joining new devices.
Zigbee2MQTT:error 2024-03-28 18:50:01: Request 'zigbee2mqtt/bridge/request/permit_join' failed with error: 'Cannot execute command, in Inter-PAN mode'
Zigbee2MQTT:info  2024-03-28 18:50:01: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{},"error":"Cannot execute command, in Inter-PAN mode","status":"error","transaction":"2b1cu-2"}'
Zigbee2MQTT:info  2024-03-28 18:50:30: Successfully changed options
Zigbee2MQTT:info  2024-03-28 18:50:30: MQTT publish: topic 'zigbee2mqtt/bridge/response/options', payload '{"data":{"restart_required":false},"status":"ok","transaction":"2b1cu-3"}'
Zigbee2MQTT:info  2024-03-28 18:50:43: Successfully changed options
Zigbee2MQTT:info  2024-03-28 18:50:43: MQTT publish: topic 'zigbee2mqtt/bridge/response/options', payload '{"data":{"restart_required":false},"status":"ok","transaction":"2b1cu-4"}'
Zigbee2MQTT:info  2024-03-28 18:51:29: Zigbee: allowing new devices to join via Coordinator.
Zigbee2MQTT:error 2024-03-28 18:51:29: Request 'zigbee2mqtt/bridge/request/permit_join' failed with error: 'Cannot execute command, in Inter-PAN mode'
Zigbee2MQTT:info  2024-03-28 18:51:29: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{},"error":"Cannot execute command, in Inter-PAN mode","status":"error","transaction":"2b1cu-5"}'
Zigbee2MQTT:info  2024-03-28 18:51:41: Zigbee: allowing new devices to join.
Zigbee2MQTT:error 2024-03-28 18:51:41: Request 'zigbee2mqtt/bridge/request/permit_join' failed with error: 'Cannot execute command, in Inter-PAN mode'
Zigbee2MQTT:info  2024-03-28 18:51:41: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{},"error":"Cannot execute command, in Inter-PAN mode","status":"error","transaction":"2b1cu-6"}'
Zigbee2MQTT:info  2024-03-28 18:54:27: Zigbee: allowing new devices to join.
Zigbee2MQTT:error 2024-03-28 18:54:27: Request 'zigbee2mqtt/bridge/request/permit_join' failed with error: 'Cannot execute command, in Inter-PAN mode'
Zigbee2MQTT:info  2024-03-28 18:54:27: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{},"error":"Cannot execute command, in Inter-PAN mode","status":"error","transaction":"mnkaz-1"}'
Zigbee2MQTT:info  2024-03-28 18:55:08: Zigbee: allowing new devices to join.
Zigbee2MQTT:error 2024-03-28 18:55:08: Request 'zigbee2mqtt/bridge/request/permit_join' failed with error: 'Cannot execute command, in Inter-PAN mode'
Zigbee2MQTT:info  2024-03-28 18:55:08: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{},"error":"Cannot execute command, in Inter-PAN mode","status":"error","transaction":"mnkaz-2"}'

Si quelqu’un a une idée ? merci

Salut,

j’ai trouvé ce post pour la même erreur https://www.reddit.com/r/homeassistant/comments/s64qw0/cc2652r_throws_error_in_inter_pan_mode_when_i/

  1. Stop Z2M
  2. Unplug CC2652R
  3. Wait about 10 seconds.
  4. Plug in CC2652R
  5. Start Z2M again.

Merci ça a résolu mon problème.

1 « J'aime »

Bonjour,

Je fais part de mon retour ayant voulu installer Z2M et Broker Mosquitto aujourd’hui. Pour ma part, je les ai installé sur HA directement.
J’ai une clé SONOFF ZigBee 3.0 USB Dongle Plus, TI CC2652P donc de type P.

Je l’ai flashée sans problème mais après l’avoir mise sur mon ordi et suivi le tuto, impossible de la détecter dans HA et ayant suivi le tuto.
Après recherche, étant sous HA virtualisé par Proxmox, j’ai du l’ajouter dans Proxmox.
Pour cela, j’ai fait un clic droit sur mon HA virtuel dans Proxmox, ensuite « Matériel » puis « périphérique USB ». Ensuite j’ai sélectionné " Utiliser les identifiants USB du fabricant et du périphérique" et ai sélectionné ma clé. Ensuite j’ai redémarré Proxmox, redémarré HA et enfin ma clé était détectée.
Pour trouver la manip, je me suis aidé de l’explication de ce site (tjs bien de citer ses sources) : ici

J’avoue ne pas avoir lu l’ensemble des messages de la discussion mais vu que cela n’était pas dans le tuto de base, je trouvais intéressant de remonter l’info si ce n’était déjà fait.

Sur ce, bonne domotique :slight_smile:

2 « J'aime »

C’est normal : une VM ne dispose que de ce qui a été configuré au départ.
Pas de périphérique USB déclaré dans Proxmox → pas de clé dans HA.
C’est pareil pour VMware ou Synology…

1 « J'aime »

Oui ça peut paraitre normal pour ceux qui s’y connaissent mais moi qui débute, je n’ai pas compris pourquoi la clé n’était pas reconnue; n’ayant pas de connaissance là dedans. C’est une simple suggestion d’attirer l’attention là-dessus pour compléter le tuto :slight_smile:

je suis vraiment désolé pour le délai de réponse (ayant eu quelques problématiques autres, je m’y suis remis uniquement cette semaine). En reprenant tout de zéro, tout a fonctionné ! merci

Bonjour,
je n’arrive pas à connecter Zigbee2MQTT.
J’ai une erreur : 502: Bad Gateway

J’ai un problème avec MQTT : si je passe par MQTT explorer, j’arrive à ouvrir la connexion avec l’ip de min raspberry (10.0.0.15).
Si je tente core-mosquitto , la connexion ne se fait pas.

Voici le log de Zigbee2MQTT :

[08:46:13] INFO: Preparing to start...
[08:46:14] INFO: Socat not enabled
[08:46:16] INFO: Starting Zigbee2MQTT...
[2024-05-23 08:46:22] info: 	z2m: Logging to console, file (filename: log.log)
[2024-05-23 08:46:22] info: 	z2m: Starting Zigbee2MQTT version 1.37.1 (commit #unknown)
[2024-05-23 08:46:22] info: 	z2m: Starting zigbee-herdsman (0.46.6)
[2024-05-23 08:46:23] error: 	z2m: Error while starting zigbee-herdsman
[2024-05-23 08:46:23] error: 	z2m: Failed to start zigbee
[2024-05-23 08:46:23] error: 	z2m: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
[2024-05-23 08:46:23] error: 	z2m: Exiting...
[2024-05-23 08:46:23] error: 	z2m: Error: Error while opening serialport 'Error: Error: Resource busy, cannot open /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2497659-if00'
    at SerialPort.<anonymous> (/app/node_modules/zigbee-herdsman/src/adapter/deconz/driver/driver.ts:202:28)
    at SerialPort._error (/app/node_modules/@serialport/stream/dist/index.js:82:22)
    at /app/node_modules/@serialport/stream/dist/index.js:118:18

Ici le log de MQTT :

[08:43:49] INFO: Setting up user mqtt
[08:43:50] INFO: Certificates found: SSL is available
cont-init: info: /etc/cont-init.d/mosquitto.sh exited 0
cont-init: info: running /etc/cont-init.d/nginx.sh
cont-init: info: /etc/cont-init.d/nginx.sh exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun mosquitto (no readiness notification)
services-up: info: copying legacy longrun nginx (no readiness notification)
[08:43:52] INFO: Starting NGINX for authentication handling...
s6-rc: info: service legacy-services successfully started
[08:43:52] INFO: Starting mosquitto MQTT broker...
2024-05-23 08:43:52: Warning: Mosquitto should not be run as root/administrator.
2024-05-23 08:43:52: mosquitto version 2.0.18 starting
2024-05-23 08:43:52: Config loaded from /etc/mosquitto/mosquitto.conf.
2024-05-23 08:43:52: Loading plugin: /usr/share/mosquitto/go-auth.so
2024-05-23 08:43:52:  ├── Username/password checking enabled.
2024-05-23 08:43:52:  ├── TLS-PSK checking enabled.
2024-05-23 08:43:52:  └── Extended authentication not enabled.
2024-05-23 08:43:52: Opening ipv4 listen socket on port 1883.
2024-05-23 08:43:52: Opening ipv6 listen socket on port 1883.
2024-05-23 08:43:52: Opening websockets listen socket on port 1884.
2024-05-23 08:43:52: Opening ipv4 listen socket on port 8883.
2024-05-23 08:43:52: Opening ipv6 listen socket on port 8883.
2024-05-23 08:43:52: Opening websockets listen socket on port 8884.
2024-05-23 08:43:52: mosquitto version 2.0.18 running
2024-05-23 08:43:52: New connection from 127.0.0.1:38946 on port 1883.
2024-05-23 08:43:52: Client <unknown> disconnected due to protocol error.
[08:43:53] INFO: Successfully send discovery information to Home Assistant.
[08:43:54] INFO: Successfully send service information to the Supervisor.
2024-05-23 08:43:56: New connection from 10.0.0.15:33709 on port 1883.
2024-05-23 08:43:56: New client connected from 10.0.0.15:33709 as 5zmbbqAmOmoLezYremV3xS (p2, c1, k60, u'mqtt').
time="2024-05-23T08:44:02+02:00" level=error msg="POST error: Post \"http://127.0.0.1:80/superuser\": EOF"
2024-05-23 08:44:08: New connection from 172.30.32.2:57042 on port 1883.
2024-05-23 08:44:08: Client <unknown> closed its connection.
2024-05-23 08:44:17: New connection from 10.0.0.46:53072 on port 1883.
2024-05-23 08:44:17: New client connected from 10.0.0.46:53072 as mqtt-explorer-41ee81b4 (p2, c1, k60, u'mqtt').
2024-05-23 08:44:21: Client mqtt-explorer-41ee81b4 disconnected.
2024-05-23 08:46:08: New connection from 172.30.32.2:58908 on port 1883.
2024-05-23 08:46:08: Client <unknown> closed its connection.
2024-05-23 08:48:08: New connection from 172.30.32.2:37240 on port 1883.
2024-05-23 08:48:08: Client <unknown> closed its connection.
2024-05-23 08:50:08: New connection from 172.30.32.2:40204 on port 1883.
2024-05-23 08:50:08: Client <unknown> closed its connection.

ici ma configuration mqtt :

logins:
  - username: mqtt
    password: mqtt
require_certificate: false
certfile: fullchain.pem
keyfile: privkey.pem
customize:
  active: false
  folder: mosquitto

Ma configuration zigbee2mqtt :

data_path: /config/zigbee2mqtt
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://10.0.0.15
  user: mqtt
  password: mqtt
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2497659-if00
  adapter: deconz

NB : j’ai un module complémentaire deConz qui tourne également

Merci :slight_smile:

Bonjour,
tu peut pas utiliser la même clé zigbee avec deconz et Z2M en même temps.

z2m: Error: Error while opening serialport 'Error: Error: Resource busy, cannot open /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2497659-if00'

Soit tu supprime deconz et passe sur Z2M. Soit il te faut une autre clé zigbee que tu installera pour Z2M, et ta conbeeII pour deconz.

Ca marche

Merci beaucoup :slightly_smiling_face:

Bonjour à tous. Merci infiniment @ClassicRed. Je n’y serai pas arrivé sans ton aide.

Je cherchais désespérément pourquoi zigbee2mqtt ne démarrait pas.

J’ai désactivé ZHA, comme tu le préconises au début. Et bingo ! Redémarrage des services et tout fonctionne. Un grand merci à toi.

Attention, toutefois, il faut bien préciser que le paramètre server dans le broker Mosquitto est localhost. Et dans zigbee2mqtt, il faut mettre core-mosquitto

Bonjour à tous et merci pour ce tuto et tous les participants.

Je viens d’analyser les 278 posts sans résultat en espérant trouver des pistes à mon problèmes…

Je vais essayer de résumer au maximum mon installation/configuration!

Matériel, je suis sous DSM Synology, home assistant est dans un container docker.

L’ensemble est installé avec un docker-compose avec home assistant, mqtt qui tourne déjà depuis pas mal de temps pour un autre matériel, fileeditor, esphome et nodered!
J’ai donc ajouté zigbee2mqtt (koenkk/zigbee2mqtt) au docker-compose.

J’ai une passerelle Sonoff ZBBridge Pro Zigbee Gateway (ZBBridge-P) que j’ai remis à zéro qui fonctionnait parfaitement sous ZHA (complètement désinstallé) avec de multiple devices.

Voici la configuration.yaml de z2m:

homeassistant: false
frontend: true
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://localhost:1883'
  user: l****t
  password: K*****8
  
serial:
    port: 'tcp://192.168.1.171:8888'
    adapter: ember
    zigbee_herdsman_debug: true
advanced:
  network_key:
    - 152
    - 57
    - 224
    - 63
    - 140
    - 156
    - 158
    - 21
    - 252
    - 36
    - 255
    - 77
    - 62
    - 67
    - 141
    - 198
  pan_id: 4038
  ext_pan_id:
    - 204
    - 169
    - 144
    - 92
    - 184
    - 180
    - 162
    - 152

La partie de mon docker-compose :

#zigbee2mqtt
 
version: '3.8'
services:
  zigbee2mqtt:
    container_name: zigbee2mqtt
    image: koenkk/zigbee2mqtt
    restart: always
    volumes:
      - ${RACINE}/zigbee2mqtt/data:/app/data
      - ${RACINE}/zigbee2mqtt/run/udev:/run/udev:ro
    ports:
      - 8888:8080
    network_mode: bridge
    environment:
      - TZ=Europe/Paris

 

Et le log via Portainer de zigbee2mqtt ne voulant pas se lancer :

Using '/app/data' as data directory
[2024-06-10 05:13:34] info: 	z2m: Logging to console, file (filename: log.log)
[2024-06-10 05:13:34] info: 	z2m: Starting Zigbee2MQTT version 1.38.0 (commit #fe048e6)
[2024-06-10 05:13:34] info: 	z2m: Starting zigbee-herdsman (0.49.2)
[2024-06-10 05:13:34] info: 	zh:ember: Using default stack config.
[2024-06-10 05:13:34] info: 	zh:ember: ======== Ember Adapter Starting ========
[2024-06-10 05:13:34] info: 	zh:ember:ezsp: ======== EZSP starting ========
[2024-06-10 05:13:34] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-10 05:13:34] info: 	zh:ember:uart:ash: Socket ready
[2024-06-10 05:13:34] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-10 05:13:37] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-10 05:13:37] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-10 05:13:39] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-10 05:13:39] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-10 05:13:42] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-10 05:13:42] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-10 05:13:44] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-10 05:13:44] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-10 05:13:47] error: 	z2m: Error while starting zigbee-herdsman
[2024-06-10 05:13:47] error: 	z2m: Failed to start zigbee
[2024-06-10 05:13:47] error: 	z2m: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
[2024-06-10 05:13:47] error: 	z2m: Exiting...
[2024-06-10 05:13:47] error: 	z2m: Error: Failed to start EZSP layer with status=HOST_FATAL_ERROR.
    at EmberAdapter.initEzsp (/app/node_modules/zigbee-herdsman/src/adapter/ember/adapter/emberAdapter.ts:850:19)
    at EmberAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/ember/adapter/emberAdapter.ts:2683:24)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:127:29)
    at Zigbee.start (/app/lib/zigbee.ts:62:27)
    at Controller.start (/app/lib/controller.ts:109:27)
    at start (/app/index.js:107:5)

J’ai checké ce lien bien entendu, mais je m’y perds…

J’espère que vous pourrez m’éclaircir sur l’erreur suivante car je suppose que le problème viendrait de ça: z2m: Error: Failed to start EZSP layer with status=HOST_FATAL_ERROR.

Merci!!