Zigbee2MQTT clé SONOFF E

Comme l’a dit @pascal_ha change aussi le server dans ta configuration z2m
image

server: mqtt://core-mosquitto:1883

C’est fait:

1 « J'aime »

Supprime le fichier « coordinator_backup.json » dans le répertoire de z2m et redémarre HA

Tant qu’à faire j’ai aussi supprimer le configuration.yaml une nouvelle fois et redémarré.Voilà ce que ça donne:

1 « J'aime »

On progresse :smile:
Remets une copie de la configuration (user et password de l’intégration MQTT)

On est revenu à un problème simple
image


Ici pas moyen de modifier les login mdp
Quand je change, ça dit échec connexion.

Ne les modifie pas en revanche, faut les coller dans la configuration de z2m (le fichier configuration ou dans l’interface graphique mais faudra de nouveau supprimer le fichier)

Si je comprends bien, le login à mettre dans Z2M est « homeassistant »; par contre le mdp il ne me le donne pas et je ne peux pas le changer ici.

1 « J'aime »

Tu cliques sur l’oeil et tu le copies (tu l’auras en clair : Ctrl + C)
image

Et sinon, c’est bien ça « utilisateur: homeassistant » et mot de passe: « la copie de celui de MQTT »

C pas fou comme mdp:
password_not_changed

OK, j’ai la même chose chez moi depuis ma dernière installation de z2m…

Du coup supprime tout ce qu’il y a dans le répertoire mqtt de l’add-on z2m

de mon user : mqttuser ?

Remets une copie du fichier configuration.yaml de z2m stp

mon configuration.yaml ressemble à ça :


alors que sur l’onglet configuration de l’add-on, j’ai ça :

Je ne sais plus comment j’ai réussi à me dépatouiller avec ça (le « password_not_changed ») et le mot de passe indiqué dans mon configuration.yaml mais j’ai réussi, faut juste que je me rappelle comment j’ai fait…

Je dirais (avec ma mémoire de poisson rouge) :
arrête zigbee2mqtt si ce n’est pas déjà fait
arrête mosquitto broker
supprime l’intégration MQTT
supprime le fichier configuration.yaml du répertoire zigbee2mqtt
enlève tout ce qu’il y a dans le paragraphe mqtt de l’onglet de configuration de z2m
redémarre zigbee2mqtt
redémarre Mosquitto broker

HA devrait redécouvrir l’intégration MQTT

et ben non, plus de mqtt, pas moyen d’appeler l’intégration
J’ai dû désinstaller le addon

Je suis obligé de quitter (hypoglutémie = besoin de ma glute : bière)
On reprend demain si tu veux

1 « J'aime »

Merci avec plaisir.
Je me suis descendu la mienne en même temps que nous discutions.

Tu dois pouvoir réinstaller l’intégration mosquitto
Tu retourne dans paramètre Addon e en bas tu as le bouton bleu pour installer un nouvel Addon tu dois y trouver dans le liste mosquitto broker

1 « J'aime »

Tu peux aller voir ce tuto

Il faut après aller créer une utilisateur qui vas te servir pour les credentials de mqtt

Pense juste bien à changer le driver de ezsp en ember

1 « J'aime »

@yann Tu veux qu’on reprenne ?