Accès a distance impossible depuis maj Core Hass

Mon problème

Bonjour,

Les maj de Hass vont me rendre dingue…

Lundi soir j’ai lancé la mise a jour du code de Hass. Il m’a demandé de faire un snapchot, ce que j’ai accepté.
Le lendemain, impossible de me connecter en local, ce n’est revenu (par miracle) que mercredi.

Seulement je n’ai plus accès a Hass depuis internet. J’utilise le reverse proxy de mon NAS Synology, ce qui fonctionnait très bien jusqu’à la mise a jour.
J’ai redémarré Hass, mon serveur sans succès.

La page m’indique une erreur sur une page blanche 400: Bad Request.
Parfois j’ai le logo
Capture d’écran du 2021-07-22 08-49-46

(Je ne peux pas poster d’infos sur la version pour le moment, je ne suis pas chez moi. Je fais ça ce soir).
Installé sur un rpi4 avec un SSD

ps: Félicitations au staff pour l’association et la maj serveur :slight_smile:

Faut pas… C’est juste de la domotique :slight_smile:
Sinon, le réflexe de base c’est de lire les releases notes avant de faire une mise à jour.
En particulier, les « breaking changes » 2021.7: A new entity, trigger IDs and script debugging - Home Assistant
Il y a une sécurité en plus quand on utilise un proxy qui est expliquée dans la doc. Ce que j’ai lu sur le forum anglais, quand c’est fait, ça marche.

En effet, il faut lire release et plus particulièrement les breaking changes.
Il y a un changement concernant l’accès à distance sur la dernière MAJ.
il faut configurer le http dans la configuration.yaml

En tant que dev, je lis les changelos pour les montés de version des technos que j’utilise mais pour ça j’avoue que je ne me prends pas la tête (a tord pour le coup !!!).

Je regarde cette après-midi quand je pourrai avoir un accès a Hass.

Merci beaucoup !

@Darslan

@fredarro a raison, j’ai eu le même souci :

A ajouter pour être plus précis :avec l’integration http :

http:
  use_x_forwarded_for: true
  trusted_proxies:
    - 172.30.33.0/24 # -> IP du container que tu vois dans les logs de ha
    - 192.168.x.0/24 # j'ai du rajouter mon vlan

Et hop depuis le WAN ca revient :wink:

@Darslan Tas retouvé ton accès depuis internet ?

Avec la doc et le code que tu as donné, oui :slight_smile:

Merci à tous !