Application Smartphone et Tablette Theengs

Je vous annonce la sortie de l’application mobile Theengs :grin:, l’application utilise Theengs Decoder pour lire les données des appareils BLE et les afficher sur votre smartphone,

image

Vous pouvez la télécharger sure google play:
Get it on Google Play

Google Play and the Google Play logo are trademarks of Google LLC.

Ou sur l’app store:
Download on the App Store

App Store and Apple logo are registered trademarks of Apple Inc.

Dans l’esprit d’OpenMQTTGateway l’application peut aussi être utilisée come passerelle MQTT! Si vous avez une tablette muralle Android vous pouvez donc installer l’app et lire les mesures de capteurs BLE pour les transmettre à Home Assistant.
Notez que le fonctionnement en arrière plan (Android uniquement) est expérimental :test_tube: pour le moment. N’hésitez pas à donner votre feedback sur cette fonctionnalité (ou les autres ;-)).

Plus d’infos ci dessous:

Le chemin été long :sweat_smile: depuis l’externalisation du décodage d’OpenMQTTGqteway, la création d’une librairie dédiée, création d’une passerelle, un addon Home Assistant, un explorateur de données et maintenant une application mobile!

Et vous savez quoi, ce n’est pas la fin, l’application va aussi être disponible pour d’autres plate formes :muscle:

7 « J'aime »

Reste à la pousser sur iOS :crazy_face:

1 « J'aime »

Bonjour,
D’abord merci pour ce portage, ça devrait m’être très utile. Je suis en train de tester l’appli et j’ai un petit souci : apparemment, le rafraîchissement des informations MQTT ne fonctionne que lorsque l’appli est en premier plan. Si une autre appli (chez moi Fullykiosk) passe devant, et même si on revient sur Theengs ensuite, le refresh ne se fait plus. Il faut désactiver et réactiver le service MQTT.
La question, c’est de savoir si c’est propre à ma tablette ou pas…
Bonne soirée! Laurent

Bonjour Laurent,

Je suppose que tu as activé le fonctionnement en arriere plan.
Ensuite je t’invite à essayer les paramètres ci dessous (ces consignes peuvent varier suivant la version d’Android) :

Depuis le menu information de l’application :

Android a vachement restreint le fonctionnement des applications en arrière plan, suivant ta version ça peut être plus ou moins facile à parametrer.

Bonsoir,
Merci pour la réponse rapide! J’ai testé de ce pas les propositions, mais sans succès. Pour info, j’utilise Android 9. J’avais déjà activé l’update en tâche de fond (intervalle de 5 min., le minimum). Pour les paramètres, ma tablette est alimentée en POE, donc j’avais désactivé toutes les options de contrôle de la batterie (qui n’existe d’ailleurs pas) et d’économie d’énergie. Pour la localisation, j’ai autorisé Theengs, mais Android n’a pas détecté à ce stade de demande d’accès à la position par Theengs…
Je suis le fil des messages avec MQTT Explorer. Dès que je passe sur une autre app, il n’y a plus aucun renouvellement. J’ai attendu plus de dix minutes pour m’en assurer…

Merci du retour.
Est ce que tu peux le laisser tourner quelques heures en arriére plan ? Et regarder si tu as des publications.

Intéressant, donc dans les autorisations tu as juste « appareils à proximité »

En réalité, c’est un peu difficile de retrouver ses petits dans les paramètres…
Voilà ce que j’ai :

et

Et avec un appui long sur l’app est ce que tu as acces aux informations et donc aux permissions?

Voilà ce que ça donne :


En cliquant sur batterie est qu’il y a des parametres egalement ?

Oui. Sous restriction en arrière-plan, c’est indiqué « Batterie autorisée en arrière-plan »; puis « utilisation de la batterie optimisée ». Mais évidemment, 0 min d’activité en utilisation active ou en arrière-plan…
Je me suis demandé si c’était lié à FullyKiosk, qui accapare assez de permissions. Mais non, identique si une autre app est en avant-plan… Je vais laisser tourner cette nuit et je verrai encore demain.

1 « J'aime »

Ca a l’air sympa, dommage que ce soit payant direct sans pouvoir tester l’app avant.

Bonjour

Il faudrait désactiver l’utilisation de la batterie optimisée si possible.

Est ce qu’il y a eu des scans durant la nuit?

Bonjour,
Alors j’ai laissé tourner la nuit, mais aucune mise à jour.
S’agissant de la batterie, c’était désactivé :

Désolé… je ne vois pas que tenter d’autre…

Merci pour le retour, je vais essayer de trouver un appareil avec cette version d’android.

Elle peut être achetée, et un refund demandé si ça ne convient pas :wink:

Bonjour;

J’ai trouvé un téléphone en Android 9 :slight_smile: et testé l’intégration MQTT et j’ai bien les publications régulièrement si le téléphone est en veille:

Voici ma configuration:



image
image

Bonsoir,
Merci de vos efforts, mais rien à faire. Je ne sais pas ce que j’ai comme version d’Android sur ma tablette, mais en tous les cas je n’ai pas les mêmes écrans et options que vous. Je renonce en l’état…
Très bonne soirée!

Dommage, je vais quand même ajouter ça dans l’aide.

Salut Jerome,

C’est fait :slight_smile:

Download on the App Store

App Store and Apple logo are registered trademarks of Apple Inc.