[Article] Gestion de sa consommation d'eau

Je n’ai pas vraiment accès à mon autre compteur (dehors dans la rue, profond, communique en radio, pas réussi à configurer un esp radio^^). C’était justement le but de ce nouveau compteur.
Il semble bien s’incrémente.
Justement le fait troublant, est que j’ai volontairement mal reclipsé la sonde, et c’est depuis que cela fonctionnait un peu mieux (machine à laver ok, mais se laver les mains non). Je l’ai reclipsé à fond et depuis plus rien, plus de remonté :rofl: :rofl: :rofl:

1 « J'aime »

Milles merci pour ce tuto, je vais le suivre à la lettre :smiley:

Je viens de commander un USL-20 (Eau froide) et un USLC-20 (Eau chaude)
Disponible en petites quantité ici sur le site Cartelectronic.fr

71€ : USL-20 (Compteur EAU à impulsions)
75€ : USLC-20 (Compteur EAU Chaude à impulsions)
Compter 15,60€ de frais de livraison.

Je croise les doits pour les recevoir avant semaine prochaine car le plombier va venir installer tout le réseau dans la nouvelle maison :slight_smile:

Bonjour à tous,
Le suivi de la consommation d’eau m’intéresse beaucoup.
En attendant un compteur, j’ai préparé un esp32. J’utilise un pulse meter avec pullup interne.
Lorsque je branche un cable Dupont sur mon entrée et la masse, l’esp compte bien un volume (normal) par contre lorsque je laisse le câble Dupont en volant sur mon entrée, l’esp compte entre 5 et 12 litres par jour, si je le débranche l’esp ne compte rien.
J’ai utilisé les entrées 4 puis 25, mais toujours le même phénomène.
Avez-vous une idée ?
Merci d’avance.

Merci pour ton intérêt.
L’esp est très sensible et le seul câble branché doit faire varier la tension. Le principal reste que cela marche avec les 2 cables branchés…

Bonjour Argonaute, merci pour ta réponse.
Effectivement j’ai branché deux câbles collés l’un à l’autre et la conso n’est plus qu’à 1 l.
Il ne me reste plus qu’à récupérer un compteur.

1 « J'aime »

Super cette gestion de l’eau. Pour moi tout fonctionne sauf les détections de la nuit.

type: entities
entities:
  - entity: sensor.eau_froide_conso_nuit
    name: Consommation nuit dernière
    icon: mdi:faucet

Il me dit que je n’ai pas ce sensor. Une idée de mon erreur ?

Salut,

Merci pour ton retour. Content que tu aies pu mettre en place tout le reste :blush:

Pas de message dans les logs ? Cela donnerait une indication.

Vérifie si les noms des 2 input_text sont bien corrects, et si ils ont bien enregistrés les bonnes valeurs dans leur historique :

  • input_text.eau_froide_compteur_debut_nuit
  • input_text.eau_froide_conso_fin_nuit

Le tuto est tellement bien fait que cela a été un Jeu d’enfant.
J’ai bien les 2 entrées et il y a bien les valeurs d’enregistrées et elles sont bien inscrite à l’heure de l’automatisation.

J’ai 4750 pour Conso fin de nuit
Et 455.25 pour eau froide compteur début nuit

Je ne vois rien de spécial dans les logs.

Mais
Dans les scripts je ne vois pas à quel moment est créé le sensor sensor.eau_froide_conso_nuit
Je vois dans l’automation input text eau_froide_conso_fin_nuit

Salut @Argonaute, je découvre seulement ton article.
J’avais mis en place la version avec le capteur magnétique au dessus de la roue crantée. Ca avait été un bon moment d’installer tout ça, à l’extérieur, sur la voirie, avec passage de câble pour le 5v depuis le garage MAIS ça fonctionnait bien.

Seulement, après environ 6-8 mois, je pense qu’un technicien est venu relever le compteur et a du bouger / déplacer mon capteur. Résultat, depuis, il me remonte des informations incohérentes : plusieurs millions de litres par heure.

Je découvre donc une autre solution dont l’installation a l’air assez simple. Je ne suis pas plombier mais ça n’a pas l’air si compliqué. Est-ce que quelqu’un l’a installé lui même et aurait des conseils à fournir ? L’idée d’installer ce type de compteur à l’intérieur de la maison m’intéresse plus que d’avoir un capteur dans un regard sur la voirie.

1 « J'aime »

Salut @Alfred1,

Oh, je suis vraiment désolé, je n’ai pas fourni le code du template pour cette entité.
Le voici, à mettre dans le fichier config.yaml ou un package dédié.

sensor:
  - platform: template
    sensors:
      # Mesure de la consomation la nuit
      eau_froide_conso_nuit:
        friendly_name: Conso eau froide nuit 
        unit_of_measurement: L
        unique_id: eau_froide_conso_nuit
        value_template: "{{ states('input_text.eau_froide_conso_fin_nuit')|float(0) }}"

J’ai rajouté ce code également dans l’article…

Ouffff. C’est pas moi qui suis tête en l’air :slight_smile:
Au moins ça servira aussi aux autres. Je vais rajouter cela alors et je reviens te dire :slight_smile:

Parfait tout fonctionne maintenant nickel :slight_smile: merci pour le travail très très utile.

Bonjour,

petite question sur ce sujet, je voulais acheté le compteur GIOANOLA couplé avec un zipulse, problème, sur la fiche produit du compteur il est noté qu’il y a un débit minimum de 50l/h (ce qui est énorme pour moi, c’est plus que ma consommation journalière).

j’ai posé la question a Domadoo a ce sujet et il m’on répondu ceci :

En dessous de ce débit minimal de 50l/h, le compteur donnera des mesures erronées.

du coup je ne sais pas vers quoi me tourné ? êtes vous sur que votre consommation relevé est juste ?

ps je crois que je suis un idiot et cela doit faire référence a une vitesse d’écoulement et on a un volume mais comme dans ma tête les litres par heure sont une consommation…
bref :slight_smile:

La question est surtout de pouvoir mesurer des volumes tirés corrects, y compris pour de petits volumes, sur une période donnée :

  • J’ai comparé les mesures du compteur officiel de la maison et les différences sont < 5%.
  • J’ai enfin fait de petits tirages en remplissant des bouteilles (1 litre, 2 litres…) et les mesures sont bonnes.

J’ai un compteur avec une précision de 0.25l, ce qui correspond bien à la tolérance sur les mesures (si on tire 2 litres, on peut avoir de 1.75 à 2.25l en fonction de ou tombe l’index).

Le débit est la quantité d’eau tirée sur une période, et donc pas de raison qu’il soit faux.
Je n’ai pas de retour sur le module zipulse et sa précision par contre. L’avantage de l’ESP est d’avoir la main sur les pulses émis par le compteur.

1 « J'aime »

J’ai un petit souci avec l’utility_meter et le sensor « annuelle » :

Mon device source est du type device_class: water (et donc je peut l’integrer dans le dashboard energie mais l’annuelle (crée via le compte de service), non :

Voici le détail des sensors :

  • source (sensor.eau_chaude_consommation_eau_chaude) :
state_class: total_increasing
unit_of_measurement: L
device_class: water
icon: mdi:water
friendly_name: Consommation Eau Chaude
  • l’annuelle (sensor.consommation_eau_chaude_annuelle) :
state_class: total_increasing
source: sensor.eau_chaude_consommation_eau_chaude
status: collecting
last_period: 0
last_valid_state: 94.12
meter_period: yearly
cron pattern: 0 0 1 1/12 *
last_reset: 2024-04-08T12:02:01.146859+00:00
unit_of_measurement: L
friendly_name: consommation eau chaude annuelle

Pour tester, j’ai supprimer/recrée l’annuelle et ça continue de me faire ce souci.

La gestion des historiques est assez terrible dans Home Assistant. Il faudra que nous fassions un article à ce sujet.

Effectivement, il faut qu’une statistique soit créée pour pouvoir l’utiliser dans le dashboard energy. Tu peux vérifier à tout moment dans l’outil de développement / statistiques si la statistique est créée ou non.

Et oui, pour cela effectivement il faut que le device_class soit bien défini (entre autre).

Comment as tu créé ton utility_meter ? En YAML ?

Tu peux recréer sensor.eau_chaude_consommation_eau_chaude dans l’interface graphique avec un helper (dans parametres / appareils et services / entrées puis choisir « compteur de service »). Normalement le device_class et l’unité sont repris de l’entité source, et ce sera bon. Ce sera le plus simple.

Si tu l’as créé en YAML et veux le garder, sauf erreur l’utility_meter ne prend pas le device_class de la source, et n’a pas d’option pour le spécifier. Il faut donc forcer le device_class en rajoutant un customize (ou à défaut un template).

Salut,
j’ai crée l’utility_meter via l’interface graphique et sur celui-ci le device_class n’existe pas ( mais il y bien le unit_of_measurement)

Tu pense qu’en YAML, il sera crée avec le device_class ? (j’ai aussi tenté un service: utility_meter.calibrate, mais pas mieux, pas de device_class)

As tu bien le device_class sur l’entité source ?
Effectivement la solution serait de forcer le device class en yaml autrement.