Docker Z2M sur un synology

Bonjour, je fait un post pour aider ceux a qui ça leur arrive car j’ai pas vus de gens en parler.

Je suis sur un synology 920+ est j’avais installer les driver usb de se github
Mais a chaque mise a jours plus rien ne marche et l’activation des modules ne marche pas
( insmod: ERROR: could not insert module /lib/modules/cp210x.ko: Invalid parameters )

Voici la solution qui marche pour moi :

Connecter vous en ssh

Dans « /lib/modules/ » supprimer tout les module que vous avais installer ( dans mon cas cp210x.ko & ch341.ko ) Ne surtout pas supprimer les autres modules, vérifier plusieurs fois pour pas faire de connerie.

Télécharger les de nouveaux sur le github pour faire une nouvelle installation de ceux-ci.

Je suis pas expert mais c’est la solution qui marche pour moi et je voulais la partager, si quelqu’un a une meilleur solution hésiter pas a la partager en commentaire.

1 « J'aime »

Hello

Le souci dur depuis que dsm 7 est sorti
Merci pour ceux qui ne savais pas comment faire , mais juste une chose
Tu devrais rajouté dans ta facon de faire comment se connecté en ssh sur le syno cela aidera aussi :wink:

Bonjour,

de mon côté j’ai plutôt utilisé la méthode de réactivation via le planificateur de tâches de DSM (en user root).

Je crois m’être inspiré du site : https://www.cachem.fr/synology-dsm-7-0-drivers-usb/

Ca donne ça :

image

Je n’ai eu aucun problème par la suite avec les mises à jour DSM.

Sur mon 920+ ça ne marche pas. Mais si d’autre ça marche juste avec ça c’est good :wink:

Ah mince, ok je suis sur Synology 220+, je pensais naïvement que c’était à cause de DSM 7.x et non de la couche matérielle.