Esp32-S2Mini problème connexion internet

@Ownz je suis dans le meme cas que toi , j ai meme fini par racheter 2 esp , pour etre sur , il y a quelque chose qui coince quelque part mais je ne sais pas ou , c est surtout que ca fonctionne tres bien quand c est relié a mon pc , et des que je le met sur une autre alim ca perd le wifi , … a ni rien comprendre

Tu utilise des chargeurs de combien d’ampères ?
J’utilise des 1-2A, voir 3A pour des esp avec écran.

je me suis posé la question aussi , j ai changé de chargeur plusieurs fois , de cable , j ai fait plein d essais , mais je pense que c est un autre problème , je cherche je cherche , mais je trouve pas , comprends pas , je vois pas le rapport entre connecté a l usb du pc (connection esp wifi ok ) et connecté a un chargeur de 3A pas de connection wifi

Ils sont quand même vachement capricieux ces S2Mini

Hello

Comment vois-tu que ton ESP est bien connecté au wifi lorsqu’il est branché sur ton PC via usb ?
Le réseau wifi que lequel tu veux brancher ton ESP est bien en 2.4 Ghz ?
Certaines box agrègent le 5Ghz et le 2.4 sous le même SSID, et dans certains cas, c’est mal foutu et peut poser des pb.
L’idéal est de séparer les 2 réseaux avec des SSID différents pour les 2 bandes de fréquences, ce qui te permet à coup sur de selectionner le 2.4 pour les équipements qui utilsient uniquement cette fréquence.

@+

Hello !

ça j’en suis sur pour le réseau car j’ai toutes mes fréquences séparées.

C’est bien ça le problème x) mais j’ai avancé aujourd’hui !
j’en suis là maintenant :

Mais pour le moment impossible de se connecter.

Comment vois-tu que ton ESP est bien connecté au wifi lorsqu’il est branché sur ton PC via usb ? via advancedscanner . je vois bien l ip de esp sur le wifi 2.4GHZ

Question bête,
Tu es bien en https pour l’interface ESPHOME et non en ip locale ?

You are not browsing the dashboard over a secure connection (HTTPS). This prevents ESPHome from being able to install this on devices connected to this computer

Effectivement je ne suis pas en HTTPS ! mais en HTTP

Comment faire pour switch ? Désolé là ça dépasse vraiment ce que je connais :rofl:

C’est clairement indiqué dans ta première capture d’écran.
Il ne faut pas faire continue mais open ESPHOME WEB

Ah oui, par contre je passe toujours par l’interface web

probleme resolu , comment ? j en sais rien , j ai juste ajouté un petit bout de code sur la config esp , est ce ca ? " platform: esp8266"

la config en question en entier :

esphome:
  name: congelateur
  friendly_name: congelateur
  platform: esp8266
  board: esp01_1m
dallas:
  - pin: GPIO4

# Individual sensors
sensor:
  - platform: dallas
    address: 0x3d00000093a8e228
    name: "Congelateur"
# Enable logging
logger:

# Enable Home Assistant API
api:
  encryption:
    key: "e3z0nbpLkIap5XjWoj9eCY4efutqD48vfQBjQLstdWI="

ota:
  password: "a4f201e2646543230a5f64a7286a71da"

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Congelateur Fallback Hotspot"
    password: "o3bB8NB3setz"

captive_portal:

INFO ESPHome 2024.5.5
INFO Reading configuration /config/esphome/congelateur.yaml…
INFO Starting log output from 192.168.1.67 using esphome API
INFO Successfully connected to congelateur @ 192.168.1.67 in 0.008s
INFO Successful handshake with congelateur @ 192.168.1.67 in 2.387s
[14:47:54][I][app:100]: ESPHome version 2024.5.5 compiled on Jun 7 2024, 14:30:44
[14:47:54][C][wifi:580]: WiFi:
[14:47:54][C][wifi:408]: Local MAC: 58:BF:25:DB:A4:05
[14:47:54][C][wifi:413]: SSID: [redacted]
[14:47:54][C][wifi:416]: IP Address: 192.168.1.67
[14:47:54][C][wifi:419]: BSSID: [redacted]
[14:47:54][C][wifi:421]: Hostname: ‹ congelateur ›
[14:47:54][C][wifi:423]: Signal strength: -86 dB ▂▄▆█
[14:47:54][C][wifi:427]: Channel: 1
[14:47:54][C][wifi:428]: Subnet: 255.255.255.0
[14:47:54][C][wifi:429]: Gateway: 192.168.1.1
[14:47:54][C][wifi:430]: DNS1: 192.168.1.1
[14:47:54][C][wifi:431]: DNS2: 0.0.0.0
[14:47:54][C][logger:185]: Logger:
[14:47:54][C][logger:186]: Level: DEBUG
[14:47:54][C][logger:188]: Log Baud Rate: 115200
[14:47:54][C][logger:189]: Hardware UART: UART0
[14:47:54][C][dallas.sensor:075]: DallasComponent:
[14:47:54][C][dallas.sensor:076]: Pin: GPIO4
[14:47:54][C][dallas.sensor:077]: Update Interval: 60.0s
[14:47:54][D][dallas.sensor:082]: Found sensors:
[14:47:54][D][dallas.sensor:084]: 0x3d00000093a8e228
[14:47:54][C][dallas.sensor:089]: Device ‹ Congelateur ›
[14:47:54][C][dallas.sensor:089]: Device Class: ‹ temperature ›
[14:47:54][C][dallas.sensor:089]: State Class: ‹ measurement ›
[14:47:54][C][dallas.sensor:089]: Unit of Measurement: ‹ °C ›
[14:47:54][C][dallas.sensor:089]: Accuracy Decimals: 1
[14:47:54][C][dallas.sensor:097]: Address: 0x3d00000093a8e228
[14:47:54][C][dallas.sensor:098]: Resolution: 12
[14:47:54][C][captive_portal:088]: Captive Portal:
[14:47:54][C][mdns:115]: mDNS:
[14:47:54][C][mdns:116]: Hostname: congelateur
[14:47:54][C][ota:096]: Over-The-Air Updates:
[14:47:54][C][ota:097]: Address: congelateur.local:8266
[14:47:54][C][ota:100]: Using Password.
[14:47:54][C][ota:103]: OTA version: 2.
[14:47:54][C][api:139]: API Server:
[14:47:54][C][api:140]: Address: congelateur.local:6053
[14:47:54][C][api:142]: Using noise encryption: YES
[14:48:31][D][dallas.sensor:153]: ‹ Congelateur ›: Got Temperature=-11.6°C
[14:48:31][D][sensor:093]: ‹ Congelateur ›: Sending state -11.56250 °C with 1 decimals of accuracy
[14:49:31][D][dallas.sensor:153]: ‹ Congelateur ›: Got Temperature=-12.1°C
[14:49:31][D][sensor:093]: ‹ Congelateur ›: Sending state -12.12500 °C with 1 decimals of accuracy
[14:50:31][D][dallas.sensor:153]: ‹ Congelateur ›: Got Temperature=-12.5°C
[14:50:31][D][sensor:093]: ‹ Congelateur ›: Sending state -12.50000 °C with 1 decimals of accuracy
[14:51:31][D][dallas.sensor:153]: ‹ Congelateur ›: Got Temperature=-12.8°C
[14:51:31][D][sensor:093]: ‹ Congelateur ›: Sending state -12.81250 °C with 1 decimals of accuracy
[14:52:31][D][dallas.sensor:153]: ‹ Congelateur ›: Got Temperature=-13.0°C
[14:52:32][D][sensor:093]: ‹ Congelateur ›: Sending state -13.00000 °C with 1 decimals of accuracy

et toi @Ownz tu en est ou ? je peux peut être aider ?

Et bien écoute, j’ai reçu à l’instant un autre ESP32, et là tout fonctionne donc le premier devait être HS !

Les boules pour autant de recherche mais au moins je sais d’où ça viens.

1 « J'aime »

Passe ton sujet en résolue, si c’est bon.

ah , mais ca ! j ai eu la même chose , perdre un temps fou , faire perdre aux autres du temps précieux , comme tu disais tout a l heure , c est un peu capricieux , mais c est pas cher ! :slight_smile: , c était quoi ton projet avec d ailleurs ? j ai lu en diagonale

C’est écris dans son sujet :sweat_smile:

1 « J'aime »

@WarC0zes j ai perdu mes lunettes

1 « J'aime »

Bonsoir,
Cela fait un bail que je n’ai pas relu ce post, et je n’ai pas les ESP sous les yeux. Mais pour les modèles à 2 ports USB, un seul permet la programmation. Donc si c’est votre cas, pensez à essayer l’autre port USB. Ce n’est pas une panne, c’est dans les spec. du constructeur.