Home Assistant ne démarre plus!

Mon problème

Home Assistant ne démarre plus!
Tout fonctionnait très bien, jusqu’à hier soir où j’ai remarqué que mes lampes ne réagissaient plus. Je me suis aperçu que Home Assistant n’était plus accessible.

Un petit coup de SSH sur le PI

pi@raspberrypi:~ $ sudo docker ps
CONTAINER ID   IMAGE                                           COMMAND   CREATED       STATUS        PORTS                  NAMES
da10dae4a282   homeassistant/armv7-hassio-observer:2020.10.1   "/init"   5 weeks ago   Up 10 hours   0.0.0.0:4357->80/tcp   hassio_observer

Il n’y a pas grand chose d’actif… et pourtant j’ai bien tout les containers suivants sur le Pi

pi@raspberrypi:~ $ docker image ls
REPOSITORY                                 TAG          IMAGE ID       CREATED         SIZE
esphome/esphome-hassio-armv7               1.16.2       7b778c21ec5d   10 days ago     1.02GB
homeassistant/armv7-hassio-supervisor      2021.02.11   be11a28f19e8   11 days ago     247MB
homeassistant/armv7-hassio-supervisor      latest       be11a28f19e8   11 days ago     247MB
homeassistant/armv7-hassio-audio           2021.02.1    40f28e0fd362   2 weeks ago     90.5MB
homeassistant/armv7-addon-zwave_js         0.1.7        b8e7e2fcca82   2 weeks ago     321MB
homeassistant/armv7-hassio-cli             2021.02.1    468da71074dd   2 weeks ago     81MB
ghcr.io/hassio-addons/zwave2mqtt/armv7     0.9.2        66ff5883c9c6   3 weeks ago     145MB
homeassistant/raspberrypi4-homeassistant   2021.2.1     c9a3a449e978   3 weeks ago     1.07GB
ghcr.io/hassio-addons/glances/armv7        0.10.0       de561930b6ad   5 weeks ago     98.4MB
homeassistant/armv7-hassio-dns             2021.01.0    eeb0a3e43eb4   5 weeks ago     85.9MB
homeassistant/armv7-addon-configurator     5.2.0        e197f4a5c640   3 months ago    130MB
hassioaddons/glances-armv7                 0.9.1        213fdb9f31ad   4 months ago    85.5MB
homeassistant/armv7-hassio-observer        2020.10.1    bf193dc8f2c4   4 months ago    71.8MB
homeassistant/armv7-addon-letsencrypt      4.11.0       6e5c6a0d41b3   4 months ago    261MB
homeassistant/armv7-hassio-multicast       3            0fbd536e8547   6 months ago    63.3MB
homeassistant/armv7-addon-mosquitto        5.1          c8d3757b5e04   17 months ago   27.6MB

Une idée de comment relancer tout ça? Un reboot ne fonctionne pas.

Ma configuration

Rapsberry Pi 4 B+ boot sur SSD
Home Assistant Supervised

Il doit néanmoins y avoir des logs du redémarrage (ou au moins de l’essai). Il y a peut-être/sans doute des infos intéressantes.

Rien dans les logs de HA… et je ne vois rien de spécial dans les logs du Pi.

Rien d’intéressant ou pas de log au démarrage?

Rien, les logs sont vides depuis le 28/02

Je pense que tu en aura vu que les containers ne démarre pas :sweat_smile:

Regarde plutôt (j’y connais rien) le debug des containers docker et savoir pourquoi ça ne se lance pas.

D’abord regarder les logs des containers en somme… :innocent:

Hello je suis dans le même cas. Pour suivre…
(rpi4 4go home assistant via docker et plus qu’un seul container actif)

pi@raspberrypi:~ $ docker ps
CONTAINER ID   IMAGE                                           COMMAND   CREATED        STATUS          PORTS                  NAMES
86bbc380e8c2   homeassistant/armv7-hassio-observer:2020.10.1   "/init"   11 hours ago   Up 11 seconds   0.0.0.0:4357->80/tcp   hassio_observer

pi@raspberrypi:~ $ docker image ls
REPOSITORY                                TAG          IMAGE ID       CREATED         SIZE
homeassistant/armhf-addon-mosquitto       5.1.1        a8410bb08268   4 days ago      80.3MB
homeassistant/armhf-addon-samba           9.3.1        10cf70629285   4 days ago      109MB
homeassistant/armhf-addon-ssh             9.0.2        01dabbab86be   4 days ago      145MB
ghcr.io/hassio-addons/node-red/armhf      8.1.2        8ccb6559aace   10 days ago     250MB
homeassistant/armv7-hassio-supervisor     2021.02.11   be11a28f19e8   11 days ago     247MB
homeassistant/armv7-hassio-supervisor     latest       be11a28f19e8   11 days ago     247MB
homeassistant/armv7-hassio-audio          2021.02.1    40f28e0fd362   2 weeks ago     90.5MB
homeassistant/armv7-hassio-cli            2021.02.1    468da71074dd   2 weeks ago     81MB
homeassistant/raspberrypi-homeassistant   2021.2.3     72ec1b25db9f   2 weeks ago     1.05GB
homeassistant/armhf-addon-duckdns         1.12.5       16f73905819e   2 weeks ago     76.7MB
homeassistant/armhf-addon-zwave           0.9.1        07eaf0bc966e   3 weeks ago     414MB
homeassistant/armv7-hassio-dns            2021.01.0    eeb0a3e43eb4   5 weeks ago     85.9MB
homeassistant/armhf-addon-configurator    5.2.0        3e4a3270919e   3 months ago    140MB
homeassistant/armv7-hassio-observer       2020.10.1    bf193dc8f2c4   4 months ago    71.8MB
homeassistant/armv7-hassio-multicast      3            0fbd536e8547   6 months ago    63.3MB
hello-world                               latest       851163c78e4a   14 months ago   4.85kB

@cerealeskiller : Depuis quand chez toi?

installation de ce lundi, je pensais avoir foiré la première fois mais à la seconde installation toujours pareil. Ca fonctionne sur le coup mais au premier redémarrage du rpi4 toujours le même problème.
j’arrive toujours à m’y connecter mais en SSH.

Bizarre… je l’avais déjà redémarré plusieurs fois auparavant sans problèmes. A mon avis, on ne va pas être les seuls… le premier avec une solution, tiens l’autre au courant!

Trouvé sur le site officiel de Home Assistant

apt install docker-ce=5:19.03.15~3-0~raspbian-buster docker-ce-cli=5:19.03.15~3-0~raspbian-buster

Il y aurait un couac avec Docker… je suis entrain de tester

Edit : après cette commande et un reboot cela fonctionne parfaitement :wink:

Edit 2: le lien vers le site officiel
https://community.home-assistant.io/t/installing-home-assistant-supervised-on-debian-10/200253/459?u=guillaume

1 J'aime

merci tu as résolu mon problème! :grinning:

1 J'aime

Salut,
j’ai eu le meme probleme hier. Puisque j’avais fais un snapshot juste avant et sauvegarder sur mon pc, j’ai pri une sd - flasher - ensuite au demarrage de HA directement choisi utiliser un snapshot et sa a fonctionner mais il lui fallait tres longtemps pour demarrer. Plus de 3h avec beaucoup de patience

peux tu ajouter le lien à ton post ?

Tu étais sous qu’elle version avant ?

C’est ajouté, je n’ai pas regardé la version avant de corriger :shushing_face:

Par contre, toujours selon le forum officiel, il y a un soucis avec Docker v20.10.4.

Par contre dans le supervisor puis « système » il m’indique je j’utilise une version non supportée: You are running an unsupported installation.
Pourrais-tu m’éclairer?

Erreurs dans le log du supervisor:

21-03-02 19:47:19 WARNING (MainThread) [supervisor.resolution.evaluations.base] Detected unsupported OS: Raspbian GNU/Linux 10 (buster) (more-info: Operating System - Home Assistant)

21-03-02 19:47:19 WARNING (MainThread) [supervisor.core] System running in a unsupported environment!

Copie des infos de mon système:

System Health

version: core-2021.2.3
installation_type: Home Assistant Supervised
dev: false
hassio: true
docker: true
virtualenv: false
python_version: 3.8.7
os_name: Linux
os_version: 5.10.17-v7l+
arch: armv7l
timezone: Europe/Amsterdam

GitHub API: ok
Github API Calls Remaining: 4970
Installed Version: 1.11.3
Stage: running
Available Repositories: 816
Installed Repositories: 5

logged_in: false
can_reach_cert_server: ok
can_reach_cloud_auth: ok
can_reach_cloud: ok

host_os: Raspbian GNU/Linux 10 (buster)
update_channel: stable
supervisor_version: supervisor-2021.02.11
docker_version: 19.03.15
disk_total: 218.8 GB
disk_used: 6.7 GB
healthy: true
supported: failed to load: Unsupported
supervisor_api: ok
version_api: ok
installed_addons: Mosquitto broker (5.1.1), Node-RED (8.1.2), OpenZWave (0.9.1), Samba share (9.3.1), Terminal & SSH (9.0.2), File editor (5.2.0), Duck DNS (1.12.5)

dashboards: 1
resources: 2
views: 9
mode: storage

Le Supervisor ne supporte que Debian pas les dérivés

Merci! :smiley: et pour remédier à cela, il y a une solution?

Je t’en pris…

Oui, installer une Debian :grin: (si tu veux rester sur une version Supervised)

Sinon tu peux aussi utiliser Home Assistant OS au lieu de la version Supervised (qui est pour les utilisateurs avancés).

Mais tu n’est pas le seul sur Raspbian et Supervised et ça fonctionne très bien.

C’est juste que tu ne pourras pas ouvrir de ticket incident car tu n’as pas les prérequis de rempli (la Debian)

1 J'aime

Ok :smiley: , donc je pense que je peux rester sur cette version car j’imagine que le passage à la version Debian en rpi4 avec SSD ça ne doit pas être simple?