Intégration Circuit Breaker EARU

Mon problème

Bonjour,
Je suis tout nouveau dans le monde HA et ma question va paraitre trop simple…
J’ai un circuit breaker EARU EAKCB-T-M qui fonctionne très bien avec l’appli Tuya sur mon smartphone. J’essaie de l’intégrer dans HA, mais je ne vois que la partie switch ON/OFF, je ne vois pas les infos courant, tension et puissance remonter. Comment puis-je faire?
Si possible, je souhaiterais l’intégrer plutôt avec local Tuya.
Merci 10000 fois !

Ma configuration


[center]## System Information

version core-2024.2.1
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.12.1
os_name Linux
os_version 6.1.63-haos-raspi
arch aarch64
timezone Europe/Paris
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.34.0
Stage running
Available Repositories 1457
Downloaded Repositories 6
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 11.5
update_channel stable
supervisor_version supervisor-2024.01.1
agent_version 1.6.0
docker_version 24.0.7
disk_total 234.7 GB
disk_used 4.8 GB
healthy true
supported true
board rpi3-64
supervisor_api ok
version_api ok
installed_addons Terminal & SSH (9.9.0), Example (8.0.3), File editor (5.8.0), Samba share (12.3.0), Duck DNS (1.15.0), Samba Backup (5.2.0), ESPHome (2023.12.9)
Dashboards
dashboards 3
resources 3
views 7
mode storage
Recorder
oldest_recorder_run 24 janvier 2024 à 21:13
current_recorder_run 12 février 2024 à 14:47
estimated_db_size 22.33 MiB
database_engine sqlite
database_version 3.44.2
[/center] ___

Hello,

Tu n’utilises pas Local Tuya aujourd’hui?

C’est expliqué comment faire pour monitorer l’énergie avec Local Tuya si ton appareil est compatible:

Est-ce que tu as regardé les attributs de ton appareil si c’est pas déjà là? :slight_smile:

Ton disjoncteur est wifi ou zigbee ?

Local tuya ne fonctionne que pour les équipements en wifi, il me semble.

Merci pour vos réponses rapides.
Oui, je l’ai intégré avec Tuya.
Sur l’appli Tuya de mon smartphone, tout y est.
Sur HA/Tuya, seule l’info ON/OFF remonte.
Avec Local Tuya, idem, sauf que je n’arrive pas à le piloter (indisponible).
De plus, dans le panel, j’ai l’info : Entité non disponible : sensor.wifi_plug_2_puissance

image

WiFi Plug 2 Socket 1 : c’est la déclaration Tuya, les 2 autres lignes c’est local Tuya.

A priori, le CB est wifi effectivement, pas zigbee.
Merci de votre aide.