Intégration de Xiaomi LUMI.GATEWAY.V2

System Health

version 2021.1.5
installation_type Home Assistant OS
dev false
hassio true
docker true
virtualenv false
python_version 3.8.7
os_name Linux
os_version 5.4.86
arch x86_64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4891
Installed Version 1.10.1
Stage running
Available Repositories 777
Installed Repositories 6
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Hass.io
host_os Home Assistant OS 5.10
update_channel stable
supervisor_version 2021.01.7
docker_version 19.03.13
disk_total 97.7 GB
disk_used 9.5 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons Check Home Assistant configuration (3.6.0), File editor (5.2.0), Samba share (9.3.0), motionEye (0.11.0), Google Assistant SDK (2.5.0), Let’s Encrypt (4.11.0), Home Assistant Google Drive Backup (0.103.1), Log Viewer (0.9.1), AdGuard Home (3.0.0)

Mon problème

Encore moi…

J’ai actuellement une Xiaomi LUMI.GATEWAY.V2, mais il m’est impossible d’activer le mode « LAN », est ce totalement « mort » pour moi ?
J’aurais aimé l’ajouter à HA, pour me faire une alarme digne de ce nom (en ajoutant par exemple une sirène correct à ce système).

Par avance, merci beaucoup pour votre aide ! :+1:

1 « J'aime »

Salut il y a sur le fil de discussion de intégration de la xiaomi un post qui en parle je crois ici.

En suivant le lien de @McFly tu trouvera le script ou application qui permet d’extraire du cloud le token associé à ta gateway.
Ensuite avec l’intégration xiaomi_miio tu aura accès à la lumière, au capteur de luminosité et tu pourra activer/désactiver l’alarme

1 « J'aime »

Excellent !!! Effectivement le lien fourni par mister McFLY, et les détails fournis par Makai, j’ai réussi à intégrer ma GATEWAY XIAOMI…
Du coup, je comptais m’acheter des sondes de températures Xiaomi, mais c’est raté, vais devoir changer de gateway, ou carrément de système, car aucun de mes modules remontent.
Le seul intérêt (pour moi), de ma gateway actuelle sous HA, c’est de pouvoir activer l’alarme à distance…
Dommage…
Encore merci pour votre aide précieuse !!

1 « J'aime »

En parcourant, un peu mieux, l’article de HA ICI, je me suis rendu compte que cette intégration était toujours en développement… Du coup je croise les doigts !

Dans l’article, on voit :
Not yet implemented features (but possible):
** Gateway internet radio (only chinese stations)*
** Gateway ringtones/sounds* ** → Pour ce point, comment faire pour l’activer ?

Est ce que les sondes de températures WSDCGQ01LM et WSDCGQ11LM sont compatibles avec ma gateway svp ?

Merci beaucoup pour votre aide !!

Je ne comprends pas pourquoi ta gateway ne remonte aucun module elle.le devrait.

As tu bien installé les deux intégration Xiaomi ?

Oui les sondes citées sont compatibles avec la gateway.

Pour activer une sonnerie supplémentaires il faut l’ajouter via mi Home et après elle est sur un ID 10000, 10001 etc en fonction du nombre de sonnerie que tu ajoutes.

Installé les deux intégrations Xiaomi ? Tu parles des intégrations Xiaomi MiiO et Gateway ?
J’ai pu installer ma gateway avec l’intégration Miio, mais impossible par « Gateway », car il m’est impossible d’activer le mode « LAN ». Ma Gateway n’est pas « compatible », d’où, je pense, le problème…

Ensuite pour les sondes, si elles sont compatibles, mais qu’elles ne remontent pas dans HA, aucun intérêt pour moi du coup :sob:

Si tu as la gateway v2 elle est sensé être compatible non ? Peux tu me donne le nom quel as dans les paramètres de l’application Mi Home stp car on a tendance a pas avoir la même appellation que Xiaomi de ses Machines hahaha

Bonjour McFly, et merci de ton aide.
Dans l’application, c’est bien Lumi.Gateway.V2, par contre derrière la passerelle, j’ai : DGNWG01LM.
Je l’ai depuis presque 6 ans, et doit être une des premières sorties je pense…

Alors la v2 dans les infos équivaut à la v1 de chez Xiaomi donc sans radio Je me trompe?

Qu’entends tu par radio ?

La v2 appelé V3 par Xiaomi a la radio dessus. Est ce que tu as la radio chinoise ?

Moi j’ai la DGNWG02LM et j’ai dû ouvrir le port indiqué :

Ouvrir le port sur la passerelle Xiaomi

Ca en parle un peu ici : [NON A JOUR] Intégration du matériels Xiaomi - #44 par Patrick_MX

Non je n’ai pas la radio
Pour préciser, j’ai réussi, par l’application, à avoir le token, et c’est comme ça que j’ai pu l’intégrer avec « XIAOMI MiiO », mais impossible avec « Xiaomi Gateway »
Merci de votre aide !

Pour pouvoir utiliser xiaomi gateway il faut la clé LAN et non le token. Or depuis les dernières mises à jour de l’application MiHome, on ne peut plus récupérer cette clé. Et pire, depuis les derniers firmware de la gateway, le port de communication en local est fermé…
Faut passer sur une clé zigbee et utiliser ZHA ou zigbee2mqtt

Oui c’est bien ce que j’ai lu, le problème c’est que ma version de la GW la DGNWG01LM, il est impossible d’activer le mode « LAN MODE », et ce n’est pas du à la version du firmware ou de version de MiHome…
Avec L’intégrateur « MiiO » j’ai réussi à faire apparaitre ma GW (avec le token), mais les modules ne remontent pas…

Ok du coup limitation hardware. Y a plus qu’à changer :grin:

Je viens à l’instant de tester ceci GitHub - AlexxIT/XiaomiGateway3: Control Zigbee, BLE and Mesh devices from Home Assistant with Xiaomi Gateway 3 (ZNDMWG03LM) on original firmware, mais j’ai un joli « gateway non compatible »…
Bon je vais laisser tomber, et suivre ton conseil, Makai, et changer.
Je vais ouvrir un nouveau sujet, pour de nouveau conseil de votre part !

Encore merci à vous tous !!