KNX entités créé mais non utilisable

Mon problème

Bonsoir tout le monde,

Mon problème est lié à l’usage de KNX et à ma configuration. Pour détailler un peu plus cela, j’ai modifié le fichier de configuration pour importer différents fichiers KNX qui sont décomposés en gestion de l’éclairage, retour d’information (température, temps d’utilisation de mes sorties), et prise commandée.

knx:
  light: !include knx/light.yaml
  switch: !include knx/switch.yaml
  sensor: !include knx/sensor.yaml

Voici un exemple de la partie switch.yaml

# Gestion de prise chambre 1
    - name: "Prise commandée chambre 1"
      address: "2/0/1"
      state_address: "2/1/1"
# --------------------------------------------
# Gestion de prise chambre 2
    - name: "Prise commandée chambre 2"
      address: "2/0/2"
      state_address: "2/1/2"
# --------------------------------------------
# Gestion de prise chambre 3
    - name: "Prise commandée chambre 3"
      address: "2/0/3"
      state_address: "2/1/3"
# --------------------------------------------
# Gestion de prise radiateur salle de bain
    - name: "Prise commandée radiateur salle de bain"
      address: "2/0/8"
      state_address: "2/1/8"
# --------------------------------------------

Une fois le fichier enregistré, la configuration testée/validée et mon installation rebooté, je suis dans l’incapacité d’utiliser la dernière entité de chacun de mes fichiers. Je dois passer à coté de quelque chose, mais je ne comprend pas.

Mon expérience HA est pas mal limitée, je me limite à du très basic pour le moment. Mais malheureusement cela ne marche pas en totalité.

Je vous remercie d’avance pour l’aide que vous allez m’apporter.

Ma configuration


[center]## System Information

version core-2022.11.0
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.10.7
os_name Linux
os_version 5.15.61-v8
arch aarch64
timezone Europe/Paris
config_dir /config
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 9.3
update_channel stable
supervisor_version supervisor-2022.10.2
agent_version 1.4.1
docker_version 20.10.18
disk_total 58.1 GB
disk_used 4.2 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons File editor (5.4.1), Samba share (10.0.0)
Dashboards
dashboards 1
resources 0
views 10
mode storage
Recorder
oldest_recorder_run 2 juin 2022 à 18:14
current_recorder_run 3 novembre 2022 à 17:34
estimated_db_size 9.68 MiB
database_engine sqlite
database_version 3.38.5
[/center] Comment récupérer ma configuration : Dans votre HA, Menu latéral `Paramètres` > `Système` > `Corrections` puis les trois petits points en haut a droite > `Informations Système` puis une fois en bas `Copier` ___

Hello

Je suis pas spécialiste en KNX, mais j’ aurais tenté ceci
Dans mon configuartion.yaml

knx: !include_dir_merge_list knx/

Je crée un dossier knx
et dedans mes fichiers

knx.yaml (configuration du KNX)
knx_light (lumières)
knx_cover (volets)
knx_sensor
knx_binary_sensor
knx_switch
knx: 
  switch:
    - name: "Prise commandée chambre 1"
      address: "2/0/1"
      state_address: "2/1/1"

    - name: "Prise commandée chambre 2"
      address: "2/0/2"
     state_address: "2/1/2"
knx: 
  light:
    - name: "xxxx"
      address: "xxxx"
      state_address: "xxxx"
      brightness_address: "xxxx"
      brightness_state_address: "xxxx"
knx: 
  sensor:
    - name: "xxxx"
      state_address: "xxxx"
      type: "xxxx"

Merci pour votre réponse, j’ai modifié ma configuration suivant vos instructions, puis testé la configuration par le biais des outils de développement (aucun problème identifié). suite à cela je redémarre le tout.

Mais cela n’a rien changé, je ne vois toujours pas dans les entités les dernières déclarations de chaque fichiers.

Dois-je recharger la configuration d’une manière particulière?

Bonjour,

La séparation en fichier que vous avez réalisé initialement semble correcte.

Que se passe t’il exactement ?

Hello, normalement rechargé suffit pour voir les nouvelles entities. Combien voyez-vous d’entities ?

Ce qu’il se passe :

  • Dans mes fichiers de configuration j’ai déclaré 103 éléments KNX

  • Dans l’interface web de HA, quand je me déplace dans les entités, je constate qu’il n’y a que 97 entités KNX

Ce constat me fait dire que mes fichiers ne sont pas lu en totalité, ou mal interprété. Et je ne comprend pas la raison de ce « bug ».

Bonjour,

Est-ce que vous aviez déjà déclaré les 103 entités avant de réaliser leur répartition dans plusieurs fichiers ou en avez vous déclarez en plus lors de cette opération ?