Migration de Pi3B+ à Pi4B 4Gb - Rions un peu (en cours - Live)

Con-texte :
Depuis quelque temps, j’ai des problèmes d’exécution de mes flow NodeRed.
Ils passent parfaitement, mais de manière aléatoire ne sont pas exécutés physiquement : Je vois bien l’envoi final d’un call_service mais pas sa traduction sur le luminaire concerné. Ça concerne toute la gamme de produits zigbee que j’utilise (Hue/Tradfri/Innr/Xiaomi).

Je déteste les erreurs aléatoires.
En procédant par élimination (et en réalisant que j’avais des pics d’usage proco sur à peu près chaque occurrence), j’en déduit que c’est la charge de calcul qui est responsable du fait que je me sois cogné le petit doigt de pied dans la commode en pleine nuit parce que la lumière ne s’est pas allumée.

Con-texte hardware :
Je fais tourner hass.io sur un Pi3B+ avec un HAT RaspBee.

Vu que je déteste me cogner le petit doigt de pied, et encore plus quand j’ai tout prévu aux petits oignons (pun intended) pour éviter ça, je viens de rage-commander un Pi4 4Gb qui va me tomber dans les pattes demain.

Le sujet (enfin) :
Mon taf -à réception du bouzin- va être de migrer Hass ET mon HAT de l’un à l’autre sans perdre aucun appairage ni aucune fonctionnalité évidemment.
Le tout en limitant au maximum la durée d’indisponibilité de mon appart.
Pour des raisons évidentes d’hygiène, je n’ai pas envie d’aller aux chiottes sans lumière.

Je vous propose donc de suivre en temps quasi-réel les grands moments de solitude que je m’apprête à vivre.
Des larmes, de la sueur, des @ù¤$£* dans tous les sens mais sans doute de la bonne humeur.

Le plan originel :

  1. Tabasser le livreur quand il me file le colis parce qu’il est en retard (optionnel)
  2. a. Flasher une SD avec un Raspbian
    b. Noter l’adresse MAC du nouveau Pi
  3. a. Configurer les ports serie pour le RaspBee (sur le 3B+ j’avais dû couper le BT et certains accès GPIO)
    b. Éteindre mon 3B+ actuel, sortir la carte SD, en faire une image sur une autre
  4. a. Sortir avec précaution le HAT, et le remettre en respectant le pinout dans le Pi4
    b. Modifier mon DHCP pour que le nouveau Pi prenne la même adresse que le précédent
  5. a. Rebooter tout le bouzin (routeur/FW/AP pour être sûr)
    b. Coller la nouvelle carte SD dans le Pi4
  6. Brancher et booter le Pi4
  7. Profit… (peut-être :sweat_smile: )

La réalisation du plan :

J’espère ceci mais avec peu d’illusions…


Allégorie d’un plan sans accroc


Si vous avez des remarques/idées/suggestions… Je prend tout.
Même les chèques déjeuner. :pleading_face:

3 J'aime

j’en rigole encore :smiley: :rofl: mal au ventre

mais oui ca devrait se passer sans accros :wink: mais par précaution, allume un cierge, egorge un coq autour d’un feu de camps en dansant tout nu autour au moment de la pleine lune… ca pourrait aider !

Sinon, quand la domotique (et surtout l’humain qui la gère) atteint ses limites:
image
et

Ca marche toujours.

Pas pour rien que je recommande à tout le monde, ailleurs qu’ici pour l’instant -mais je ne fais que commencer en ces lieux (réaction du public : :scream:)- de conserver les inters physiques, hein… :face_with_raised_eyebrow:

Après tout, comme vient de me balancer un pote :

:joy: :rofl: :joy: :face_with_raised_eyebrow:

(sinon ouais j’ai racheté du pétrole pour ma lampe et une bonbonne de gaz pour mon réchaud de camping…) :ninja:

Package reçu.

Dissipateurs collés, malgré le côté chinoisium on a l’air d’être sur du cuivre.
Je vous donne les poids des dissipateurs en question (nul doute que les internetz sauront donner leur opinion là dessus et donneront la composition exacte du truc… c’est juste que j’avais une balance sur le bureau)
1.04g pour la ram
5.29g pour le proco
0.68g pour l’usb

Y’a un vague truc préinstallé sur la SD.

Ça se clip pas trop mal dans le boîtier…

Je tente le boot direct…

Première erreur de noob que j’ai réalisé en lançant SSH… Par défaut c’est coupé. :man_facepalming: :

Retour à la case édition de la carte SD.

Okay… Ça ne passe toujours pas…

Je sens que je vais formater la SD pour y coller un truc que je connais.

On va tenter la co directe sur un écran…

Je vais aller me fouetter avec des orties fraîches.

Tu m’étonnes que le SSH ne fonctionnait pas même après correction sur la SD… J’attaquais la mauvaise IP.

Z’avez le droit de vous moquer.

Bilan :
Le matos a l’air de marcher
Daedaal est toujours aussi con que d’hab
Il est 21h10, je sens que je vais plutôt travailler ma cuisinière que faire ma migration

(heu je parle bien entendu de me faire à manger bande de sales !)

Suite au prochain numéro et j’ai comme dans l’idée qu’il sera gratiné vu le démarrage…

2 J'aime

Premier test effectué.

Échec critique. Le Pi4 démarre vaguement, aucun moyen d’y accéder (même en natif sur un raspbian)…

Je sens que ce truc va m’énerver ! Limite je me dis que j’aurais aussi vite fait de réappairer toutes mes ampoules que de me fritter sur le transfert…

Nan, je déconne…

Je vais prendre le temps pépouze demain. En plein jour au moins. Parce que la maglite entre les dents… c’est marrant 5 minutes mais après ça pique un peu.

Je sens bien le simple bug d’IP parce que mon DHCP n’a pas reporté la bonne assez vite.

Au pire je ferai une réinstall propre de hass et j’importerai mon backup de deconz.

(je vous avais dit que ce ne serait pas une partie de plaisir… :stuck_out_tongue:)

1 J'aime