Mosquitto Broker Socket Error client <unknown>, disconnecting

bonjour

je suis sur HA supervisor-2021.06.8 avec un pi 4 avec SSd
et une Conbee II.
j’utilise zigbee2mqtt
ma Conbee est très bien détecté et j’arrive très bien a appairer et faire fonctionner les périqhériques.
mais dans le journal de Mosquitto Broker :

1628509973: New connection from 172.30.32.2 on port 1883.
1628509973: Socket error on client <unknown>, disconnecting.
1628510093: New connection from 172.30.32.2 on port 1883.
1628510093: Socket error on client <unknown>, disconnecting.
1628510159: Saving in-memory database to /data/mosquitto.db.
1628510213: New connection from 172.30.32.2 on port 1883.
1628510213: Socket error on client <unknown>, disconnecting.
1628510333: New connection from 172.30.32.2 on port 1883.
1628510333: Socket error on client <unknown>, disconnecting.
1628510453: New connection from 172.30.32.2 on port 1883.

cette erreure défile toute la journée (tout comme dans le poste de pilou8830)
sauf que moi l’adresse IP est pas la meme 172.30.32.2
et je ne s’est pas du tout comment y remédier.
j’ai bien entendu créé un utilsateur mqtt (sans droit admmin) sous HA.

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
  user: mqtt
  password: mqtt
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2438983-if00
  adapter: deconz
advanced:
  log_level: warn
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

config MQTT:

logins: []
customize:
  active: false
  folder: mosquitto
certfile: fullchain.pem
keyfile: privkey.pem
require_certificate: false

Ma configuration


System Health

version core-2021.8.4
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.6
os_name Linux
os_version 5.10.17-v8
arch aarch64
timezone UTC
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 6.2
update_channel stable
supervisor_version supervisor-2021.06.8
docker_version 20.10.6
disk_total 109.3 GB
disk_used 3.7 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons File editor (5.3.3), Zigbee2mqtt (1.21.0-1), Mosquitto broker (6.0.1), Visual Studio Code (3.6.1)
Lovelace
dashboards 1
resources 0
mode auto-gen
___

je vient a l’instant de trouver un sujet d’une autre personne qui est confronté au meme problème que moi.
je suis a creuser de se coté la.

https://github.com/home-assistant/addons/issues/2097

Salut,

Si tu as accès en ssh à homeassistant, tu peux essayer de trouver à qui est assignée l’ip en question

docker inspect -f '{{.Name}} - {{.NetworkSettings.Networks.hassio }}' $(docker ps -aq) |grep 172.30.32.2

voila la réponse a la commande:

/hassio_supervisor - {0x400061e9c0 [] [supervisor 7173c1745181] 3289f6d9c5c1a4f48b1d9b1c6f1ba53b622417567bc812661f6e8c3936fc9da9 678be94ee98906718a03e10981eb05287c315689f1bd970f3a41f28f01f8c4bf 172.30.32.1 172.30.32.2 23 0 02:42:ac:1e:20:02 map[]}

j’en déduit que sous l’adresse 172.30.32.2 se trouve hassio supervisor

C’est ça. Mais du coup, comme c’est l’adresse de transit … ça va pas donner plus d’info sur le coupable

J’ai eu ce genre de problèmes et j’y ai perdu pas mal de temps !!!

Le seul contournent que j’ai trouvé a été de restaurer une ancienne version du broker. Il y a quelques personnes qui en parlent sur GitHub.

image

Merci, ne sachant plus quoi faire.
je vais suivre t’ai conseille, et éssayer ça.

Bonjour, je pense bien avoir le même problème :

Tu as trouvé une solution ? Je voulais changer le port par défaut, c’est trop simple comme idée ?

Merci pour votre aide.

Bonjour

non malheureusement je n’ai pas trouvé de solution.
je me suis résigné a tout formater le SSD de mon Pi 4 et tout réinstaller.
j’ai ensuite commencé pas créer un utlisateur MQTT en premier
installer Mosquito broker
Zigbee2mqtt en dernier.
et ca ma porté chance l’érreure n’était plus présente.
a ne rien y comprendre.

bonne chance

Mince alors.
Je reçois bien les messages, on dirait :


Mais il y a énormément de messages d’erreur dans le journal.
J’ai essayé d’arrêter Mosquito, désinstaller puis recommencer. Ca ne change rien. Pas évident les débuts avec HA ! Je suis surpris, peu de personnes semblent rencontrer ce problème.

Oh, je viens de voir cela dans le Github :


Apparemment, c’est normal !