Nextcloud home assistant

Mon problème

Bonjour je cherche a mettre en place Nextcloud serveur sur home assistant via le module, j’aimerais que le dossier de donnée soit un dossier qui est sur un partage qui est monté via la gestion de stockage intégré dans HA.
Voici la configuration et le message d’erreur que j’ai…
Merci d’avance :pray:

Ma configuration




Texte à remplacer par votre configuration

Comment récupérer ma configuration :
Dans votre HA, Menu latéral Paramètres > Système > Corrections puis les trois petits points en haut a droite > Informations Système puis une fois en bas Copier


Salut,

je ne sais pas d’où tu as récupéré l’add-on NextCloud, j’en avais pas encore vu.
Mais comme un add-on n’est qu’un Container Docker, pour avoir accès aux partages, il faut que l’add’on ait ajouté un volume /share pointant sur le répertoires des partages de HA.

En faisant un tour sur mon portainer, j’ai vu que la majorité de mes add-ons ne le font pas…

Salut apparemment c’est bon je vois bien mes données via le docker et l’addon a été récupéré chez alexbelgium

Salut,

Dans le container, fais un coup un whoami et un ls -lah ? Il semblerait plus que c’est une histoire de permission UNIX que un problème de montage …

voici les infos
image

Ok, alors maintenant qu’on sait que tout est monté en root, il faudrait d’une manière ou d’une autre voir sous quel process tourne NextCloud dans ton container (sans doute avec ps aux).

Si il tourne sous un utilisateur avec moins de privilèges que root, il faut monter ton volume avec ces privilèges là.

je récupère ça comme info

et voici les infos que tu m’as demandées tout à l’heure, mais sur le dossier d’origine, mais je n’arrive pas a mètre en place les mêmes droits sur le parage que j’ai monté, j’ai même essayé de mettre le user abc dans le groupe root mais ça ne change rien.

Tu comptes utiliser ce folder NextCloud ailleurs ?

Si non, la solution « quick and dirty » serait de faire un chown abc:users /share/DATA/Nextcloud dans ton container. Il va changer le owner du folder et normalement, sur la machine hôte, vu que le user abc n’existe pas tu devrais voir un nombre à la place. C’est pas très propre, mais ça marche.

Une autre solution, encore pire, est de simplement faire un chmod 777 /share/DATA/Nextcloud pour donner accès à tout le monde au folder. Mais c’est vraiment dégeu et ça n’isole plus du tout ton folder.

J’ai essayé ça, mais ça ne marche pas, en fait, j’ai fait autrement, je suis reparti de zéro et j’ai mis dans les options de configuration les infos suivantes :
networkdisks: //192.168.1.10/Partages/Nextcloud
cifsusername: « Utilisateur »
cifspassword: « mot de passe »

Puis à la 1ʳᵉ connexion web pour le paramétrage, j’ai fait pointer le dossier de données sur le point de montage et c’est bon.

Merci pour ton aide

Top, content que tu aies résolu ton soucis !