Pas de mise à jour de l'état des capteurs z2m

Hello !

Je m’arrache les cheveux sur ce problème depuis quelques jours et il va me falloir un coup de main pour trouver la solution.
Voilà le souci. J’ai acheté récemment une clé Phoscon Conbee 2 et 2 matériels zigbee :

  • 1 contrôleur Gledopto GL-C-009 (pour gérer un ruban de led horticole)
  • 1 contacteur de puissance CASAia-CCB-432-32 (qui intègre en plus la mesure de la puissance et totalise la conso électrique)

J’ai installé l’add-on Zigbee2mqtt et il m’a créé des sensors pour les 2 matériels.
Mon problème est que leur état n’est jamais mis à jour. Par exemple, la valeur de la conso électrique en kWh du CCB-432 ne bouge jamais. Je dois relancer HA pour que la valeur change, juste une fois, en attendant le redémarrage suivant.
Je précise que les matériels fonctionnent. Le contacteur s’allume et s’éteint quand les automatisations le lui demandent, la led aussi. C’est juste que ce que je peux voir dans les cartes lovelace n’a aucun rapport avec ce qui se passe en réalité. C’est ballot pour faire du monitoring…

Je ne sais même pas par quel bout prendre le truc. J’ai sûrement raté qq chose dans la config, mais je ne vois aucun message d’erreur dans les logs de l’add-on, rien non plus dans les logs HA.
Si vous avez des idées…
Merci d’avance.

Ma configuration zigbee2mqtt


data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://core-mosquitto
  user: xxxxxx
  password: xxxxxxx
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2476531-if00
  adapter: deconz
advanced:
  log_level: warn
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}
availability: false
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

System Health

version core-2022.2.3
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.63-v8
arch aarch64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4922
Installed Version 1.22.0
Stage running
Available Repositories 979
Downloaded Repositories 13
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 7.2
update_channel stable
supervisor_version supervisor-2022.01.1
docker_version 20.10.9
disk_total 28.6 GB
disk_used 6.6 GB
healthy true
supported true
board rpi3-64
supervisor_api ok
version_api ok
installed_addons Samba share (9.5.1), SSH & Web Terminal (10.0.2), Duck DNS (1.14.0), Let’s Encrypt (4.12.0), File editor (5.3.3), Home Assistant Google Drive Backup (0.105.2), Spotify Connect (0.10.0), Mosquitto broker (6.0.1), Zigbee2mqtt (1.23.0-1)
Lovelace
dashboards 5
resources 6
views 13
mode storage
Spotify
api_endpoint_reachable ok

Salut,

Quelques détails dont tu n’as pas parlé et que tu pourrais vérifier:

  • Les valeurs sont elles mises à jour dans Z2M ?
  • Tu as essayé d’écouter ce qu’il se passe sur les topics MQTT côté HA en commençant par « zigbee2mqtt# » ?

Alors, non, je viens de regarder dans l’interface utilisateur web de z2m. Les valeurs ne sont pas mises à jour.
Et les 2 matériels sont qualifiés de « Vu il y a » N/A. Pas bon signe ça…

Wow ! En écoutant ce topic, j’ai instantanément 6 messages au contenu très très riche. Qu’est-ce que je dois regarder pour avancer ?

Si dans l’interface de Zigbee2MQTT de ta sonde (onglet Expose) tu n’as pas de valeurs mises à jour, ça n’a pas beaucoup de chances de remonter de nouvelles valeurs dans HA… et le problème n’est pas forcément HA du coup…

Pour le MQTT, rien de spécial, juste voir que des choses arrivent et que tu vois des infos de tes appareils… justement c’était pour voir si des nouvelles valeurs arrivaient ou pas…
Les messages super longs sur les topics « zigbee2mqtt/bridge/# » c’est juste les messages généraux qui permettent d’avoir la liste et les specs de tous tes capteurs…
Tu devrais ensuite avec d’autres messages sur des topics comme « zigbee2mqtt//# » qui mettent les valeurs à jour…

Oui, je ne soupçonnais a priori pas de problème côté HA. Je comprends bien que si rien ne bouge dans z2m (du moins en apparence, parce que en réalité oui), il n’y a pas grand chose à publier. Plutôt un truc que j’aurais loupé côté z2m.

Bon ben je vais attendre de voir ce qui se passe cette nuit. Le contacteur devrait faire son job. Je verrai demain le résultat dans les messages publiés.

Je constate aussi que les LQI sont assez faibles. ça peut jouer ?

Pour info supplémentaire, à la base tout a tourné nickel pendant quelques jours avec ZHA. Les valeurs se mettaient à jour quasi instantanément. Sur le CCB432, j’avais même des sensors supplémentaires par rapport à ce que voit z2m. Mais la Conbee 2 a décidé de passer en mode « Offline » et donc n’assurait plus son rôle de passerelle (pas compris pourquoi, je n’avais rien bricolé ou mis à jour). Je n’ai pas su régler ce problème, d’où mon essai avec z2m. Mais si je pouvais restaurer le fonctionnement avec ZHA, ça m’irait nickel aussi !
Mais bon…avoir des problèmes et tenter de les régler, c’est toujours apprendre :wink: donc z2m ou zha, peu m’importe, je prends :smiley:
En tout cas, merci pour ton aide

LQI bas c’est pas forcément bon… il est possible que ton soucis soit plus lié à la qualité de signal.
Si tes appareil sont « loins » ou au travers de plus de 1 mur ca commence à être problématique.

J’avais un capteur de température, 15m, au travers d’un mur porteur.
Aucun répéteur entre le capteur et la clé.
Ca donnait des pertes de connections de plusieurs heures et aucune nouvelle valeur.
C’est seulement l’ajout de répéteurs entre qui a aidé…

Maintenant ça dépend vraiment de ton installation et de la situation des pièces.

Il y a bien des messages concernant le contacteur qui apparaissent à l’écoute du sujet.
Par exemple :

{
    "energy": 120.39,
    "linkquality": 143,
    "power": 0,
    "state": "OFF"
}

« energy » c’est la valeur en kWh du compteur d’énergie consommée
« power » la valeur en W de la puissance instantanée
Elles ne bougent pas alors qu’elles devraient.

« state » l’état On ou Off du contacteur
Lui il fonctionne

Salut

je pensais au début que ton matériel n’était pas encore intégré dans Z2M mais en cherchant CASAIA CCB432 control via MQTT | Zigbee2MQTT et Gledopto GL-C-009 control via MQTT | Zigbee2MQTT, il semble que si.

Malgré tout, même si pris en compte, il y a parfois quelques différences. J’ai par exemple une télécommande zigbee qui est bien intégrée et qui pourtant ne donne pas du tout le résultat escompté.

tu écoutes le sujet avec quoi ??? MQTT explorer???
En théorie, si le sujet lu reste fixe, c’est que ton matériel le transmet fixe. Comme il n’y a pas d’interface d’administration, la seule intervention que tu puisses faire, c’est la réinitialisation d’usine (appuyer 10s sur le bouton), ou carrément la réinitialisation des valeurs d’énergie (2 fois de suite la réinitialisation d’usine).

Après cela il faudra à nouveau appairer, en espérant que ça règle ton problème.

Sinon ensuite il te restera le forum Z2M pour éventuellement soumettre un ticket

A+ Fred

Merci pour ton intervention.

Je n’ai pas voulu écrire un pavé dans mon premier message, mais ça fait partie des premières choses que j’ai vérifiées avant de poster.

Comme c’était juste à des fins de test, j’ai écouté directement dans l’intégration Mosquitto / configurer / écouter un sujet.

ça pue pour moi, si c’est le cas et qu’il n’y a pas une option dans la config pour activer un truc qui ne l’est pas par défaut.

J’ai déjà dû passer par la réinitialisation d’usine pour associer le contacteur à la conbee via z2m. Le seul mode appairage (appui de 3s) ne permettait pas d’y arriver. J’ai bien peur que la réinitialisation des valeurs d’énergie ne m’apporte pas grand chose de plus :confused:

Je vais sûrement être contrait d’en passer par là.

Du coup, je vais quand même essayer de voir si j’arrive à rattraper ZHA.
Je vais créer un autre sujet pour en discuter.

Salut,

tu n’a pas dit à quoi ressemble ton environnement.
A combien de distance sont le capteurs de la clé Zigbee.
Tu dis que le LQI est bas, c’est combien ?
(un de tes messages montre 143, c’est plutot correct)

Salut,
Ben c’est une vieille maison des années 30 rénovée. Il y a de vrais murs, pas des cloisons minces.
Cela a donc une influence directe sur les LQI, j’imagine.
Le LQI pouvant monter à 255, je pensais intuitivement que 143 ce n’était pas terrible. Mais je n’ai aucune référence. Je découvre tout juste le zigbee.
Le ruban led horticole est le plus éloigné. Il doit être à 10/12m de la conbee, avec 2 murs à passer.
Le contacteur est à environ 7m de la conbee, avec 2 murs aussi.

Il y a quand même un truc qui me fait dire que mon problème n’a pas de rapport évident avec les LQI. C’est que, avec ZHA (bon ok, je n’ai pu l’utiliser que quelques jours), je n’ai constaté aucune latence à la mise à jour des sensors. C’était hyper réactif.

ZHA et Z2M font en théorie le même travail mais en pratique, le résultat est totalement différent en fonction du matériel zigbee que l’on possède.
De mon côté, rien moyen de faire avec ZHA alors que tout fonctionne parfaitement sous Z2M. Peut être qu’avec un peu de chance, ce sera l’inverse pour toi :wink:

Hello,
Après quelques jours de test, je pense pouvoir annoncer que… cela fonctionne correctement ! :partying_face: :champagne:
Merci à toi pour cette suggestion :

C’est le seul truc qui ait marché.

Deux petites infos complémentaires apprises au passage:

  • pour les 2 matériels dont je dispose, le paramètre « Last seen » n’est jamais renseigné. Sa valeur est toujours « N/A ». Mais ça n’a pas grande importance. Je ne m’en sers pas,
  • l’orientation spatiale du matériel semble avoir une incidence sur la LQI. Pour le contrôleur Gledopto, elle oscillait entre 30 et 80 avec des pertes de connexion. Depuis que je l’ai orienté différemment, en le laissant exactement au même endroit, elle varie en 130 et 180.

Encore un grand merci pour le coup de main !

Cool, heureux d’avoir pu t’aider

Il y a souvent beaucoup de paramètres à la remontée qui ne sont pas d’une grande utilité.

Ce n’est pas étonnant. La communication entre deux éléments est liée par le positionnement des antennes de ces éléments. En modifiant légèrement le positionnement, tu as simplement placé les antennes dans une position plus favorable.

A+ Fred