Pool pump manager

Mon problème

Bonjour a tous,

Comme beaucoup je souhaite automatiser la filtration de ma piscine. J’ai installer un module Shelly pour contrôler la pompe. Je voulais une solution simple pour estimer la durée de filtration de la piscine en fonction de la température.
Je me suis donc reporté vers pool pump manager mais impossible de le faire fonctionner. Je l’ai installé avec HACS puis j’ai ajouter les lignes de codes suivantes dans mon fichier configuration.yaml

pool_pump:
  switch_entity_id: switch.shelly1_244cab43ed87
  pool_pump_mode_entity_id: input_select.pool_pump_mode
  pool_temperature_entity_id: sensor.pool_water_temperature

Je n’ai aucun switch qui se rajouter dans mes entités. Quelqu’un utilise cette intégration pour faire fonctionner sa piscine?
Par ailleurs je n’ai pas de capteur de température pour ma piscine. Je pensais utiliser la température donnée par l’intégration météo france. Je ne sais pas si cela permet un calcul fiable du temps de filtration. Quelqu’un peut il faire un retour?
Merci d’avance

Salut,

Il y a 2 version de pool_pump celle sur la branche master et celle sur la branche dev

là, ta configuration ressemble à celle pour la master, mais je te conseil d’utiliser la dev

Voici comment je le configure :

pool_pump:
  switch_entity_id: switch.pompe_piscine
  pool_pump_mode_entity_id: input_select.pool_pump_mode
  pool_temperature_entity_id: sensor.piscine_filtrage
  schedule_break_in_hours: 0.0

au lieu de ce type de conf :

pool_pump:
 switch_entity_id: switch.pool_pump_switch
 pool_pump_mode_entity_id: input_select.pool_pump_mode
 swimming_season_entity_id: input_boolean.swimming_season
 run_pool_pump_hours_swimming_season_entity_id: input_number.run_pool_pump_hours_swimming_season
 run_pool_pump_hours_off_season_entity_id: input_number.run_pool_pump_hours_off_season

si tu n’a pas de sonde de température, je te conseil de crée un input_number pour simuler la temperature manuellement : (on peut faire ça en GUI maintenant)

input_number:
  pool_water_temperature:
    name: Temperature Piscine
    min: 0
    max: 30
    step: 0.1
    mode: slider
    unit_of_measurement: 'H'

et après, tu l’utilisera, comme ça : pool_temperature_entity_id: input_number.pool_water_temperature

Je pense que le module doit être en erreur car ton sensor.pool_water_temperature n’existe pas (si tu n’a pas de sonde de temperature , sensor.pool_water_temperature ne peut pas exister , non ? )

je te conseil fortement d’activer les logs de cette extension pour trouver ton souci, tu peut faire ça comme ça :

logger:
  default: warning
  logs:
    custom_components.pool_pump: debug

ps: il faut bien-sur crée le input_select associé : (on peut faire ça en GUI maintenant)

input_select:
  pool_pump_mode:
    name: Piscine Mode
    options:
      - 'Auto'
      - 'On'
      - 'Off'