Problème avec zigbee2mqtt

Mon problème

Le programme zigbee2mqtt ne se lance pas

Ma configuration


[center]## System Information

version core-2022.10.1
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.10.5
os_name Linux
os_version 5.15.61-v8
arch aarch64
timezone Europe/Paris
config_dir /config
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 9.0
update_channel stable
supervisor_version supervisor-2022.09.1
agent_version 1.3.0
docker_version 20.10.17
disk_total 28.5 GB
disk_used 4.7 GB
healthy true
supported true
board rpi3-64
supervisor_api ok
version_api ok
installed_addons Mosquitto broker (6.1.3), Terminal & SSH (9.6.1), File editor (5.4.1), Zigbee2MQTT (1.28.0-1)
Dashboards
dashboards 1
resources 0
views 10
mode storage
Recorder
oldest_recorder_run 2 octobre 2022 à 16:27
current_recorder_run 6 octobre 2022 à 23:03
estimated_db_size 17.00 MiB
database_engine sqlite
database_version 3.38.5
[/center]

Bonjour,
c’est mon premier post, je ne sais pas si je suis au bon endroit et le la forme du message est correcte.
Veuillez m’en excuser.

J’aimerais connecter l’appareil lixee sur mon compteur Linky, mais il faut installer zibgbee2mqtt et je ne comprends absolument rien.

J’ai une passerelle Sonoff Zigbee 3.0 USB Dongle Plus à laquelle j’ai lié 4 capteurs de température et tout fonctionne.

J’ai essayé plein de choses et ça ne fonctionne pas, existe-t-il un fichier type où il suffit juste de changer quelques info ? je sais pas vraiment par quoi commencer.

Merci

Didier

J’ai modifié le fichier /config/zigbee2mqtt/configuration.yaml :
homeassistant: true
permit_join: true
mqtt:
server: mqtt://localhost:1883
user: user_mqtt
password: user_mqtt
serial:
port: /dev/ttyUSB0
adapter: deconz

les logs :

[20:35:01] INFO: Preparing to start…
[20:35:02] INFO: Socat not enabled
[20:35:06] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:info 2022-10-07 20:35:16: Logging to console and directory: ‹ /config/zigbee2mqtt/log/2022-10-07.20-35-15 › filename: log.txt
Zigbee2MQTT:info 2022-10-07 20:35:16: Starting Zigbee2MQTT version 1.28.0 (commit #unknown)
Zigbee2MQTT:info 2022-10-07 20:35:16: Starting zigbee-herdsman (0.14.62)
Zigbee2MQTT:error 2022-10-07 20:35:27: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-10-07 20:35:27: Failed to start zigbee
Zigbee2MQTT:error 2022-10-07 20:35:27: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-10-07 20:35:27: Exiting…
Zigbee2MQTT:error 2022-10-07 20:35:27: undefined

_Dans le module ziggbee2mqtt onglet configuration :
socat
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777

slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: « -d -d »
log: false

mqtt
server: mqtt://localhost:1883

serial__

Salut,

Bon déjà faut remettre les choses au clair je pense :wink:
A commencer par :
Si tu as la clé Sonoff qui marche et 4 capteurs de températures visibles des Home Assistant, ça veut dire que don réseau Zigbee marche. Mais aussi surement que tu utilises ZHA, la passerelle Zigbee intégrée à Home Assistant.

Zigbee2MQTT c’est un concurrent.
Et les 2 ne peuvent pas marcher ensemble, ils se disputeraient l’accès à la clé Sonoff.

Bref avant d’aller plus loin dans la question Zigbee2MQTT, faut déjà confirmer ce que tu veux faire.

Je ne sais pas, ZLinky, il ne marche pas avec ZHA ? (je n’utilise pas ça, donc je ne sais pas.)

Merci pour ton retour.

Je pensais que zigbee2mqtt était juste une couche de plus et que ZHA servait de lien entre le zigbee et le mqtt.
L’ignorance fait faire n’importe quoi :grinning:

Partout j’ai lu qu’il fallait utiliser zigbee2mqtt pour communiquer avec zlink.
Avec ZHA, je n’ai pas réussi à appairer (je sais pas si c’est le bon terme) Zlink, sur le coup je me suis dit
qu’il fallait absolument zigbee2mqtt . En plus le compteur linky est à l’extérieur dans la rue (à moins de 10m de l’antenne du dongle sonoff).

mon objectif est de communiquer avec des objets zigbee mais surtout avec le zlink.

Je vais revoir tout ça et rééssayer d’appairer le zlink avec ZHA. je sais pas vraiment comment tester ce module sans le bancher au compteur.

Je vais aller faire un tour sur les tutos et infos du forum, trop de lacunes, même si j’ai une bonne connaissance linux, je connais pas HA.

merci !

Didier

ps : j’ai essayé de désactiver le ZHA et lancer zigbee2mqtt mais rien à faire.
comme je teste sans comprendre ce que je fais, c’est mal parti.

[21:58:01] INFO: Preparing to start…
[21:58:02] INFO: Socat not enabled
[21:58:07] INFO: Starting Zigbee2MQTT…
TypeError: Cannot read properties of undefined (reading ‹ mqtt ›)
at /app/lib/util/settings.ts:379:43
at Array.reduce ()
at /app/lib/util/settings.ts:377:46
at Array.forEach ()
at iterate (/app/lib/util/settings.ts:370:26)
at /app/lib/util/settings.ts:409:21
at Array.forEach ()
at iterate (/app/lib/util/settings.ts:370:26)
at /app/lib/util/settings.ts:409:21
at Array.forEach ()

Salut,

Pour utiliser les périphériques Zigbee les plus répandus, ZHA c’est suffisant et très simple à mettre en place, vu que ça marche dès que tu banches la clé.
Zlinky de Lixee, d’après leur page produit est compatible avec ZHA aussi, je suppose que pour le faire marcher il doit être branché et alimenté par le compteur.

Si tu es du genre à vouloir essayer les produits Zigbee les plus exotiques, alors passer à Zigbee2MQTT peut avoir un intérêt, il couvre énormément plus d’appareils que ZHA.
Mais si tu veux le faire, vaux mieux utiliser le tuto présent sur ce forum.

Bonjour,

Merci pour tes réponses, je vais faire un tour sur les tutos et les posts, il y a beaucoup d’infos.
En regardant les posts, j’ai réussi à faire marcher ziggbee2mqtt (non sans mal) et à utiliser les capteurs de température.
Pour le moment, je n’ai pas réussi à appairer la z_link, mais je ne désespère pas, il y a pas mal de post sur le forum à ce juste.

Didier

1 « J'aime »

bonjour,

comment as tu reussi a faire fonctionner la clé sonoff avec zigbee2mqtt ?

Attention il existe 2 types de clé sonoff
celle a base de chipset CC2652P c’est la cle ZBDONGLE-P
celle la est reconnue directement par Z2M

la seconde ZBDONGLE-E est a base de EFR32MG21
je crois qu’il faille saisir un paramatre specifique pour qu’elle soit reconnue

voir

consulte le debut du sujet pour identifier ta version
il,y a un tableau donnant les differences

1 « J'aime »

tout a fait :
la version E :
Capture d’écran 2022-12-06 133858
il y a adapter en plus.

la version P:

1 « J'aime »

salut tu as reussi a configurer je n’y arrive pas non plus

Si tu nous donnes aucune indication des problèmes rencontrés, ça n’ira pas très loin…

j’essai de configurer avec SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2


La solution été juste plus haut, te faut rajouter la ligne adapter: ezsp pour la v2 [model E].

j’ai essayer mais ca marche pas non plus !
je dois pas etre douer

as tu desactivé ZHA dans les integrations?
tu as pas autre chose dans ton log?

Salut,
tu as quoi comme installation de HA, MQTT & Zigbee2MQTT.
Car le mqtt://localhost:1883 ça me parait suspect, si tu as Z2M en container, le localhost pas certain que ce soit correct.

Pas de container ha supervisé mosquito broker mqtt et zigbee2mqtt

Mais « HA Supervised » c’est avec des container sous docker.
Donc si mosquitto et zigbee2MQTT c’est installé en tant que modules complémentaires le config du serveur MQTT devrait être l’exemple donné dans la doc du module:

  • Depending on your configuration, the MQTT server config may need to include the port, typically 1883 or 8883 for SSL communications. For example, mqtt://core-mosquitto:1883 for Home Assistant’s Mosquitto add-on.

Bah visiblement le MQTT se connecte pas… :slight_smile:
Mosquitto tourne bien? et l’as tu déjà connecté à HA?

enlève la partie MQTT et relance, cela devrait etre bon.
image

un peu de lecture sur ce post : Je n'arrive pas à faire fonctionner Zigbee2mqtt - #9 par LeLapinFou

1 « J'aime »