Problème carte Xiaomi Map pour robot aspirateur

Bonjour a tous

Je ne sais pas ce qu’il se passe, je n’ ai plus de Map avec mes robots, pourtant la configuration est bonne et les robots sont biens reconnus sur les cartes.
Ci joint le code et la carte, merci de votre aide


Ma configuration


Home Assistant 2023.6.2
Supervisor 2023.06.2
Operating System 10.2
Interface utilisateur : 20230608.0 - latest

Bonjour Mickael,

Regarde l’indentation de tes lignes attributes:, j’ai l’impression qu’il y a une tabulation en trop

d’après la doc

camera:
  - platform: xiaomi_cloud_map_extractor
    host: !secret xiaomi_vacuum_host
    token: !secret xiaomi_vacuum_token
    username: !secret xiaomi_cloud_username
    password: !secret xiaomi_cloud_password
    draw: ['all']
    attributes:
      - calibration_points

Cordialement
Abel

Bonjour,
Parfois aussi ça me le fait en redémarrant le robot ça le recharge normalement

Salut

j’ai ce comportement de manière récurrente. c’est pour moi secondaire car la commande de l’aspirateur est toujours possible

Bonjour
Oui , moi aussi la carte fonctionne ne pas toujours très bien, elle me sert beaucoup. Et là le problème est que je n’ai plus jamais la Map …que se passe-t-il ?

Bonjour,

Désolé, je ne vais pas aider beaucoup, mais j’ai moi aussi ce problème depuis quelques semaines.
Mais ce que je remarque c’est quand j’ai cette erreur dans HA, si je vais dans l’application, la carte ne charge pas non plus, ça reste en chargement de la carte en cours. Je ne sais pas si c’est systématique mais je l’ai déjà constaté.

Bonjour. J’ai également un problème avec xiaomi robot vacuum e12 et l’application xiaomi home. La carte ne se charge pas. J’ai tenté de lancer le robot depuis l’application ou depuis le robot directement sans succès…
Si qqun a une suggestion… merci

Bonjour,
J’avais le même problème de perte de carte, pour simplifier, je perdais la carte l’après midi et la récupère le lendemain matin. Dans home assistant, j’ai désactivé la mise à jour de la carte (auto_update: false) et j’ai remarqué que je ne perdais plus la carte dans l’appli Xiaomi (mi-home).
La solution que j’ai trouvé pour ne plus la perdre, c’est de désactiver la mise à jour de la carte qui est par défaut réglée à 5 secondes et d’utiliser le blueprint proposé par PiotrMachowski pour gérer la mise à jour de la carte quand le robot est utilisé.
Depuis je n’ai plus de problème…