Problème pour appairer mes devices zigbee

Hello,

Mon problème

Après 7 mois d’arrêt suite à un kernel panic, j’ai remis en fonction HA.
Evidemment ça ne s’est pas passé simplement, mais j’ai pu tout remettre en fonction à l’exception des devices Zigbee à partir de ma clé Conbee II connecté à un Raspberry PI 4.
Je pense avoir tout essayé (avec les liens utiles partagés sur le forum) :

  • clé Conbee II branché sur l’USB 2 du PI 4, avec un cordon de rallonge
  • j’ai tenté le changement de channel 11 à 25 (25 de mémoire celui que j’avais avant le kernel panic)
  • HA/Deconz m’indiquent une clé activée, le firmware est à jour 2.13.4 sous HA, 26660700 sous Deconz/Phoscom, version de la configuration Deconz 6.11.1
  • les devices Zigbee sont des Xiaomi Aqara capteur de mouvement, de vibration, d’ouverture de porte et un répéteur Ikea Tradfi, j’ai changé les piles de Aqara capteur de mouvement et vibration pour les tester sans succès
  • j’ai fait des appuis longs (mode réinitialisation) ainsi que des appuis courts toutes les secondes; le capteur répond par 3 clignotements rapides, puis 1 rapide, puis 1 lent, mais rien n’accroche sous HA :frowning:
  • j’ai essayé les intégrations Deconz et ZHA (en désinstallant le précédent pour n’avoir qu’une intégration zigbee)
  • le debug view donne ceci

    Bref je pense avoir tout essayé, et je n’arrive pas à les appairer :frowning:
    Pouvez-vous m’aider à voir comment je peux résoudre ce problème ? :thinking: :frowning:
    Merci d’avance pour votre aide :pray:

Ma configuration


[center]## System Health

version core-2021.12.8
installation_type Home Assistant Supervised
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.87-v7l+
arch armv7l
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 5000
Installed Version 1.19.3
Stage running
Available Repositories 998
Downloaded Repositories 29
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Raspbian GNU/Linux 11 (bullseye)
update_channel stable
supervisor_version supervisor-2021.12.2
docker_version 20.10.12
disk_total 915.6 GB
disk_used 29.3 GB
healthy true
supported failed to load: Unsupported
supervisor_api ok
version_api ok
installed_addons Duck DNS (1.14.0), ESPHome (1.16.2), File editor (5.3.3), Home Assistant Google Drive Backup (0.103.1), Mosquitto broker (6.0.1), Portainer (1.4.0), Samba share (9.5.1), Terminal & SSH (9.3.0), deCONZ (6.11.1)
Lovelace
dashboards 1
resources 22
views 12
mode storage
[/center]

Du coup je me demande si ça ne viendrait pas de la clé Conbee II ?
Je me demande donc si ça ne vaut pas le coup de profiter des soldes pour acheter une nouvelle clé Zigbee = pour des devices Xiaomi Aqara et Ikea Tradfi, quelle clé me conseilleriez-vous ? en effet, je me demande si la clé Sonoff zigbee 3.0 est capable de lire mes devices.
Merci pour vos retours

Salut.
Avant de changer de matos as tu essayé l’intégration zigbee2mqtt ? C’est celle qui offre la plus grande liste de capteurs supportés…
Attention également, si beaucoup de périphériques usb => alimentation avec assez de puissance du pi ?

1 « J'aime »

Hello @Pulpy ,

J’ai donc désinstallé Deconz/Phoscon, et installé l’add-on Zigbee2mqtt.
J’ai laissé le port /dev/ttyACM0 qui correspond à l’adresse de la clé Conbee 2 dans la configuration; mais après le démarrage, le journal me donne ces messages d’erreurs, même après redémarrage HA

J’ai vu que ce code d’erreur peut concerner la mauvaise nomination du port, mais il s’agit pourtant bien de /dev/ttyACM0 (j’ai tenté /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2215462-if00 mais c’est le même message d’erreur)

Je ne vois pas ce qui peut clocher :frowning:

Salut,
Tu as mis la bonne valeur ?

Yes Merci !! ça marche mieux avec adapter: conbee
Du coup, ça a permis de poursuivre le démarrage avec succés.
J’ai pu lancer l’add-on en barre latérale pour activer l’appairage, mais rien y fait :frowning: , il ne détecte pas mon capteur de mouvement Xiaomi Aqara tout comme le capteur de vibration Xiaomi Aqara

J’ai retiré la clé bluetooth et caméra, des ports USB du pi4 (donc il ne reste plus que le SSD et la rallonge USB2 > conbee II, et redémarré HA; mais rien n’y fait :frowning: :sob:

Cool. Maintenant il ne reste plus qu’à voir les logs et à confirmer que le capteur n’est pas dans la liste zigbee2mqtt

Donc c quoi la règle pour un conbee 2 et zigbee2mqtt:
Adapter: deconz ou adapter: conbee?

Combee c’est pas dans la doc… Erreur de retranscription probablement

Cliquant sur « Activer Appairage (Tout) » et sur les boutons des devices zigbee ~5s pour avoir des clignotements (Xiaomi Aqara mouvement, Xiaomi aqara vibration et répéteur ikea tradfi), j’obtiens le journal debug suivant; (il y a 2 messages join car j’ai fait 2 essais d’appairage); je suis à 1 mètre pour les 2 capteurs, et 1 étage d’écart pour le répéteur (mais le répéteur j’étais arrivé sans souci à l’apairer à l’époque); qu’en penses-tu @Pulpy ?

Hello,
De ce qu’on voit là, l’appairage n’est pas fini.
Pour le bouton et le capteur de vibration, il ne faut pas oublier de les actionner environ toutes les 5 sec, afin qu’il envoit un payload complet.

arrgh, j’ai beau appliqué tes conseils (appui court toutes les 5sec.) et au bout de 2 tentatives de 240s de tentatives d’appairage, toujours aucun device détecté, c’est incroyable :frowning: je suis désemparé, je vois pas d’où ça peut venir
Je note quand même que la nature des clignotements a évolué : de 3 clignotements rapides aprés 3-4s d’appui long, puis 1 rapide après relachement, puis 1 long 3-4s après; je suis passé à 1 rapide une fois sur 2, et 10 clignotements très rapides suivi d’un rapide, l’autre fois sur 2.
Dans les log, je voix cela :

info  2022-01-14 23:47:52: Zigbee: allowing new devices to join.
info  2022-01-14 23:47:53: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"cp3z3-1"}'
info  2022-01-14 23:48:00: Succesfully changed options
info  2022-01-14 23:48:00: MQTT publish: topic 'zigbee2mqtt/bridge/response/options', payload '{"data":{"restart_required":false},"status":"ok","transaction":"cp3z3-2"}'
debug 2022-01-14 23:48:06: Saving state to file /config/zigbee2mqtt/state.json
debug 2022-01-14 23:51:57: Received MQTT message on 'zigbee2mqtt/bridge/request/permit_join' with data '{"device":null,"time":254,"transaction":"cp3z3-3","value":false}'
info  2022-01-14 23:51:57: Zigbee: disabling joining new devices.
debug 2022-01-14 23:51:57: Received MQTT message on 'zigbee2mqtt/bridge/request/permit_join' with data '{"device":null,"time":254,"transaction":"cp3z3-4","value":false}'
info  2022-01-14 23:51:57: Zigbee: disabling joining new devices.
info  2022-01-14 23:51:59: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":false},"status":"ok","transaction":"cp3z3-3"}'
info  2022-01-14 23:51:59: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":false},"status":"ok","transaction":"cp3z3-4"}'
info  2022-01-14 23:52:18: Connected to MQTT server
info  2022-01-14 23:52:18: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
debug 2022-01-14 23:52:24: Received MQTT message on 'zigbee2mqtt/bridge/request/permit_join' with data '{"device":null,"time":254,"transaction":"qy7lg-1","value":true}'
info  2022-01-14 23:52:24: Zigbee: allowing new devices to join.
info  2022-01-14 23:52:25: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"qy7lg-1"}'
debug 2022-01-14 23:53:06: Saving state to file /config/zigbee2mqtt/state.json
debug 2022-01-14 23:58:06: Saving state to file /config/zigbee2mqtt/state.json
debug 2022-01-15 00:01:08: Received MQTT message on 'zigbee2mqtt/bridge/request/networkmap' with data '{"routes":false,"transaction":"qy7lg-2","type":"raw"}'
info  2022-01-15 00:01:08: Starting network scan (includeRoutes 'false')
debug 2022-01-15 00:01:09: LQI succeeded for 'Coordinator'
info  2022-01-15 00:01:09: Network scan finished
info  2022-01-15 00:01:09: MQTT publish: topic 'zigbee2mqtt/bridge/response/networkmap', payload '{"data":{"routes":false,"type":"raw","value":{"links":[],"nodes":[{"definition":null,"failed":[],"friendlyName":"Coordinator","ieeeAddr":">
debug 2022-01-15 00:03:06: Saving state to file /config/zigbee2mqtt/state.json
debug 2022-01-15 00:08:06: Saving state to file /config/zigbee2mqtt/state.json
debug 2022-01-15 00:10:57: Received MQTT message on 'zigbee2mqtt/bridge/request/networkmap' with data '{"routes":false,"transaction":"eko2a-1","type":"raw"}'
info  2022-01-15 00:10:57: Starting network scan (includeRoutes 'false')
debug 2022-01-15 00:10:58: LQI succeeded for 'Coordinator'
info  2022-01-15 00:10:58: Network scan finished
info  2022-01-15 00:10:58: MQTT publish: topic 'zigbee2mqtt/bridge/response/networkmap', payload '{"data":{"routes":false,"type":"raw","value":{"links":[],"nodes":[{"definition":null,"failed":[],"friendlyName":"Coordinator","ieeeAddr":">
debug 2022-01-15 00:11:06: Received MQTT message on 'zigbee2mqtt/bridge/request/permit_join' with data '{"device":null,"time":254,"transaction":"eko2a-2","value":true}'

le state.json se résume à {}
pour information, mais je ne pense pas que cela pose problème, j’ai mis le channel 25 dans la configuration (pour éviter la zone de channel 11 … wifi …)

J’ai pas joué avec les canaux chez moi mais là il n’y a clairement aucune trame de type ‹ annoucement › qui indique la présentation d’un appareil. Donc communication entre le clé et les appareils = nulle
Au niveau des clignotement c’est un gros bordel y compris au sein de la même marque c’est jamais pareil. Seule la doc est salvatrice.
Le principe est cependant simple : mode join sur la clé + reset du device pour répartir propre + séquence apparaige + attendre la fin de la création côté HA.

Merci pour tes retours @Pulpy = que me conseilles-tu de faire du coup ?
= tu penses que ça peut venir de la clé qu’il faut changer ? est-ce qu’une clé Sonoff zigbee 3.0 fonctionneraient avec d’anciens devices zigbee ?
Je te rejoins : le principe est simple, et ne m’avait pas posé trop de souci sous Deconz jusqu’à présent (qq soucis de maj firmware ou changement canal)
Mais là je me dis que ça ne peut venir que de la clé car sinon j’aurais réussi à appairer 1 des 3 devices testés.
Je sais que chacun se fait sa propre expérience des protocoles, différentes d’une personne à l’autre; c’est sûr que cette expérience me freine, même si auparavant j’étais très satisfait de mes 4 devices zigbee en réactivité/stabilité ; changer de protocole me coûterait cher sans forcément avoir la réactivité/stabilté :frowning:

Salut,

Personnellement, je remettrai pas trop le matériel en cause. Une clé non fonctionnelle, mais juste assez correcte pour ne rien voir, et ça sans produire par ailleurs la moindre erreur … j’y crois pas trop. C’est pas du matériel ‹ mécanique › qui s’use avec l’age, et c’est pas non plus de la techno pour fusée… Mis à part mettre le firmware en l’air, je pense que c’est assez robuste pour resister à plein de contraintes
Quant à la panne des 3 devices en même temps … les proba sont quasi nulles
La première source défaillance, c’est généralement l’utilisateur, dans ton cas, comme c’est pas ta première experience, c’est pas forcement le cas principal.
Reste la configuration : une coquille, un paramètre pas compatible, ça me parait une bonne piste, d’autant plus que tu sembles avoir fait quelques changements de ton coté (le canal par exemple)
Donc à ta place, suppression de l’addon, flash de la clé avec la dernière version (même si c’est déjà le cas), reinstallation de l’addon et tests avec la config la plus basique/par défaut possible => port usb + option deconz + confg mqtt et c’est tout !!
Et puis il reste un test facile à faire… Utilise phoscon pour faire 1 appairage, si ça fonctionne c’est pas la clé

OK, je me disais aussi pour le firmware de la clé pouvait être la cause . Mais à priori l’add-on deconz me disait qu’il était à jour
= des conseils pour flasher le dernier firmware de la clé ? Sinon je recherche sur le net
= quand tu dis phoscon, = je ne sais pas trop à qu’elle méthode tu penses : une site qui teste le matériel ? Un branchement sur pc ?

Pour le flash et le logiciel, coté site fabriquant c’est bien pour commencer

https://phoscon.de/en/conbee/software#phoscon-app

Alors, bilan de la soirée :

  • firmware updaté sous linux (26720700) flashé sur la clé conbee 2 en appliquant ton 2ème lien
  • retentative d’appairage sans succès
  • après une tentative phoscon sur pi4, j’ai simplement installé deconz sur PC puis tester l’apparaige sous Phoscon, mais rien n’y fait
  • peut-être que cette capture d’écran du deconz avec un voyant rouge peut donner un indice non ?

oups, j’ai l’impression qu’il n’a pas aimé ma mise à jour firmware

pourtant

j’y comprends plus rien

Reflashé sous PC, et ça se passe aussi bien que sous pi4; mais même message d’erreur du debug help :frowning:

Donc même avec deconz sur PC l’appairage ne marche pas ? Tu passes bien par phoscon « add new light » ?
Il ne te reste qu’a comparer ta config avec celle la Network lost and configuration restore does not help · dresden-elektronik/deconz-rest-plugin Wiki · GitHub
Souvent en testant la conbee sur d’autre solution la configuration peut etre changée (Des 0xDDDDDDDDDDD a la place des 0x00000000)

Hello @hoeby
Oui même avec déconz sur PC, l’apairage ne marche pas. C’est exact je suis passé par phoscon, mais comme il s’agit d’un « motion sensor » j’ai plutôt pris « ajouter un nouveau capteur » (comme je le faisais à l’époque pour ce device).
Mais tu as raison, la configuration Network Settings différait sur l’aspect « Static NWK address » qui était coché et « NWK update ID » qui était à 3 = du coup, en décochant et mettant 1, sauvegardant puis relançant « join network », et refaisant une tentative d’appairage capteur sous phoscon, voilà que ça marche du premier coup !! :slight_smile: super !!
Demain, je bascule donc cette manip du PC vers le pi pour voir si ça marche aussi … je vous tiens au courant