[Resolu] Du ménage dans MQTT

Bonjour à tous,

Je débute dans HA et je pense que j’ai besoin de faire du ménage avec MQTT. Je m’explique :
J’ai suivi ce tuto initialement pour installer MQTT pour mon aspirateur xiaomi (firmware valetudo)…je pense que le probleme vient de là…J’avais une integration sans avoir le module Mosquitto broker derriere, je ne sais pas si c’est un fonctionnement logique.
Mon aspirateur est donc actuellement connecté sur test.mosquitto.org : 1883
MQTT - Home Assistant

Ensuite, pour myelectricaldata, j’ai installé le module mosquito broker. Et là, il me disait au moment de la config que le port 1883 était déjà utilisé. J’ai donc défini le port 1885.

Desormais, je test avec MQTT explorer, et j’ai une connexion refusée…

Pouvez vous m’aider a remettre tout ca au propre ?? Comment savoir ce qui tourne sur le port 1883 ?

Ma configuration


|Version|core-2023.7.1|
| — | — |
|Type d’installation|Home Assistant Supervised|
|Développement|false|
|Supervisor|true|
|Docker|true|
|Utilisateur|root|
|Environnement virtuel|false|
|Version de Python|3.11.4|
|Famille du système d’exploitation|Linux|
|Version du système d’exploitation|5.10.0-23-amd64|
|Architecture du processeur|x86_64|
|Fuseau horaire|Europe/Paris|
|Répertoire de configuration|/config|


Salut,

Y’a pas mal de choses qui ne tiennent pas la route :confused:
test.mosquitto.org c’est un serveur public pour tester uniqument. Je doute que ton aspi soit conencté là dessus et que ça marche sur ton HA.

Si tu as le port 1883 d’utilisé, tu as surement un autre broker d’installé sur la machine.

Le fonctionnement de MQTT de base c’est 1 broker central sur lequel tous les appareils et applis qui passent pas MQTT envoient et lisent leurs messages.

Peux tu partager la liste des add-ons qui tu as actuellement installé sur ton serveur HA?
Va falloir repartir de 0 avec MQTT :slight_smile:

1 « J'aime »

Oui pas de probleme avec ca, je suis là pour ca…Pourtant mon aspirateur fonctionnait via HA…donc etrange…

Voilà ce que j’ai dans mes modules :

Le mosquito broker ne demarre pas en raison du port 1883 déjà utilisé…mais par quoi???

Ca dépend de ce que tu as sur ta machine.
1883 est le port utilisé par défaut par le protocole MQTT, je crois pas qu’il y ait autre chose de répandu qui l’utilise… :confused:

S’il n’y a rien d’autre que HA Supervised. Un test pourrait être d’arrêter tous les autres add-ons.
Puis de démarrer Mosquitto pour voir si ça passe.
Ca c’est juste si jamais tu as par erreur mis le 1883 sur un autre service, pensant installer MQTT.

S’il y a autre chose qui tourne hors HA, faut voir qu’est-ce qui peut y avoir…

Non c’est sur je n’ai pas utilisé le port manuellement pour un autre module, mais je pense que ca vient de la premiere install que j’avais faites pour mon aspirateur…sans avoir installé le module mosquitto broker. J’avais juste une integration MQTT qui apparaissait et qui était configuré pour pointer sur test.mosquitto.org (voilà ce que j’ai utilsié MQTT - Home Assistant) et l’integration s’est install directement
Je l’ai suppr depuis directement depuis le menu integration mais visiblement ca ne suffit pas…

Oui mais non. :slight_smile:
Une intégration utilise le port 1883 du serveur qui est distant dans ton cas.
Le broker lui il veut gérer et ouvrir le port 1883 de ta machine locale.

Donc ce ne peut pas être ça.

Autres idées:

  • Est-ce que sur ton docker tu arrives à voir les ports attachés au container?
  • Redémarrer la machine complètement. Des fois ça suffit.

En lancant la commande sudo netstat -tunlp sur la machine hote, j’ai trouvé ca… :thinking:
tcp 0 0 127.0.0.1:1883 0.0.0.0:* LISTEN 544/mosquitto
En cliquant sur le bouton integration, la conf propose d’utiliser le port 1883 par défaut…donc ca doit bien créer quelque chose quelque part pour appliquer cette conf…??

Si on parle bien d’intégration, non, ça crée dans HA la possibilité d’utiliser MQTT pour des connexions sortantes. Ces connexions sortantes sont vers un hôte (ou un container) avec un port cible.
Le port cible est par défaut 1883.

Mais, en aucun cas, ça ne va rendre le port 1883 de ta machine occupé.

Là, j’ai l’impression que d’une manière ou d’une autre, tu as installé un broker qui lui « bind » sur le port 1883.

@AlexHass t’a donné des pistes.

Je viens de lancer la desinstall direct en ligne de commande…
Je viens de réussir à lancer le module Mosquitto broker sur le port 1883 !
Ma conf :

active: false
folder: mosquitto
logins:
  - username: mqtt
    password: *******
customize:
  certfile: fullchain.pem
  keyfile: privkey.pem
  require_certificate: false

Le journal :

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/mosquitto.sh
[20:53:47] INFO: SSL is not enabled
cont-init: info: /etc/cont-init.d/mosquitto.sh exited 0
cont-init: info: running /etc/cont-init.d/nginx.sh
cont-init: info: /etc/cont-init.d/nginx.sh exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun mosquitto (no readiness notification)
services-up: info: copying legacy longrun nginx (no readiness notification)
[20:53:48] INFO: Starting NGINX for authentication handling...
s6-rc: info: service legacy-services successfully started
[20:53:49] INFO: Starting mosquitto MQTT broker...
2023-07-20 20:53:49: Warning: Mosquitto should not be run as root/administrator.
[20:53:50] INFO: Successfully send discovery information to Home Assistant.
[20:53:50] INFO: Successfully send service information to the Supervisor.

En revanche, toujours impossible de me connecter par MQTT explorer… Connexion refusée

En mettant dans la config de MQTT explorer l’@IP où est le broker, le port 1883, le user mqtt et le password « xxxx » ça devrait marcher.
Tu as bien mis tout ça ?

Je viens de recréer mes users et c’est bon j’ai réussi à me connecter !!!

Mon aspirateur est reconnecté, totu semble etre OK, je vais pouvoir poursuivre, la connexion MQTT explorer fonctionne egalement ! Merci :slight_smile: