Switch ikea/tradfri carré E1743 avec conbee II et ZHA ...za marche pas!

Bonsoir,
J’ai acheté le kit tradfri du débutant: une lampe et un petit interrupteur carré 0/1.

Pour la lampe, je l’ai appairée sans problème avec la conbee II et ZHA, ça marche nickel.

Pour le switch, il y a un problème: l’appairage s’est fait, l’appareil est déclaré mais il ne montre qu’une seule entité: celle du niveau de batterie, mais aucune entité pour actionner le on/off. Rien n’y fait!
Il semble que je ne soit pas le seul dans ce cas
Quelqu’un a-t-il résolu ce problème?
D’avance merci de vos conseils.

Pour les boutons, ce n’est pas l’état qu’il faut utiliser mais l’événement.

Tu n’as pas d’entité car c’est normal :

Il y a des Blueprint ou Controler X qui gère tout ça très bien…

Bonjour et merci de vos réponses,
J’ai peu d’expérience dans le domaine et j’ai du mal à capter la subtilité entre état/événement.
Jusqu’à maintenant, HA m’a proposé la création d’un déclencheur automatiquement dans lovelace. Or pour le switch tradfri, ça n’a pas marché, la proposition était vide. Je ne suis pas le seul à avoir ce problème.
D’après ce que j’ai compris, quand un problème de ce type arrive, les concepteurs de ZHA ajoute une couche zigpy pour corriger le problème. Ces corrections sont apparemment dénommées Zhaquirks. Pour mon switch, la correction est ici (ligne55)
Par ailleurs, Blueprint qui m’évite de reprogrammer toute l’automation n’a pas fonctionné. J’ai essayé.

Prochaine piste: trouver un tuto qui montre comment affiner les réglages de ZHA dans configuration.yaml pour autoriser les OTA tradfri et vérifier que les zhaquirks fonctionnent bien chez moi…

Bon Dimanche! :wink: