Synology -Sonoff (E) Zigbee2mqtt : Error while starting zigbee-herdsman

Bonjour,
Je commence avec la domotique. J’ai un Nas synology 7.2 avec Sonoff module E.
Ma configuration est basé sur deux docker un pour zigbee2mqtt/mosquitto et un autre docker pour HA.
Le souci je n’arrive pas a démarer zigbee2mqtt:

"2024/05/24 22:58:12,stdout,[2024-05-24 22:58:12] e[31merrore[39m: 	z2m: Failed to start zigbee"

"2024/05/24 22:58:12,stdout,[2024-05-24 22:58:12] e[31merrore[39m: 	z2m: Error while starting zigbee-herdsman"

"2024/05/24 22:57:54,stdout,[2024-05-24 22:57:54] e[32minfoe[39m: 	zh:zstack:znp: Skip bootloader for CC2652/CC1352"

"2024/05/24 22:57:52,stdout,[2024-05-24 22:57:52] e[32minfoe[39m: 	zh:zstack:znp: Writing CC2530/CC2531 skip bootloader payload"

"2024/05/24 22:57:52,stdout,[2024-05-24 22:57:52] e[32minfoe[39m: 	zh:zstack:znp: Serialport opened"

"2024/05/24 22:57:52,stdout,""[2024-05-24 22:57:52] e[32minfoe[39m: 	zh:zstack:znp: Opening SerialPort with {\""path\"":\""/dev/ttyACM0\"",\""baudRate\"":115200,\""rtscts\"":false,\""autoOpen\"":false}"

J’ai installé les drivers sur le Nas et le port est /dev/ttyACM0.

xxxx@NasHomeSyn:~$ lsusb -cui
|__usb1          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (Linux 4.4.302+ xhci-hcd xHCI Host Controller 0000:00:15.0) hub
  |__1-1         1a86:55d4:0442 02  1.10   12MBit/s 132mA 2IFs (ITEAD SONOFF Zigbee 3.0 USB Dongle Plus V2 20240122200556)
  1-1:1.0         (IF) 02:02:01 1EP  () cdc_acm tty/ttyACM0
  1-1:1.1         (IF) 0a:00:00 2EPs () cdc_acm

Ma configuration de zigbee2mqtt confiuration.yaml :

homeassistant: true
permit_join: true
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://192.168.1.26:1883'
  client_id: zigbee2mqtt
  include_device_information: true
serial:
  port: /dev/ttyACM0
 #port:        /dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_ 20240122200556-if00-port0
adapter: ezsp

frontend:
  port: 8020

J’espère que qulqu’un puisse m’aider.
Philippe

Bonjour @pfawaz,
quand tu veut afficher du code dans un message, uilise la balise « texte préformaté » ( icone </> ). Ca permet de bien afficher du code ( respecter les espaces ). J’ai éditer ton message.

1 « J'aime »

adapter: doit être au même niveau que port:, il manque 2 espaces

serial:
  port: /dev/ttyACM0
  adapter: ezsp

Depuis la dernière maj de Zigbee2MQTT, pour la clé sonoff E faut passer par le driver ember, le ezsp est désormais obsolète au profit du nouveau ( ember ).

un tuto pour flasher la clé sonoff >>> Mise a jour Sonoff DONGLE -E (pour Zigbee2mqtt 1.37.0-1)(ember) - #115 par pascal_ha

1 « J'aime »

Merciiiiiiiiiiiiiiiiiiiiiii beaucoup @WarC0zes
J’ai flashé le Sonoff avec 7.4.3 et modifié le fichier et ca marche …
J’ai essayé d’abord avec la 7.3 mais ca n’a pas fonctionné.
Encore merci.

1 « J'aime »

c’est le grand classique en ce moment entre Z2M 1.37 et le Dongle E.

Pense a mettre ton sujet en résolu, en cochant la case solution sur le message approprier.

1 « J'aime »