Une solution pour accès HA depuis extérieur mais sur installation modem 4g Freemobile

Bonjour à tous :slightly_smiling_face:

Je suis confronté à un problème génant qui ne me permet pas de profiter pleinement de ma configuration HomeAssistant :slightly_frowning_face:

Mon problème

Impossible d’accéder à Home Assistant depuis l’extérieur de mon « domicile », car j’utilise une connexion en mode 4G sur sim Freemobile.
A priori, mon adresse ip wan et extérieure diffère car en mobile il y à un reroutage entre l’adresse ip publique et celle annoncée à mon routeur, donc impossible de faire de paramétrage de port et réseau.

Avez vous des solutions pour contourner ce problème ?

Ma configuration


System Health

version core-2022.3.8
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.9
os_name Linux
os_version 5.10.92-v8
arch aarch64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.24.0
Stage running
Available Repositories 1081
Downloaded Repositories 5
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 7.5
update_channel stable
supervisor_version supervisor-2022.03.5
docker_version 20.10.9
disk_total 29.0 GB
disk_used 3.5 GB
healthy true
supported true
board rpi3-64
supervisor_api ok
version_api ok
installed_addons deCONZ (6.12.0), Samba share (9.5.1), Terminal & SSH (9.3.0), Duck DNS (1.14.0), File editor (5.3.3)
Lovelace
dashboards 1
resources 3
views 2
mode storage
___

Salut

La fonction de nabucasa est particulièrement adaptée dans ce genre de cas

Payant mais c’est une certaine garantie de pas se prendre la tête avec une solution VPN

2 « J'aime »

Hmm ce n’est pas exactement une utilisation « de bon père de famille » :wink:

As tu regardé les solutions comme Zerotier (y’an un add-on dans HA).
Sinon c’est possible qu’avec HA Cloud ça peut marcher, mais je ne suis pas certain…

@Pulpy-Luke, gg pour la réponse rapide, la recherche de l’aritcle sur free m’a fait perdre 1 min :wink:

@AlexHass J’ai fait simple :innocent:

C’est vrai que zerotier, j’y pense jamais … Le concept est pas mal mais je ne m’y fais pas

1 « J'aime »

J’ai mentionné ça comme possibilité, mais je n’ai jamais expérimenté…

Salut et merci pour vos réponses rapide :slight_smile:

Très sincèrement je doute que ce genre de solution en cloud fonctionne, aussi bien coté Nabucasa, que Zerotier
Le soucis est que je n’ai pas de contrôle sur le « routeur » intermédiaire entre mon modem gérant mon réseau local est donc mon Raspberry Pi 3B+ avec HomeAssistant, et le réseaux extérieur.

A moins que quelqu’un ayant déjà été dans ma situation puisse confirmer que c’est fonctionnel avec une de ces 2 solutions ?

Pour donner un poil plus de détail sur ma situation, et le pourquoi de l’utilisation d’une sim Freemobile en modem 4G, c’est tout simplement que je vie dans un fourgon, comme on dit à la mode vanlife :wink:

Il y pas de raison que la solution de nabucasa ne fonctionne pas…
A la différence d’un mécanisme conventionnel où c’est ‹ toi › qui arrive sur ton routeur depuis l’extérieur, là c’est HA qui vient se connecter que le serveur nabucasa. Toi ensuite utilise nabucasa qui fait l’intermédiaire…

La solution est gratuite pendant 30j tu ne prends pas grands risques à essayer

1 « J'aime »

En fait on a donné ces solutions là spécifiquement à cause de ça. :slight_smile:
Des solutions où tu n’est pas obligé de directement accéder à l’IP publique de la machine.

Après effectivement il faut tout de même voir comment ton modem 4G se comporte et s’il reste connecté et joignable H24… mais ça c’est lié à cette techno.

Salut
Je suis dans le même cas que toi
J’utilise Ngrok et ça marche pas mal

Et en plus si ça marche avec nabu casa, ta contribution permettra de participer à la perenité de la solution.

2 « J'aime »

Bonjour,
J’ai été dans la même configuration et j’utilisais Zerotier ou Wireguard sans aucun problème pendant un an pour accéder à mon HA depuis l’exterieur.
Sinon, il faut passer par un VPS qui a une IP fixe avec lequel on crée un VPN entre HA et ce VPS.
Cette dernière solution était pour moi celle qui me permettait d’utiliser Google Assistant alors qu’avec Zerotier ou Wireguard directement en addons ce n’était pas possible.

C’est l’avantage de la solution officielle nabucasa… GA/GH ça fonctionne nativement

Merci à tous pour vos réponses, je viens de tester avec Zerotier est c’est parfaitement fonctionnel !

En fait c’est beaucoup plus simple que je pensais :slight_smile:

Pour résumé, je rappel ma situation :
Modem 4G, sim Freemobile (abonnement illimité)
Raspberry Pi 3B+ pour Homeassistant

J’ai donc simplement installé le module complémentaire (boutique addon et communautaire), Zerotier One
La configuration est hyper simple, il suffit de créer un « réseau virtuel » sur https://my.zerotier.com/, puis de renseigner l’identifiant de ce réseaux sur la configuration de l’addon.
Ensuite il faut retourner sur les réglages du « réseau virtuel » sur https://my.zerotier.com/ est validé le rajout du Raspberry dans la liste des Members (visible dans le log de l’addon).
De même, ensuite j’ai installé ZeroTier One sur mon smartphone Android, puis rajouter l’identifiant du « réseau virtuel », en cochant l’option « route all traffic ».
Enfin je suis retourné sur les réglages du « réseau virtuel » sur https://my.zerotier.com/ est j’ai validé le rajout de mon smartphone dans la liste des Members (visible en bas de l’application android).

Voilà, c’est parfaitement fonctionnel, bien que ça oblige à activer le « vpn » de Zerotier, donc lancer l’application Android lorsque je veux accéder à mon HomeAssistant, mais c’est top, et gratuit en plus :slight_smile:

Pour l’heure, vue que je suis au début des essais et de l’utilisation de HomeAssistant je vais continuer avec Zerotier, mais par la suite je vais probablement chercher plus poussé et je garde donc dans un coin de ma tête la possibilité de passer par Nabu Casa

1 « J'aime »