ZLinky_TIC - ou connecter simplement Linky en zigbee

Beh tu ma fait connaitre une intégration :slight_smile: merci
je vais regarder comment mettre ca en place.

Bonjour à tous,

Est il possible d’utiliser le Zlinky avec la xiaomi gateway 3 (compatible zigbee 3), au travers du plugin AlexxIT/XiaomiGateway3 ?

Qlq a déjà essayé avec succès ?

Merci :slight_smile:

Sur le github tu l’info : GitHub - AlexxIT/XiaomiGateway3: Control Zigbee, BLE and Mesh devices from Home Assistant with Xiaomi Gateway 3 on original firmware

( le Zlinky est compatible Z2M et ZHA )

j’ai pas de xiaomi gateway 3 mais dans tout les cas il te demande d’avoir Z2M ou ZHA

après si tu utilise Z2M ou ZHA je te conseille d’investir dans une vrais cle Zigbee :slight_smile:

oui, ça fonctionne très bien, j’en parle dans mon commentaire le 24 mars …

Finalement j’ai utiliser TTS. J’ai créer un script sous HA , qui remonte dans google assistant et j’ai créer une routine qui appelle le script.

voici mon script:

alias: Consommaton électrique
sequence:
  - service: tts.google_translate_say
    data:
      entity_id:
        - media_player.nest_mini
      message: >-
        Tu consommes {{
        states("sensor.lixee_zlinky_tic_cf99d205_electrical_measurement_apparent_power")
        }} watts.
mode: single
icon: mdi:transmission-tower

Résultat:
« Ok google, combien je consomme d’électricité ? »
« Tu consommes 390 watts » :smile:

J’ai bien galéré pour ajouter mon Zlinky à deconz, j’utilise la version « classique » de homeassistant avec HassOS, je vous donne donc les étapes qui m’ont permis d’y arriver … me reste maintenant tout le boulot d’intégration dans HomeAssistant mais ce sera pour plus tard.

  1. Collecte de liens :
  1. première étape, se connecter en ssh directement sur HassOs et pas dans le container dedié à HomeAssistant. Le tout est expliqué ici : Debugging the Home Assistant Operating System | Home Assistant Developer Docs

  2. puis, trouver un moyen de copier le fichier ddf quelque part sur HassOs. Làs, j’ai simplement glissé la carteSD dans l’ordi et copié le lixee_zlinky_historique_mono.json dans la partition data. /mnt/data/supervisor/share/

  3. enfin, déplacer le fichier DDF de HassOs vers le container DeCONZ.

# identifier le container Deconz et copier son id ( 26abed96b08c par exemple ) 
docker container ls

# on se connecte au container 
docker exec -it 26abed96b08c /bin/bash

#on vérifie que le chemin suivant nous emmène bien quelque part 
/data/.local/share/dresden-elektronik/deCONZ/devices/

# reste à copier le tout : 
docker cp /mnt/data/supervisor/share/lixee_zlinky_historique_mono.json 26abed96b08c:/data/.local/share/dresden-elektronik/deCONZ/devices/
  1. Puis la tambouille deconz très bien illustrée ici : intégration à HA via deconz · Issue #16 · fairecasoimeme/Zlinky_TIC · GitHub.
    astuce : ne pas oublier de passer le status en Gold, sinon, vous allez vous retrouver bloqué comme lui juste à l’arrivée.

et voilà, j’espère maintenant que ça va durer un peu avant d’avoir à remettre les mains dedans… :slight_smile:

2 « J'aime »

Bonjour à tous,

Et voilà un petit saut vers fin may 2022: je viens de recévoir mon Lixee que j’ai installé sur mon compteur triphasé.
J’ai l’ai ajouté avec ZHA et je constate que :

  • toujours pas d’index remontant automatiquement dans le dashboard Energie

Je regarde la procédure de @max : mettre à jour le firmware, puis ajouter des entités, puis une automation…, puis je regarde ma montre … 01.42am :frowning: … et là, j’hésite :slight_smile: → grand merci, @max j’ai peur, mais c’est top ce que vous avez fait :wink:

Que ferez-vous à ma place ?

  1. la nuit ne fait que commencer : suivez la procédure de @max
  2. pourquoi dormir ? C’est l’opportunité de tester zigbee2mqtt: installe zibgee2mqtt + mqtt broker en parallèle de ton ZHA et rajoute ton Zlink_TIC via zigbee2mqtt une fois pour toutes
  3. allez dormir: un jour, ZHA va ratrapper zigbee2mqtt et comme par magique, tout va commencer à fonctionner tout seul

En autres mots: combien de temps estimé pour la procédure de @max et combien de temps pour partir de zéro sur zigbee2mqtt ?

Merci pour vos avis !!

Bon, j’ai fini par essayer de mettre à jour le firmware de Zlinky_TIC… sans succès:

j’ai ajouté ceci dans mon configuration.yaml (d’abord sans et après avec les 2 dernières lignes):

zha:
  zigpy_config:
    ota:
      otau_directory: /config/zigpy_ota
      ikea_provider: false
      ledvance_provider: false

Ensuite, j’ai suis allé dans mon addon SSH, j’ai créé un répertoire /config/zigpy_ota et j’ai téléchargé le fichier .ota avec wget:

wget https://github.com/fairecasoimeme/Zlinky_TIC/releases/download/v5.0/ZLinky_router_v5.0.ota

Et puis j’ai redémarré Home Assistant. Et rien. Et puis j’ai redémarré le host. Et mon ZLinky_TIC est toujours en v1… est-ce que j’ai loupé une étape ?

Merci !

Enfin, j’ai réussi finalement à mettre à jour le firmware !

J’ai dû ajouter une nouvelle ligne dans config:

zha:
  zigpy_config:
    ota:
      otau_directory: /config/zigpy_ota
      ikea_provider: false
      ledvance_provider: false
      salus_provider: false

Désormais, je suis en V5.

Bonjour,
Je suis nouveau sur le forum.
J’ai reçu mon ZLiny_TIC hier mais je ne parviens pas à le mettre à jour ; il reste en version 1.
J’utilise une Zigate en version 3.1d.
HomeAssistant est en version core-2022.5.5

Je pense pourtant avoir bien suivi la procédure (et attendu longtemps, plus d’une nuit…)
Dans mon fichier configuration.yaml, j’ai ajouté :

J’ai également copié le fichier .ota :

J’ai ensuite reboot HomeAssistant (j’ai également tenté un reboot de la VM et même un reboot du Host).

Il ne se passe rien.
A noter, qu’il n’y a quasi rien dans les logs non plus ce que je trouve également étrange :

Quelqu’un a t il une idée ?

Merci

En complément de mon message juste au dessus, en me connectant en SSH, j’ai bien les logs en debug présent pour l’upgrade OTA.
Il semble bien trouver le fichier et l’upgrade mais le progress reste à 0.0

2022-05-25 08:39:38 DEBUG (SyncWorker_2) [zigpy.ota.provider] ImageKey(manufacturer_id=4151, image_type=1): /config/zigpy_ota/ZLinky_router_v5.0.ota, version: 5, hw_ver: (None, None), OTA string: OM15081-RTR-JN5189-0000000000000

et un peu plus bas :

2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA query_next_image handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacture_id=4151, image_type=1, current_file_version=1, hardware_version=None, model=ZLinky_TIC
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01A\x01\x007\x10\x01\x00\x01\x00\x00\x00'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=65, command_id=1, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:query_next_image(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, current_file_version=1)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x01 (TSN 65): query_next_image(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, current_file_version=1)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA query_next_image handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacture_id=4151, image_type=1, current_file_version=1, hardware_version=None, model=ZLinky_TIC
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01A\x01\x007\x10\x01\x00\x01\x00\x00\x00'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=65, command_id=1, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:query_next_image(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, current_file_version=1)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x01 (TSN 65): query_next_image(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, current_file_version=1)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA query_next_image handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacture_id=4151, image_type=1, current_file_version=1, hardware_version=None, model=ZLinky_TIC
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image version: 5, size: 240478. Update needed: True
2022-05-25 08:43:11 INFO (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Updating: LiXee ZLinky_TIC
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=65, command_id=2, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: query_next_image_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, image_size=240478)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] No OTA image is available
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=65, command_id=2, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: query_next_image_response(status=<Status.NO_IMAGE_AVAILABLE: 152>, manufacturer_code=None, image_type=None, file_version=None, image_size=None)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.util] Duplicate 65 TSN
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image version: 5, size: 240478. Update needed: True
2022-05-25 08:43:11 INFO (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Updating: LiXee ZLinky_TIC
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=65, command_id=2, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: query_next_image_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, image_size=240478)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.util] Duplicate 65 TSN
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01B\x03\x007\x10\x01\x00\x05\x00\x00\x00\x00\x00\x00\x000'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=66, command_id=3, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x03 (TSN 66): image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image_block handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacturer_id=4151, image_type=1, file_version=5, file_offset=0, max_data_size=48, request_node_addr=Noneblock_request_delay=None
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA upgrade progress: 0.0
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=66, command_id=5, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: image_block_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, image_data=b'\x1e\xf1\xee\x0b\x00\x018\x00\x00\x007\x10\x01\x00\x05\x00\x00\x00\x02\x00OM15081-RTR-JN5189-0')
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01B\x03\x007\x10\x01\x00\x05\x00\x00\x00\x00\x00\x00\x000'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=66, command_id=3, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x03 (TSN 66): image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image_block handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacturer_id=4151, image_type=1, file_version=5, file_offset=0, max_data_size=48, request_node_addr=Noneblock_request_delay=None
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA upgrade progress: 0.0
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=66, command_id=5, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: image_block_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, image_data=b'\x1e\xf1\xee\x0b\x00\x018\x00\x00\x007\x10\x01\x00\x05\x00\x00\x00\x02\x00OM15081-RTR-JN5189-0')
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.util] Duplicate 66 TSN
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01B\x03\x007\x10\x01\x00\x05\x00\x00\x00\x00\x00\x00\x000'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=66, command_id=3, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x03 (TSN 66): image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image_block handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacturer_id=4151, image_type=1, file_version=5, file_offset=0, max_data_size=48, request_node_addr=Noneblock_request_delay=None
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA upgrade progress: 0.0
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=66, command_id=5, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: image_block_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=0, image_data=b'\x1e\xf1\xee\x0b\x00\x018\x00\x00\x007\x10\x01\x00\x05\x00\x00\x00\x02\x00OM15081-RTR-JN5189-0')
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.util] Duplicate 66 TSN
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01C\x03\x007\x10\x01\x00\x05\x00\x00\x00(\x00\x00\x000'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=67, command_id=3, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x03 (TSN 67): image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image_block handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacturer_id=4151, image_type=1, file_version=5, file_offset=40, max_data_size=48, request_node_addr=Noneblock_request_delay=None
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA upgrade progress: 0.0
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=67, command_id=5, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: image_block_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, image_data=b'000000000000^\xab\x03\x00\x00\x00 \xab\x03\x00\xe0_\x01\x04\x01\x02\x00\x00#\x02\x00\x00\xads\x00\x00\xc5s')
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01C\x03\x007\x10\x01\x00\x05\x00\x00\x00(\x00\x00\x000'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=67, command_id=3, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x03 (TSN 67): image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image_block handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacturer_id=4151, image_type=1, file_version=5, file_offset=40, max_data_size=48, request_node_addr=Noneblock_request_delay=None
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA upgrade progress: 0.0
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=67, command_id=5, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: image_block_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, image_data=b'000000000000^\xab\x03\x00\x00\x00 \xab\x03\x00\xe0_\x01\x04\x01\x02\x00\x00#\x02\x00\x00\xads\x00\x00\xc5s')
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.util] Duplicate 67 TSN
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received ZCL frame: b'\x01C\x03\x007\x10\x01\x00\x05\x00\x00\x00(\x00\x00\x000'
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=0, is_reply=0, disable_default_response=0, reserved=0, *is_cluster=True, *is_general=False), tsn=67, command_id=3, *is_reply=False)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Decoded ZCL frame: Ota:image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Received command 0x03 (TSN 67): image_block(field_control=<FieldControl.0: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, maximum_data_size=48)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA image_block handler for 'LiXee ZLinky_TIC': field_control=FieldControl.0, manufacturer_id=4151, image_type=1, file_version=5, file_offset=40, max_data_size=48, request_node_addr=Noneblock_request_delay=None
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] OTA upgrade progress: 0.0
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply header: ZCLHeader(frame_control=FrameControl(frame_type=<FrameType.CLUSTER_COMMAND: 1>, is_manufacturer_specific=False, is_reply=1, disable_default_response=1, reserved=0, *is_cluster=True, *is_general=False), tsn=67, command_id=5, *is_reply=True)
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.zcl] [0x6280:1:0x0019] Sending reply: image_block_response(status=<Status.SUCCESS: 0>, manufacturer_code=4151, image_type=1, file_version=5, file_offset=40, image_data=b'000000000000^\xab\x03\x00\x00\x00 \xab\x03\x00\xe0_\x01\x04\x01\x02\x00\x00#\x02\x00\x00\xads\x00\x00\xc5s')
2022-05-25 08:43:11 DEBUG (MainThread) [zigpy.util] Duplicate 67 TSN

Faut compter 15 min pour le flash a 100%. Je suis sur rpi3 , donc sur VM je sais pas trop mais est ce que ta clef zigate est bien installer ?

moi j’avais mis ca dans le configuration.yaml

zha:
  zigpy_config:
    ota:
      otau_directory: /config/zigpy_ota
      ikea_provider: false
      ledvance_provider: false

logger:
  default: info
  logs:
    homeassistant.components.zha: debug
    zigpy: debug

Oui, la Zigate est bien installée. D’ailleurs les données de Linky remonte bien dans HA.

Bonjour à tous,
Quelqu’un arrive t’il a avoir les données d’injection avec Zlinky + Z2Mqtt + linky en mode standard ?
Merci par avance
Stéphane

Bonjour, De mon côté le Zlinky est intégré avec Z2M et les données sont visibles dans l’interface zigbee2Mqtt.
En revanche impossible de faire remonter les données dans le tableau de bord énergie.
Quelqu’un a t’il fait remonter les données Zlinky dans le tableau de bord énergie ?

Oui sans problème depuis des mois

Bonjour.
Actuellement j’ultilise le ZLinky avec Z2mqtt, et suite à un passage de mon compteur en mode standard (je suis en triphasé, mode base), je n’arrive pas à avoir la puissance instantanée délivrée, les valeurs sont fantaisistes en comparaison avec les valeurs du compteur (j’ai bien supprimé le ZLinky de Z2mqtt, puis ré-appairage).
Quelqu’un qui serait en triphasé, mode standard peut-il me confirmer qu’il arrive à afficher ces valeurs ?
Pour info, j’utilise le sensor ZLinky_TIC_EASD01 pour la consommation dans la carte énergie.

Merci par avance

Oups je me rends compte que je ne t’ai jamais répondu.
J’utilise Gazpar :

Par contre c’est du quotidien et pas génial pour cela.
GRDF dispose d’une option (12€/an) pour avoir du détail horaire pour les relevés, mais la demande ne peut pas être faite par un particulier, mais obligatoirement par son fournisseur d’énergie (qui s’occupe de re-facturer).
SAUF QUE je suis chez Total Energie et qu’après des semaines de négo avec le support client qui ne comprenait rien, ils ont fini par me dire qu’ils ne faisaient pas pour le moment.

Et GRDF m’a confirmé qu’ils n’avaient eu aucune demande de la part de Total Energie (même s’ils avaient la possibilité de le faire, ça n’est juste pas encore dans leur offre).