Accéder a Home Assistant depuis l’extérieur en HTTPS avec un NDD Freebox et Let's Encrypt

@Herbs
La conf de mon accès distant est bonne, pas de port 443 dans cette conf
J’ai aussi tenté de modifier l’url interne pour mieux coller au tuto en remettant l’ip de la machine host de HA, mais cela ne change rien (je n’aurais pas compris que ce soit ça le pb :crazy_face:)

De quelle partie tu parles ? je ne te suis pas

Hello
@pcan
As tu pensé a scanner les ports ouvert - fermer ??

Oublie pas que quand tu modifie les ports sur la freebox , tu dois OBLIGATOIREMENT reboot celle-ci électrique , pour que les paramètres soit pris en compte

Autre chose :

Tu ne dis nullement si tu as un IP FULLSTACK

J’ai bien une IP Fullstack

Le résultat nmap

Starting Nmap 7.40 ( https://nmap.org ) at 2022-10-15 17:49 UTC
Nmap scan report for MON_IPV4.subs.proxad.net (MON_IPV4)
Host is up (0.093s latency).
PORT     STATE    SERVICE
...
443/tcp  open     https
...

Es-tu certain pour le hardreboot de la FB ?
J’ai un doute car :

  • si je désactive la redirection du port 443 ça ne fonctionne plus en local en utilisant le ndd
  • si je désactive la redirection du port 8123 ça ne fonctionne plus sur ce port en utilisant le ndd (interne et externe)

Dans le doute, j’ai quand même reboot la FB, mais ça ne résoud pas mon problème

Et oui , ca fait X année que je suis chez free , me suis deja fait avoir a ce sujet pour les ports
Mais la on vois qui est ouvert

Dans la box tu as une section DMZ , met l’adresse IP de HA pour voir

Et reboot , essai de te connecté

Le fais de mettre HA dans le DMZ , cela ouvre tous les ports

@ClassicRed
Je pratique aussi free depuis un certain temps :wink: mais la je coince …
J’ai essayé de passer par la fonction DMZ comme tu me l’as suggéré, et ce fut un test intéressant bien que ça ne fonctionne pas non plus.
En effet, j’active la DMZ et j’indique bien la machine HA en destination, je valide avec « Appliquer », puis « OK », pas de changement, alors je redémarre la freebox, idem … je reviens sur les paramétres de gestion des port de la freeebox, et la … la DMZ n’est pas activé :thinking:
Je me dis alors que je suis fou, mal réveillé, je recommence, pareil :crazy_face:

Conclusion, je ne peux pas activer la DMZ, et la redirection du port 443 ne fonctionne toujours pas.

J’ai un peu cherché, et j’ai vu sur le forum de l’ADUF que certain avaient le même problème.

Dans des temps lointain on faisait les paramétrages du routeur de la FB sur notre espace abonné, page de paramétrage à laquelle je n’ai plus accès. Je me demande s’il n’y a pas un reliquat de conf de l’époque qui traîne chez free qui fait que ma redirection ne fonctionne pas (un vieux paramétrage de redirection de ce même port vers une autre IP).

Donc, j’arrête de traiter ce problème ici pour l’instant et je vais contacter Free pour voir de quoi il en retourne.

Merci @Pulpy @Herbs & @ClassicRed d’avoir essayé de m’apporter de l’aide

J’ai pas free donc ça fait un long moment que je n’ai pas suivi les évolutions de l’interface mais il y a une option pour rendre l’accès à la console d’administration possible depuis internet. C’est ça qu’il faut chercher et désactiver

Bon ben là c’est un mal pour un bien ! Activer la dmz sur ha est un non sens ! Tout internet directement envoyé sur un système domotique c’est courir un risque démesuré (partage samba, accès ssh, port mqtt et j’en passe)

Si quelqu’un sait ou est planquée cette option, je suis preneur

Edit : si tu parles de ceci c’est désactivé, et ce n’était de toute façon pas sur le port 443
image
image

Oui bien sur, c’était juste pour tester et voir ce que ça pouvait nous apprendre, je ne suis ni un expert réseaux, ni un expert sécu pour m’aventurer la dedans et devoir mettre en place FW, WAF, etc … pour sécuriser mon install

@pcan

L’accès distant à la console de la box est désactivé chez moi.

Malgré cela elle garde en mémoire le port que j’avais paramétré pour ça, c’est visible en allant ici :

http://mafreebox.freebox.fr/api_version

Je n’utilise pas le ndd freeboxos pour HA, mais en local j’accède bien à la box via le port 443 depuis https://ndd.freeboxos.fr/login.php (j’héberge mon serveur dns local qui pointe ce domaine vers la box).

Et de l’extérieur la redirection du 443 vers le 443 de mon reverse proxy fonctionne bien.

J’ai cherché et à part le wifi, on dirait qu’on ne peut plus paramétrer quoique ce soit depuis l’interface client.

Juste pour être sur tu as bien l’option « Activer l’authentification par mot de passe » décochée ?

image

Salut a tous,

je viens de lire les échanges, c’est peut etre bêtes mais je tiens a faire par de cette remarque.

@pcan Si tu veux avoir acceder a ton serveur HA depuis l’extérieur et le port 443, il faut faire une redirection du 443 vers le 8123 de ton serveur domotique, car seul le 8123 est accessible pour HA (par défaut)

Ou sinon passer par NPM et depuis NPM tu rediriges le ndd vers ip-local:8123

mais je ne pense pas que tu puissr acceder a HA via le port 443 ? (en tojt cas par défaut)

Marty :smiley: C’est bien ce que j’essaye de faire (voir mon premier post ici) :

Je pense que passer par NPM ne changera rien, ça me parait maintenant évident que c’est bien la redirection du port 443 qui ne fonctionne pas sur le FB

@Herbs : l’option « Activer l’authentification par mot de passe » était activée, c’est drôle, mais la encore, j’ai fait l’essaie de désactiver, Appliquer, puis OK, pas de changement, redémarrage FB et c’était à nouveau coché …
Cela dit, le port pour la connexion sécurisé à la console FB depuis l’extérieur n’est pas le 443

Peux-tu partager un lien stp ?

Je sais pas ce que t’as vu sur le sitre de l’aduf, mais dans ce cas là je dirai reset vers les « paramètres d’usine » ?

pardon j’ai lu les différentes réponses mais pas forcément fait attention aux images.

je n’ai. plus de freebox depuis peu donc je ne pzux pas vérifier.

est ce que quelqu’un qui a une. freebox a pu tester voir si chez lui ca marche cette config ?

Je me suis embrouillé, c’est sur le bug traker de free, voici le lien

C’est ce à quoi j’ai pensé un moment, mais pour l’instant j’aimerais éviter car j’ai une conf DHCP assez fourni et je n’ai pas de garanti que l’export de la conf de FB exporte ces params

Bonjour tout le monde !

Aprés être resté bloqué quelques jours, je me suis mise à lire le thread !
J’ai lu avec attention les messages precedents sur le problèmes de @pcan et je suis dans la même situation.

Bonjour,
Actuellement j’accède depuis l’extérieur à HA en http (FAI Free en IP statique) et j’ai ce message dans HA « code-server is being accessed in an insecure context. Web views, the clipboard, and other functionality may not work as expected. »
Si je suis les indications de ce tutoriel (création nom de domaine + Let’s Encrypt), la remarque de @McFly laisse penser qu’il faudra faire quelque chose en plus pour sécuriser ? (VPN)

@pcan , désolé du retard mais en voyant votre discussion, je peux peut-être t’aider.

J’ai une Révolution avec un Home Assistant sur un PC et j’y accede bien de l’extérieur via une redirection du port 80 et 443 :
image

Je n’ai aucune redirection sur le port 8123 de configurer dans la console Freebox.

Donc tout mon trafic entrant passe par ce PC-SERVEUR-DOMO.
Sur ce PC-SERVEUR-DOMO, j’ai installé un Nginx-Proxy-Manager qui me permet de router mon flux en fonction de l’URL.

Par exemple, depuis l’extérieur, je peux accéder à mon HA via l’URL https://home-assistant.mondomaine.fr et mon NPM redirige le flux https de home-assistant.mondomaine.fr vers l’URL en http et IP : http://192.168.1.3:8123.

En plus NPM gère seul les rafraîchissements des certificats auprès de let’s Encrypt.

Pour configurer Nginx Proxy Manager, tu peux t’appuyer sur le tuto : ✅ Accès de l’extérieur en HTTPS avec Nginx Proxy Manager