Ajout d'une clé Bluetooth dans HA

Mon problème

Je n’arrive pas à faire apparaitre dans « hardware » de la partie « supervisor », une clé USB bluettoth.
Je la vois bien sur mon hyperviseur (Proxomox), et je l’ai ajouté sur ma VM « HA », mais rien n’apparait.
Au cas où, j’ai bien rebooter ma VM, pour que le changement soit prit en compte.
Merci de votre aide !

Ma configuration


version 2021.1.5
installation_type Home Assistant OS
dev false
hassio true
docker true
virtualenv false
python_version 3.8.7
os_name Linux
os_version 5.4.86
arch x86_64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4908
Installed Version 1.10.1
Stage running
Available Repositories 778
Installed Repositories 7
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Hass.io
host_os Home Assistant OS 5.10
update_channel stable
supervisor_version 2021.01.7
docker_version 19.03.13
disk_total 97.7 GB
disk_used 9.9 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons Check Home Assistant configuration (3.6.0), File editor (5.2.0), Samba share (9.3.0), motionEye (0.11.0), Google Assistant SDK (2.5.0), Let’s Encrypt (4.11.0), Home Assistant Google Drive Backup (0.103.1), Log Viewer (0.9.1), AdGuard Home (3.0.0), room-assistant (2.13.0)
Lovelace
dashboards 1
mode storage
views 7
resources 1
___

Je comprends que tu utilises proxmox. Dans ce cas, peux tu lancer:

lsusb

Dans l’hôte proxmox et dans la VM ou tu veux voir la clé bluetooth.

Il faudrait s’assurer qu’au niveau OS la clé est bien « là ».

Je vois bien la clé en ligne de commande, et également sur ma VM (suite à son ajout par l’interface web).
Avec les dernières versions de PROX, il n’y a plus besoin de les intégrer à sa VM à la main, tout se fait par l’interface web.
En fait j’ai également un 2eme périphériques USB (mon RFLINK), je suis en train de me dire, que je devrais certainement faire comme le RFLINK, l’ajouter à ma conf HA, pour qu’il fasse son job, non ?

Je n’ai pas de BT installé… Mais d’après ce que je vois il faut l’intégration bluetooth_tracker. Voir Bluetooth Tracker - Home Assistant.
Tu as installé ça?

Oui, mais je crois qu’en fait, il n’y a rien à faire, HA à fait apparaitre les périphériques bluetooth à portés, directement dans « Entités »…
OUPS… Désolé…

Merci beaucoup pour ton aide Golfvert

Bonjour,

Tu egayes ma curiosité ,-)

En ajoutant simplement ta clé USB, sans lui donner de chemin dans un quelcobnque fichier, ta clé est reconnue et ca fonctionne ?

C’est bien cela ?

Bonjour Pepite,

Alors, je pensais car 2 de mes appareils étaient remontés avec la notion « source type : bluetooth »…
Mais, par exemple, le smartphone de ma femme ne remonte pas, alors que son bluetooth est bien actif…
Si un PRO passe par là, je veux bien qq éclaircissement.

Merci beaucoup !

Bonjour,

Avez-vous réussi à ajouter le dongle?

Je suis a peu près dans le même cas

  • HA sous une VM ESXI (HA OS)
  • Un RFXCOM branché en usb, fonctionne correctement
  • Clé USB Bluetooth (Sena)

Les 2 clés sont bien ajoutées à ma VM:
image

En ssh sur HA, pas de device bluetooth trouvé via bluetoothctl:
image

Je ne vois pas non plus les périphériques USB (ni même le RFXCOM) via lsusb:
image

Dans le superviseur / host / hardware, je retrouve bien le RFXCOM:
image
Mais rien qui ne correspond à ma clef bluetooth.

J’ai tenté l’intégration native (bluetooth_tracker) avec lajout dans mon config.yaml

device_tracker:
  - platform: bluetooth_tracker

Et également :GitHub - custom-components/ble_monitor: Xiaomi Mijia BLE MiBeacon monitor

Mais rien n’y fait. Une piste à suivre?