Appairage modules impossible avec ConBee2

Bonjour à toutes et à tous,

suite à mon récent passage sous HA, j’ai décidé de passé par Zigbee2MQTT pour gérer mes appareils.
Problème, lorsque j’essaie d’appairer mes modules, aucun d’entre eux n’est détecté.

Pour info, j’ai une clé ConBee2 et les logs n’affichent aucun message d’erreur concernant la configuration.

Si quelqu’un a déjà rencontré ce genre de problème, je serai ravi qu’il m’aguille sur le sujet.

System Health

version core-2021.12.9
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.63-v8
arch aarch64
timezone Europe/Paris
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud failed to load: timeout
Home Assistant Supervisor
host_os Home Assistant OS 7.1
update_channel stable
supervisor_version supervisor-2021.12.2
docker_version 20.10.9
disk_total 55.2 GB
disk_used 4.5 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons Mosquitto broker (6.0.1), Zigbee2mqtt (1.22.2-1), Studio Code Server (4.0.0)
Lovelace
dashboards 1
resources 0
views 1
mode storage

Salut,

Partage ta configuration de Zigbee2mqtt :wink:
Est ce que ta clé est reconnue dans le matériel HA?

Je suis dans la même config que toi.

La clé est correctement reconnu dans HA, pas de problème de ce côté là.
Voici ma configuration de Zigbee2MQTT :

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: true
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://192.168.1.62:1883
  user: MQTT_USER
  password: MQTT_PASSWORD
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2472596-if00
  adapter: deconz
advanced:
  log_level: info
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
  baudrate: 38400
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}
availability: false
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

Bizarre, j’ai exactement la même config que toi…mis à part la partie mqtt où je me liste au base_topic.

Tu es sur un port USB2 ou 3 de ton Pi? Une allonge?

Elle est connectée sur port USB2 avec rallonge

Bizarre…tout semble en ordre.

Quels sont les devices que tu essaye de connecter?

Dans Zigbee2mqtt > Paramètres > A propos, tu vois le firmware de ta Conbee?

Actuellement, ce sont des SONOFF ZBmini que j’essaie d’appairer.
Le firmware de la Conbee était dans sa dernière version. Je suis en train de tester avec la clé SONOFF mais j’ai le même problème, impossible d’appairer…

Salut,
C’est peut-être bête, mais tu autorises l’appairage ?
image

Voici mes logs Zigbee :

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] socat.sh: executing... 
[21:04:17] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing... 
[21:04:18] INFO: MQTT available, fetching server detail ...
[21:04:18] INFO: Previous config file found, checking backup
[21:04:18] INFO: Creating backup config in '/config/zigbee2mqtt/.configuration.yaml.bk'
[21:04:18] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks ...
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[21:04:19] INFO: Handing over control to Zigbee2mqtt Core ...
> zigbee2mqtt@1.22.2 start
> node index.js
Zigbee2MQTT:info  2022-01-19 21:04:25: Logging to console and directory: '/config/zigbee2mqtt/log/2022-01-19.21-04-23' filename: log.txt
Zigbee2MQTT:info  2022-01-19 21:04:25: Starting Zigbee2MQTT version 1.22.2 (commit #unknown)
Zigbee2MQTT:info  2022-01-19 21:04:25: Starting zigbee-herdsman (0.13.188)
Zigbee2MQTT:info  2022-01-19 21:04:26: zigbee-herdsman started (resumed)
Zigbee2MQTT:info  2022-01-19 21:04:26: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20211217,"transportrev":2},"type":"zStack3x0"}'
Zigbee2MQTT:info  2022-01-19 21:04:26: Currently 0 devices are joined:
Zigbee2MQTT:warn  2022-01-19 21:04:26: `permit_join` set to  `true` in configuration.yaml.
Zigbee2MQTT:warn  2022-01-19 21:04:26: Allowing new devices to join.
Zigbee2MQTT:warn  2022-01-19 21:04:26: Set `permit_join` to `false` once you joined all devices.
Zigbee2MQTT:info  2022-01-19 21:04:26: Zigbee: allowing new devices to join.
Zigbee2MQTT:info  2022-01-19 21:04:26: Connecting to MQTT server at mqtt://core-mosquitto:1883
Zigbee2MQTT:info  2022-01-19 21:04:27: Connected to MQTT server
Zigbee2MQTT:info  2022-01-19 21:04:27: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
Zigbee2MQTT:info  2022-01-19 21:04:27: Started frontend on port 0.0.0.0:8099
Zigbee2MQTT:info  2022-01-19 21:04:27: MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"commit":"unknown","coordinator":{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20211217,"transportrev":2},"type":"zStack3x0"},"log_level":"info","network":{"channel":11,"extendedPanID":"0x00124b0024c9ef42","panID":6789},"permit_join":true,"version":"1.22.2"}'
Zigbee2MQTT:info  2022-01-19 21:06:49: Zigbee: disabling joining new devices.
Zigbee2MQTT:info  2022-01-19 21:06:49: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":false},"status":"ok","transaction":"knbca-1"}'
Zigbee2MQTT:info  2022-01-19 21:06:51: Zigbee: allowing new devices to join.
Zigbee2MQTT:info  2022-01-19 21:06:52: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"knbca-2"}'

En revanche, c’est peut-être pas grand chose mais lorsque j’ai suivi le tuto, au moment de l’intégration du broker, il est spécifié de cocher la case « Activer la découverte ». Je n’ai pas cette case d’afficher…

Ben là, il faut regarder dans les logs zigbee…

Voici mes logs Zigbee :

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] socat.sh: executing... 
[21:04:17] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing... 
[21:04:18] INFO: MQTT available, fetching server detail ...
[21:04:18] INFO: Previous config file found, checking backup
[21:04:18] INFO: Creating backup config in '/config/zigbee2mqtt/.configuration.yaml.bk'
[21:04:18] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks ...
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[21:04:19] INFO: Handing over control to Zigbee2mqtt Core ...
> zigbee2mqtt@1.22.2 start
> node index.js
Zigbee2MQTT:info  2022-01-19 21:04:25: Logging to console and directory: '/config/zigbee2mqtt/log/2022-01-19.21-04-23' filename: log.txt
Zigbee2MQTT:info  2022-01-19 21:04:25: Starting Zigbee2MQTT version 1.22.2 (commit #unknown)
Zigbee2MQTT:info  2022-01-19 21:04:25: Starting zigbee-herdsman (0.13.188)
Zigbee2MQTT:info  2022-01-19 21:04:26: zigbee-herdsman started (resumed)
Zigbee2MQTT:info  2022-01-19 21:04:26: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20211217,"transportrev":2},"type":"zStack3x0"}'
Zigbee2MQTT:info  2022-01-19 21:04:26: Currently 0 devices are joined:
Zigbee2MQTT:warn  2022-01-19 21:04:26: `permit_join` set to  `true` in configuration.yaml.
Zigbee2MQTT:warn  2022-01-19 21:04:26: Allowing new devices to join.
Zigbee2MQTT:warn  2022-01-19 21:04:26: Set `permit_join` to `false` once you joined all devices.
Zigbee2MQTT:info  2022-01-19 21:04:26: Zigbee: allowing new devices to join.
Zigbee2MQTT:info  2022-01-19 21:04:26: Connecting to MQTT server at mqtt://core-mosquitto:1883
Zigbee2MQTT:info  2022-01-19 21:04:27: Connected to MQTT server
Zigbee2MQTT:info  2022-01-19 21:04:27: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
Zigbee2MQTT:info  2022-01-19 21:04:27: Started frontend on port 0.0.0.0:8099
Zigbee2MQTT:info  2022-01-19 21:04:27: MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"commit":"unknown","coordinator":{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20211217,"transportrev":2},"type":"zStack3x0"},"log_level":"info","network":{"channel":11,"extendedPanID":"0x00124b0024c9ef42","panID":6789},"permit_join":true,"version":"1.22.2"}'
Zigbee2MQTT:info  2022-01-19 21:06:49: Zigbee: disabling joining new devices.
Zigbee2MQTT:info  2022-01-19 21:06:49: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":false},"status":"ok","transaction":"knbca-1"}'
Zigbee2MQTT:info  2022-01-19 21:06:51: Zigbee: allowing new devices to join.
Zigbee2MQTT:info  2022-01-19 21:06:52: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"knbca-2"}'

En revanche, c’est peut-être pas grand chose mais lorsque j’ai suivi le tuto, au moment de l’intégration du broker, il est spécifié de cocher la case « Activer la découverte ». Je n’ai pas cette case d’afficher…

Cela évolue très vite sur HA et donc les tutos peuvent evoluer mais il ne faut pas hésiter a proposer les changements car nous n’installons pas les add-ons ou autres souvent hihi

C’est pas lié directement à l’appairage, cette partie concerne la remonter des infos via MQTT.

J’hésiterai pas à en faire part alors :wink:

1 « J'aime »

Dans ce cas, je sèche totalement. Surtout que j’ai suivi à la lettre la documentation de Zigbee2MQTT pour installer et configurer l’addon…

Bon, après de multiples tentatives, impossible d’appairer quoi que ce soit.

J’ai donc fait un test en passant par une carte SD au lieu du SSD et là, miracle. Les modules peuvent être appairés…
Allez comprendre pourquoi dans un cas ça fonctionne et pas dans l’autre alors que niveau logiciel, c’est exactement la même configuration.

Oh… ca me rapelle quelque chose… tu peux lire tout le thread avant qu’on reparte dans le debug step by step.
Mais semblerait que mettre sur un port USB2 du PI aiderait…

https://forum.hacf.fr/t/integration-des-modules-zigbee-impossible-sur-le-ssd/8484

2 « J'aime »

Oui, c’est ce que j’avais lu. Je suis en train de faire le test, je verrai bien ce que ça donne.

EDIT : Bon, après le test avec le passage de mon SSD sur un port USB2, cela fonctionne correctement

2 « J'aime »

Salut @Carthage,

Peux-tu me dire si tu as acheté ton raspberry sur une boutique officielle ou si tu es passé par un revendeur divers ? Si possible peux-tu mettre un lien ?

J’avais acheté à l’époque le RPi ainsi que l’alimentation sur la boutique officielle. Ca fait plus d’un an que j’ai acheté tout ça donc pour avoir un lien…