Depuis la manip duckdns, plus d’accès en local à mon iPad et gsm androïd

Mon problème

Bonjour,

Tout est dans le titre.
Via mon pc Windows, jr ne sais plus entrer mon ip ha avec le port seuls, mais je dois absolument ajouter https:// devant . Bon, j’ai tout le tralala concernant un problème de certificat. Mais j’ai lu que c’était normal et j’accède bien à ha.
Par contre, aucune des applications mobiles (iOS et androïd) ne fonctionne. Elles ne veulent pas de l’ip, l’ip avec https devant et le nom de domaine duckdns. Ceci en local.
En 4g, aucun problème. Je me connecte avec mon nom de domaine duckdns et il y a bien un certificat valide.
Avez-vous déjà eu ce genre de problème ?
J’ai lu plein de trucs sur le net mais aucun ne marche.
J’ai besoin, quand je suis chez moi, de pouvoir accéder via le wifi à mon instance ha.
Petite précision qui me laisse perplexe. Quand j’essaye en local avec mon iPad via safari et l’adresse https://192.168.1.2:8123/, j’arrive sur la page d’accueil de ha me demandant de me connecter avec nom et mp. Quand je les rentre (et je suis sûr de ce que je rentre), il me dit « impossible de se connecter ». Et sur mon pc, je vois une notification avec l’adresse ip de mon iPad disant qu’elle a essayé de se connecter avec une authentification invalide…

Merci

Ma configuration


System Health

version core-2021.2.3
installation_type Home Assistant OS
dev false
hassio true
docker true
virtualenv false
python_version 3.8.7
os_name Linux
os_version 5.4.83-v7
arch armv7l
timezone Europe/Brussels
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4939
Installed Version 1.11.3
Stage running
Available Repositories 748
Installed Repositories 5
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud undefined
Hass.io
host_os Home Assistant OS 5.12
update_channel stable
supervisor_version supervisor-2021.03.4
docker_version 19.03.13
disk_total 14.0 GB
disk_used 6.5 GB
healthy true
supported true
board rpi3
supervisor_api ok
version_api ok
installed_addons Samba share (9.3.1), File editor (5.2.0), Terminal & SSH (9.0.2), KNXD daemon (0.4.1), Node-RED (8.1.2), Samba Backup (4.4), InfluxDB (4.0.3), Alsa & PulseAudio Fix (3.4), Let’s Encrypt (4.11.0), Duck DNS (1.12.5), Mosquitto broker (5.1.1), Grafana (6.1.3)
Lovelace
dashboards 1
resources 3
views 7
mode storage

C’est normal car elles ne sont pas aussi permissives que les navigateurs. Donc il faut mettre le ndd dont le certificat certificat correspond.

Si ton routeur supporte le loopback, rien n’empêche de mettre ton ndd…En revanche si le loopback n’est pas supporté, essaie avec un port autre que le 443 (sur livebox, il daut un autre port par exemple).

Bonjour’

Si je met le nom de domaine en utilisant mon wifi, ça ne marche pas…

Comment savoir si mon routeur supporte le loopback?
J’avais lu cette histoire sur d’autres sites et certains conseillaient de mettre 8123 vers 8123 (ouverture de port). Dans le doute, j’ai essayé Mais chez moi, rien n’y fait .

Merci de la réponse

J’ai le même constat que toi, Firefox sur iphone ne veut pas se connecter à HA en https://adresse_ip_locale:8123 (mauvaise authentification) par contre c’est ok via le nom de domaine, avec le wifi connecté. Je n’ai rien fait de spécial hormis rediriger le port 443 vers mon routeur ORBI et l’ORBI vers HA.

Pour ton loopback quel est ton FAI? Regarde dans son forum, ils doivent probablement en parler.

Plus ça va aller et moins l’exception de certificat va être supportée…

N’est ça pas @golfvert ? (de mémoire, t’es le premier à en avoir parlé)

Je confirme… Je prends une analogie pour ces histoires de certificats sur les contrôles d’identité. En gros, un certificat c’est comme une carte d’identité. Quand on veut voter/aller dans un avion (on va bien le refaire un jour)/… on montre sa carte d’identité. Et la personne vérifie que la photo et la personne devant lui sont les mêmes. Là, en utilisant https://@IP:8123 et pas https://mon_domaine:8123 c’est comme si on se présentait avec la carte d’identité de la voisine pour voter. Un scrutateur un minimum attentif dira, non, pas de vote. Là, c’est pareil.
Petit à petit, les systèmes (navigateurs, application,…) sont de plus en plus exigeants et empêchent de se connecter quand la tête (l’url utilisée pour accéder au site) ne correspond pas à la carte d’identité (le certificat).

3 J'aime

Bonjour,

Désolé du retard de ma réponse mais j’essaie d’avancer sur tous les fronts.

En gros, je suis Belge et mon FAI est Proximus. J’ai vérifié, il ne prend pas en charge le loopback.

A un moment, je n’avais carrément plus accès à HA peut importe la méthode. J’ai du me mettre en 4G et le faire refonctionner via mon GSM.

J’ai vu que pour avoir accès via windows à mon nom de domaine en https. Il fallait modifier le fichier HOSTS. Je l’ai fait et ca marche.

Seulement, peut importe l’adresse que je rentre dans les app ou sur le navigateur autant ios que android, rien ne marche. J’ai lu un truc sur ngnix mais c’est pas top non plus.

euh… le top pour moi c’est ✅ Accès de l’extérieur en HTTPS avec Nginx Proxy Manager

Je suis chez orange avec la livebox qui ne gère pas le loopback et grâce à NPM, je peux me connecté à mon HA avec :

  • ha.nom_de_domaine.duckdns.org (en http et https, NPM redirige vers https car il fournit le certificat)
  • http://@ip:8123

DuckDns me sert juste à avoir un nom de domaine et j’utilise l’intégration HA du même nom pour informer le DNS d’un changement d’@ip.

Ne pas oublier de renseigner aussi (dans toutes les configurations, pas forcément celle que je présente) :

  • URL externe
  • URL interne

C’est paramètres se trouvent en bas de page : Open your Home Assistant instance and show your general Home Assistant settings.

Bonjour,

Interessant cette info. Je vais l’essayer demain soir et te redirai quoi.

ha.nom_de_domaine.duckdns.org. Le « ha » tu veux dire ha ou http??? Je ne comprends pas.

Je l’ai fait mais je ne suis pas sur de ce que je devais indiquer pour l’interne. Car sur certains posts (forum anglais), ils disaient qu’il fallait mettre la même que l’externe (NDD). Car sinon, c’est http://IP:8123 ? https://IP:8123 ? IP:8123 ? ou la même chose sans le :8123?
En fait, j’ai fait tellement de test que je ne sais plus car suivant ce que je faisais, un coup c’est une sorte qui marchait, un coup une autre etc.

Merci à toi de l’info

ha c’est un sous-domaine. Comme ici, le forum est forum.hacf.fr :wink:
Pas la peine de mettre http ou https avec nginx… En fait si tu mets rien c’est de base http et tu arrive devant nginx qui te redirige vers le https :+1:

Moi je suis :

  • URL externe : https://ha.nom_de_domaine.duckdns.org
  • URL interne : http://@ip:8123

En fait avec cette solution, sur ton réseau local (wifi, ethernet) ton instance HA n’est pas sécurisé donc accessible sans certificat ni connexion sécurisée, par contre en passant par ha.nom_de_domaine.duckdns.org tu passes par NPM qui sécurise la connexion.

Bonjour,

Je suis en train de regarder pour faire l’installation que tu me proposes.
Juste une petite question: Ils disent qu’il faut MariaDB. Hors, j’ai influxDB de déjà installé. Ca marche aussi?
Sinon, est-ce que ca ne va pas faire double emploi?
Quelle est la différence entre les 2?
InfluxDB, je l’utilise pour Grafana.

Merci

Je n’utilise pas InfluxDB ni Grafana.
Je pense que l’un est l’autre peuvent cohabiter mais je n’ai pas du tout creusé la question.

Bonjour,

Sais-tu m’aider?

Je suis presque à la fin du tuto sans problème mais au moment du: Request a new SSL Certificat
Ca foire. J’ai: internal error sans plus d’explication.

Une idée?

As-tu bien redirigé les ports 80 et 443 vers ta machine hébergé NPM ?

J’ai installé l’addon sur HA
Sur mon routeur, j’ai fait ca: 80 vers 8123 sur l’adresse 192.168.1.2 (HA)
Pareil pour le 443

C’est juste?

Vu que c’est pour la création de let’s encrypt qui pose problème mais que duckdnd en crée un aussi, ce ne serait pas là le problème?
J’ai regardé les logs de Nginx mais je ne les comprends pas…

Appuie sur ce bouton pour ouvrir une demande d’entraide concernant l’article NPM :

Besoin d’aide ? Cliquez ici !

Et reprends les explications de ton problème :+1: