Détecteur de mouvement et coupure lumière

Bonjour à tous !!!

Je viens de recevoir mon détecteur de mouvement PIR connecté en wifi sur tuya, et je voudrais savoir s’il est possible d’utiliser le détecteur de mouvement pour lui faire éteindre une lumière si il ne détecte rien (car c’est pas Versailles ici !!!), car j’ai regardé pour faire une automatisation mais déjà je ne trouve pas mon détecteur dans HA intégrations tuya il y a que mes ampoules et via l’appli tuya je n’arrive pas à lui faire ce que je veux, donc besoin d’aide pour savoir si c’est possible.
Merci d’avance pour votre aide

C’est ça le problème du coup…non ?

As tu rechargé l’integration pour faire apparaître les nouveaux appareils (ça force l’interrogation qui est toutes les 5min de mémoire):

integrations (1)

Salut @Clemalex, j’ai fais ce que tu as dis « rechargé l’intégration » et toujours rien, je rentre demain et je vais réinstaller le détecteur pour voir.
Je te tiens au jus
Merci

Bonsoir tout le monde, je viens de réinstaller mon détecteur et il ne remonte pas sur HA :upside_down_face: pourquoi je suis toujours emmerdé :weary: , car du coup je ne peut pas faire ce que je veux, je ne comprends pas pourtant il fonctionne bien me détecte bien m’averti mais pas HA ne l’intègre pas…
Help me !!!

Je ne veux pas dire de bêtise car je n’ai pas d’appareil Tuya.

Mais je ne vois pas de détecteur PIR sur la page d’intégration: Tuya - Home Assistant

Salut @clement et merci je comprends mieux alors, j’avais même pas vu que l’intégration tuya ne prennait pas tout en charge, pour moi tout ce qui était détecté par tuyau serai transmit à HA, bon j’ai plus qu’à trouver d’autre détecteur, je pense plus à du sonoff ?

Bonsoir, tout le monde vous me conseillez quoi comme détecteur de mouvement pour qu’il soit reconnue par HASSIO ?
Merci

Moi j’ai des détecteurs de marque Xiaomi qui fonctionnent parfaitement.
Par contre, ils détectent les animaux, l’aspirateur, etc.

ok super merci @Clemalex

Plus cher et il faut un protocole réseau en plus, les yeux zwave de fibaro Fibaro Motion Sensor FGMS-001-ZW5 - Détecteur de mouvements, luminosité, température, sans-fil Z-Wave+ - www.domotique-store.fr
J’en ai 4 depuis 4 ou 5 ans et ça marche vraiment bien. Et on peut régler la sensibilité et donc le chat ou l’aspirateur ne déclenche pas.

Bonjour à tous !!!
Je relance le topic, pour faire un test j’ai un capteur de mouvement en 433mhz, j’ai une antenne rflink brancher sur mon raspberry contenant HA , j’ai son id via RFLink loader, mais je ne vois pas comment l’utiliser avec HA, pour en revenir au début je voudrais faire :
_ si ma lumière est allumé et que mon détecteur de mouvement en 433 ne détecte rien au bout de 5 minutes que ça éteigne la lumière.
Merci d’avance pour vos réponses

Je corrige j’ai trouvé mon détecteur de mouvement et il fonctionne sous HA il apparait comme une lampe quand je la désactive et que je passe devant le détecteur elle s’allume ouf !!! donc maintenant il me faut faire une automatisation pour lui dire si tu ne détectes rien pendant 5 minutes éteint la lumière, cool ça avance :kissing_smiling_eyes:
edit: dans ma tête je vois les choses comme ça … mais à transcrire en numérique c’est autre chose
Si ma lumière est allumé et que le détecteur me vois il ne se passe rien par contre si ma lumière est allumé et que le détecteur ne me vois plus au bout de 5 minutes éteindre la lumière

automation:
  trigger:
    - platform: state
      entity_id: light.detecteur_de_mouvement
      to: "off"
      for: "00:05:00"

Avec une condition sur la lampe et une action d’extinction

@Clemalex je ne comprends pas trop je dois le mettre dans config.yaml ou automation.yaml ?

Tu n’as pas à toucher à ce fichier, il est géré par l’interface graphique.

Tu passe directement par l’interface graphique (sauf si tu as changé de configuration) :

Dans l’exemple, light.ceiling_lights est ton détecteur et light.bed_light la lumière à éteindre

alias: 'Plus de mouvement '
description: ''
trigger:
  - platform: state
    entity_id: light.ceiling_lights
    to: 'off'
    for: '00:05:00'
condition:
  - condition: state
    entity_id: light.bed_light
    state: 'on'
action:
  - service: light.turn_off
    target:
      entity_id: light.bed_light
  - service: persistent_notification.create
    data:
      message: Extinction de la lampe extérieure
      title: Lumières
mode: single

@Clemalex magnifique le tuto c’est exactement ce qu’il me faut pour que je comprenne , je le mets avec mes éléments et je te tiens au jus je vais baisser le temps du off pour aller plus vite en tout cas merci

Bon super facile à reproduire avec ton tuto, mais comme d’hab je dois avoir un truc qui merde car ça reste allumé si je fais dans automasation execute ça s’éteint,
Voici mon auto

alias: Pas de mouvement
description: ''
trigger:
  - platform: state
    entity_id: light.ev1527_05a5b9_0a
    to: 'off'
    for: '00:01:00'
condition:
  - condition: state
    entity_id: switch.bf655eaa274bfb6325caqm
    state: 'on'
action:
  - service: light.turn_off
    target:
      entity_id: switch.bf655eaa274bfb6325caqm
  - service: persistent_notification.create
    data:
      message: Extinction de la lampe extérieure
      title: Lumières
mode: single

Je viens de voir une erreur que je viens de corriger

alias: Pas de mouvement
description: ''
trigger:
  - platform: state
    entity_id: light.ev1527_05a5b9_0a
    to: 'off'
    for: '00:01:00'
condition:
  - condition: state
    entity_id: switch.bf655eaa274bfb6325caqm
    state: 'on'
action:
  - service: switch.turn_off
    target:
      device_id: f9d2367a693ca8a522b23e22ec0b8ead
  - service: persistent_notification.create
    data:
      message: Extinction de la lumière salle de bain
      title: Lumières
mode: single

mais ça reste toujours allumé et quand je fais execute rien

j’ai rajouté sous device_id

entity_id: switch.bf655eaa274bfb6325caqm

ça reste toujours allumé mais si je fais execute ça s’éteint
je me demande si le détecteur est bien pris en compte, pourtant j’ai créé un bouton dans lovelance et quand je passe devant le détecteur le bouton s’active par contre il reste actif est-ce normal je ne sais pas

nouveau test plus simple pour savoir si le détecteur fonctionne

alias: Nouvelle automatisation
description: ''
trigger:
  - platform: state
    entity_id: light.ev1527_05a5b9_0a
    to: 'on'
condition: []
action:
  - service: switch.turn_on
    target:
      device_id: f9d2367a693ca8a522b23e22ec0b8ead
      entity_id: switch.bf655eaa274bfb6325caqm
mode: single

par contre il faut que mon bouton soit désactivé pour que cela fonctionne et comme il ne revient pas tout seul ça fonctionne qu’une fois :sweat_smile: