DuckDNS bloqué lors de l'installation

Bonjour à tous,

J’ai installé DuckDns en suivant le tutoriel de Paradis artificiel. Je suis arrivé jusqu’à l’étape du restart de HA mais maintenant impossible d’y rentrer autant avec l’ip 8123 autant avec mon nom de domaine. J’ai dû faire une erreur lors de l’étape de Configurator.
image

Je n’avais pas toutes les entrées comme lui il a j’ai donc ajouter a la suite des entrées:
config:
http:
base_url: my-domain.duckdns.org:8123
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

et après j’ai redémarré mais la plus possible de rentrer. Heureusement j’avais mis Samba et je vais sur l’ordi sous config/home assistant.log et la je vois cela:

Capture d’écran 2020-11-28 à 15.33.49

Ensuite j’ai été sous config/configuration yaml, enlevé le test ci-dessus mais ça n’a rien changé je n’arrive toujours pas à rentrer sous HA.

Please Help :slight_smile:

en complément voici ce que j’ai maintenant sous configuration yaml (je viens de commencer)

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Tu te connectes en https ou http ?

Pour appuyer la question de @Sylvain_G :

L’installation de l’addon DuckDNS ne signifie pas que la connexion est sécurisée et donc les ajouts des balises ssl_certificate et ssl_key ne doivent pas être présentes.

Ces 2 balises doivent être présente si tu ajoute l’addon Let's Encrypt.

Pour finir, je te conseille de tout reprendre et de suivre ce tutoriel, plus récent.

PS : Une petite présentation ? (#communaute:presentations)

Hello,
Merci pour vos retours.
Je viens de me présenter comme recommandé :slight_smile:

Je vais reprendre et suivre le tutoriel indiqué ci-dessus mais pour cela pouvez vous m’aider à régler mes bêtises? car je ne peux plus rentrer sur HA ni avec nom de domaine.duckdns.org:8123 ni avec 192.162.1.xxx.

Dois-je nécéssairement formater ma sd et recommencer?

Est ce que tu tape http://@ip ou https://?

Car si tu as activé la connexion sécurisée (avec les balises ssl), il faut maintenant taper https://.

Tu peux aussi enlever de ton fichier de configuration toute la partie http (si tu as ajouter l’addon Samba.

J’ai essayé les deux mais pas moyen d’entrer. J’ai enlevé le texte dans samba configuration yaml
http:
base_url: my-domain.duckdns.org:8123
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

mais ça change rien toujours pas d’accès.

il reste maintenant les lignes suivante sur configuration yaml:

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Fait voir le contenu du fichier home-assistant.log en épurant les données personnelles.

utilise le triple ``` (accent grave) pour insérer du code…

```
Code formaté automatiquement ici
```

Dans le fichier home-assistant.log j’ai que ça:

020-11-28 10:54:38 WARNING (MainThread) [homeassistant.components.http] The ‹ base_url › option is deprecated, please remove it from your configuration

j’ai réussis à rentrer sur HA avec https://192.168.1.xxx:8123

Je vais maintenant recommencer en désinstallant DuckDns et refaire cela avec le tutoriel plus récent que tu as mentionné ci-dessus.

Un message a été fusionné à un sujet existant : Accès depuis l’extérieur avec DuckDNS

Poste directement à la suite sur le forum