Fibaro Roller Shutter 3 - Pas de retour de position

Bonjour,

(précision, je suis nouveau sur Hass, je découvre le concept des entités)
J’ai un module Fibaro Roller Shutter 3 installer pour contrôler un volet roulant.
Il fonctionne bien, je peux contrôler le volet depuis Hass.

L’appareil dispose de plusieurs entités.
Toutefois, (hormis les deux premières), toutes les autres entités ne changent pas même si le volet est en mouvement.
J’avais réussi a « l’appairer » avec Zwave (mais déprécié) et je pouvais voir différents paramètres avec les valeurs de configuration possible. (lister dans la doc ici : Roller Shutter 3 | FIBARO Manuals)
Avec ZwaveJS, je n’ai plus cette possibilité.

Je ne peux donc pas s’avoir depuis Hass si le volet est ouvert ou fermé, quel est sa position exacte, etc.
Comment doit-on faire pour avoir cette information ?

Également, des documentations existe-t-elle pour savoir a quoi correspondent chacune des entités ?

Merci

Liste des entités du module Fibaro

  • cover.roller_shutter_3_current_value => Permet d’afficher la flèche vers le haut, le bas et le bouton stop.
  • sensor.roller_shutter_3_electric_consumed_w => Fonctionne quand le volet est en fonctionnement
  • sensor.roller_shutter_3_electric_consumed_kwh => Fonctionne quand le volet est en fonctionnement
  • binary_sensor.roller_shutter_3_power_management_over_current_detected => Reste tout le temps en inactif
  • sensor.roller_shutter_3_power_management_over_current_status => Reste tout le temps en inconnu
  • sensor.roller_shutter_3_system_hardware_status => Reste tout le temps en inconnu
  • binary_sensor.roller_shutter_3_system_system_hardware_failure_with_failure_code => Reste tout le temps en inactif
  • sensor.roller_shutter_3_alarmlevel => Reste tout le temps en inconnu
  • sensor.roller_shutter_3_alarmtype => Reste tout le temps en inconnu

Configuration :

  • Raspberry Pi 4B 4Go
  • SSD 120Go connected on USB3.0
  • Home Assistant OS 2021.2.3
  • Clé Zwave Aeotec Z-stick Gen5+

Up du sujet.
Des idées svp ?
Merci

A tu essayé une autre intégration Zwave ?

Car ZwaveJS est jeune et pas encore complet…

Non, comme le volet fonctionne avec ZWaveJS, je n’ai pas regardé sur l’ancienne version qui est depreciée. Je pensais partir sur la nouvelle pour ne pas avoir a refaire toute la config si je passe sur l’ancienne et ensuite revenir a la nouvelle dans quelques mois.

Bonjour;

il te faut obligatoirement installer zwavejstomqtt car c’est le seul à avoir un panneau de contrôle.

Donc tu stop zwaveJS et tu installe/configure/lance zwavejstomqtt (la configuration est la même que sur zwaveJS)

tu ouvre le web UI de zwavejstomqtt et tu pourras calibrer le volet, tu dois modifier la valeur 150 (1 octet) « Calibration du volet » à deux et cliquer sur le triangle bleu juste à coté
Le volet va se fermer/ouvrir pour se calibrer et c’est bon à partir de la
à se moment la, du stop zwavejstomqtt et tu lance zwaveJS ton volet sera calibrer et opérationnel :wink:

1 J'aime

Bonsoir
@TheD6Bel

Le volet est déjà fonctionnel sous ZwaweJS. La calibration s’est bien passée et je peux ouvrir, fermer et stopper le volet roulant avec les flêches et le bouton stop.
Le soucis vient du fait que sur ZwaveJS, je n’ai pas de retour de position du volet et les entités (voir message initial) ne change pas de statut.
Donc pour faire des automatisations ce n’est pas du tout pratique de ne pas connaître la position actuelle du volet et de ne pas pouvoir demander a le fermer a 50% par exemple.

Voici ce que j’ai sur mon dashboard
volet

Contrôle quand même le réglage 150 et vérifie quel chiffre est configuré, si tu vois 0 c’est qu’il n’est pas calibré, si tu vois un 1 c’est qu’il est calibré et dans le doute relance une calibration

J’ai installé il y a une semaine exactement la même configuration chez mon père et j’ai du lancer la calibration manuellement même si elle c’est faite a la première mise en route (enfin le deuxième module seulement)

J’ai remarqué le problème car j’ai installé une intégration depuis HACS qui te permet d’ouvrir ton volet au pourcentage que tu veux, et le volet ne faisait que s’ouvrir ou de fermer sans jamais stopper ou j’ai demandé

Après la calibration c’était niquel :slight_smile:

Le nom c’est Shutter Card :wink:

Edit:

Je viens de contrôler et j’ai pas d’entités pour le pourcentage en plus de toi juste une deuxième entité volet en plus