Ha supervised ne redemarre pas 😭

Hello,
Pff… Décidément mon HA supervised n’aime pas les redémarrages de mon pi :confused: c’était plutôt stable depuis longtemps mais là il semble ne pas arriver à lancer le container hassio_supervisor

J’ai beau faire un sudo docker start - ai hassio_supervisor ça démarre mais ça saute très rapidement. :disappointed:

Savez-vous ce que je dois faire pour retrouver HA ? :sob:

Salut,

Reinstalle HA par dessus (sans rien toucher). Profites-en pour mettre à jour l’os et l’installer en .deb…
ça va reprendre la config existante donc rien n’est perdu

Aïe je suis dans la panade : il ne veut tout simplement plus l’installer docker.
Je l’ai desinstaller auparavant, j’ai aussi fait un apt-get upgrade, mais il n’a pas voulu non plus aller jusqu’au bout :sob:
Pas vraiment envie de relancer l’installation de raspberry os (j’ai plein de choses installées :confused:)

C’était pas l’idée du siècle…
Non seulement tu es coincé mais la desinstallation de docker va avoir pour effet de détruire les volumes. Du coup la méthode décrite au dessus n’est plus garantie de fonctionner…
J’espère que tu as un backup dans un coin… Tu es probablement bon repartir de 0

Hello,

Oui j’ai un backup HA.
Mais Pff… Reinstall du pi :sob:
Au début je n’avais pas supprimé docker au début, j’avais déjà rencontré l’erreur dpkg
Ça me désespère

Essaye ça avant de rebooter, et de relancer l’installation de docker :

apt-get clean && apt-get -y update && apt-get -y upgrade && apt-get -y dist-upgrade && apt-get -y auto-clean && apt-get -y autoremove

Et peu importe la fin de la reinstallation de docker, verifie s’il est pas là quand même :

docker ps

Cette commande bloque sur la même erreur dpkg code 2 :sob:


Le fichier zenity est vide et sans propriétaire, et je ne vois rien sur le net en rapport avec cela :sob:

Zenity c’est pour de l’affichage graphique… Franchement sur un serveur on s’en f***, un interface texte c’est exactement comme ce que tu fais là avec xterm… En plus ça bouffe des ressources qui pourraient être utilisées pour autre chose.
Plus on ajoute de trucs qui ne sont pas indispensables (y compris les trucs pas domotiques), plus c’est compliqué à remettre en place.
ça va piquer un peu, mais tu gagnera à faire une installation propre à mon avis

EDIT : au passage quitte à exploiter un terminal graphique, profites-en pour le faire à distance, tu auras la possibilité de faire du copié/collé et de la capture d’écran

1 « J'aime »

Pff OK @Pulpy-Luke merci pour tes conseils.

Faut que je laisse ma déception, mais je me demande comment éviter de retrouver dans quelques mois ces déboires : se passer de docker ? Donc migrer par exemple de home assistant à home assistant os ? Mais :
1- est-ce que le supervisor est présent dans home assistant os ? Il me semble que oui
2- est-ce que la récupération de mon snapshot pourra se faire sans pb ? Là j’ai un doute :thinking: c’est possible ?
3- ça veut dire que je dedie un nouveau pi à home assistant et que je dois faire communiquer HA ave les 3 applications domotiques que j’avais sur mon pi supervised : fhem (mqtt) , motioneye et homebridge. J’espère que ça peut le faire
Bref un projet réaliste ?

J’ai pas bien d’idée du souci (sans log c’est mort pour trouver une piste), mais c’est certainement pas docker en soit la cause… Au contraire, c’est à mon avis mieux et bien plus souple que faire une installation HA OS
Docker c’est juste une couche intermédiaire. Et puis HA OS pour le coup, c’est light de chez light : c’est sûr tu n’aura pas de session graphique là dessus.
Doncje réponds pas à tes questions mais ça soulève des interrogations par rapport à ton besoin :

  • 1 => As-tu bien en tête à quoi sert le supervisor ? C’est pas fondamental pour avoir HA mais c’est structurant pour le choix et si tu poses la question pour HA OS, alors je pense qu’il te manque des infos
  • 2 => Quelque soit le type d’installation, il y a une méthode backup. Là encore c’est dans le concept de HA
  • 3 => Pas forcement, en tout cas, avec du docker, tu peux mixer (même si j’aime pas) mais avec HA OS, tu va souffrir.

Bref, (re)jette un oeil là ça va éclaircir le sujet https://forum.hacf.fr/t/conseils-sur-le-choix-methode-ou-type-dinstallation/2068

PS : j’ai pas vu le résultat de la commande docker ps :innocent: Ni le fait d’avoir rebooté

1 « J'aime »

Dernier espoir avant de repartir de 0, reconstituer la base des packages…
Voir https://www.malekal.com/resoudre-les-problemes-ou-erreurs-installation-de-paquet-dpkg/#Code_derreur_1_ou_2_ou_100:

sudo dpkg ––configure –a
sudo apt install -f
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update

Et le problème n’a rien à voir avec docker.
C’est sans doute l’arrêt brutal qui a corrompu le fichier de config des packages.

1 « J'aime »

Tu es sur une carte SD ?

1 « J'aime »

Hello ,
Pour répondre à vos questions :

@McFly non, j’ai installé Raspberry OS puis HA supervised sur SSD

@golfvert j’ai joué les commandes qui se sont bien déroulé dans l’ensemble (il a quand fallu que je passe en sudo su - pour qu’il reconnaisse la 1ère commande, mais une fois ceci déroulé, le curl docker abouti à la même erreur E: Sub-process /usr/bin/dpkg returned an error code (2) :frowning:

@Pulpy-Luke j’ai déroulé ton processus et :

  1. les commandes apt-get... ont été avortées au moment de passer aux upgrade avec la même errreur ``E: Sub-process /usr/bin/dpkg returned an error code (2)```
  2. je reboote quand même fait un curl docker… et rebelotte E: Sub-process /usr/bin/dpkg returned an error code (2)
  3. du coup, docker ps donne -bash: docker : commande introuvable :frowning:

En effet conclusion hâtive de ma part, le pb dpkg n’a donc rien à voir avec un souci dockr :frowning:

Ca me fout un coup au moral car ça me prend du temps de tout réinstaller; j’ai commencé la fois précédente à me lister toutes les étapes (HA, fhem, wifi scan, enable_uart… motioneye, homebridge…) pour éviter de perdre du temps en recherche (mais par exemple l’os-agent du raspberry j’avais pas noté et je me suis planté hier d’os-agent avant de basculer sur l’armv7); bref je vais repartir sur la réinstall propre du pi

Je ne peux que te conseiller de faire une image complète de ton disque que tu pourras réinstaller facilement si tu as un blocage suite à une mise à jour.
Même sur une carte SD, comme ça cela ne prend que quelques minutes à remettre en route et tu as tout le temps qui faut pour comprendre le problème.

Mais je suis sûr que tu y a déjà pensé pour l’avenir ;o)

Hello @Mourakami

Oui j’y ai déjà pensé depuis longtemps, mais mes recherches pour faire une copie intégrale (voire incrementale) en « plug and play » d’un ssd sur un autre ssd se sont révélées infructueuses. Je vois des solutions logicielles sur le net dont j’ai expérimenté certaines mais rien de probant.
Si tu as une solution de clonage je suis preneur :thinking::wink:

Normalement avec Win32 Disk Imager cela devrait le faire.

1 « J'aime »

un coup de clonezilla également fonctionne très bien :+1:

1 « J'aime »